Журнал лабораторных работ

Содержание

Журнал

Вторник (12/18/12)

/dev/pts/0
15:38:58
#Set to YES to suppress rule display

15:38:58
#Set to YES to suppress rule display

15:38:58
#Set to YES to suppress rule display

15:38:58
#Set to YES to suppress rule display

15:38:58
#Set to YES to suppress rule display

15:38:58
#Set to YES to suppress rule display

15:38:58
#Set to YES to suppress rule display

15:38:58
#Set to YES to suppress rule display

15:43:39
#ipfw -h
ipfw syntax summary (but please do read the ipfw(8) manpage):
        ipfw [-abcdefhnNqStTv] <command>
where <command> is one of the following:
add [num] [set N] [prob x] RULE-BODY
{pipe|queue} N config PIPE-BODY
[pipe|queue] {zero|delete|show} [N{,N}]
nat N config {ip IPADDR|if IFNAME|log|deny_in|same_ports|unreg_only|reset|
                reverse|proxy_only|redirect_addr linkspec|
                redirect_port linkspec|redirect_proto linkspec}
set [disable N... enable N...] | move [rule] X to Y | swap X Y | show
...
OPTION: bridged | diverted | diverted-loopback | diverted-output |
        {dst-ip|src-ip} IPADDR | {dst-ip6|src-ip6|dst-ipv6|src-ipv6} IP6ADDR |
        {dst-port|src-port} LIST |
        estab | frag | {gid|uid} N | icmptypes LIST | in | out | ipid LIST |
        iplen LIST | ipoptions SPEC | ipprecedence | ipsec | iptos SPEC |
        ipttl LIST | ipversion VER | keep-state | layer2 | limit ... |
        icmp6types LIST | ext6hdr LIST | flow-id N[,N] | fib FIB |
        mac ... | mac-type LIST | proto LIST | {recv|xmit|via} {IF|IPADDR} |
        setup | {tcpack|tcpseq|tcpwin} NN | tcpflags SPEC | tcpoptions SPEC |
        tcpdatalen LIST | verrevpath | versrcreach | antispoof
15:43:39
#ipfw -h
ipfw syntax summary (but please do read the ipfw(8) manpage):
        ipfw [-abcdefhnNqStTv] <command>
where <command> is one of the following:
add [num] [set N] [prob x] RULE-BODY
{pipe|queue} N config PIPE-BODY
[pipe|queue] {zero|delete|show} [N{,N}]
nat N config {ip IPADDR|if IFNAME|log|deny_in|same_ports|unreg_only|reset|
                reverse|proxy_only|redirect_addr linkspec|
                redirect_port linkspec|redirect_proto linkspec}
set [disable N... enable N...] | move [rule] X to Y | swap X Y | show
...
OPTION: bridged | diverted | diverted-loopback | diverted-output |
        {dst-ip|src-ip} IPADDR | {dst-ip6|src-ip6|dst-ipv6|src-ipv6} IP6ADDR |
        {dst-port|src-port} LIST |
        estab | frag | {gid|uid} N | icmptypes LIST | in | out | ipid LIST |
        iplen LIST | ipoptions SPEC | ipprecedence | ipsec | iptos SPEC |
        ipttl LIST | ipversion VER | keep-state | layer2 | limit ... |
        icmp6types LIST | ext6hdr LIST | flow-id N[,N] | fib FIB |
        mac ... | mac-type LIST | proto LIST | {recv|xmit|via} {IF|IPADDR} |
        setup | {tcpack|tcpseq|tcpwin} NN | tcpflags SPEC | tcpoptions SPEC |
        tcpdatalen LIST | verrevpath | versrcreach | antispoof
15:43:39
#ipfw -h
ipfw syntax summary (but please do read the ipfw(8) manpage):
        ipfw [-abcdefhnNqStTv] <command>
where <command> is one of the following:
add [num] [set N] [prob x] RULE-BODY
{pipe|queue} N config PIPE-BODY
[pipe|queue] {zero|delete|show} [N{,N}]
nat N config {ip IPADDR|if IFNAME|log|deny_in|same_ports|unreg_only|reset|
                reverse|proxy_only|redirect_addr linkspec|
                redirect_port linkspec|redirect_proto linkspec}
set [disable N... enable N...] | move [rule] X to Y | swap X Y | show
...
OPTION: bridged | diverted | diverted-loopback | diverted-output |
        {dst-ip|src-ip} IPADDR | {dst-ip6|src-ip6|dst-ipv6|src-ipv6} IP6ADDR |
        {dst-port|src-port} LIST |
        estab | frag | {gid|uid} N | icmptypes LIST | in | out | ipid LIST |
        iplen LIST | ipoptions SPEC | ipprecedence | ipsec | iptos SPEC |
        ipttl LIST | ipversion VER | keep-state | layer2 | limit ... |
        icmp6types LIST | ext6hdr LIST | flow-id N[,N] | fib FIB |
        mac ... | mac-type LIST | proto LIST | {recv|xmit|via} {IF|IPADDR} |
        setup | {tcpack|tcpseq|tcpwin} NN | tcpflags SPEC | tcpoptions SPEC |
        tcpdatalen LIST | verrevpath | versrcreach | antispoof
15:43:39
#ipfw -h
ipfw syntax summary (but please do read the ipfw(8) manpage):
        ipfw [-abcdefhnNqStTv] <command>
where <command> is one of the following:
add [num] [set N] [prob x] RULE-BODY
{pipe|queue} N config PIPE-BODY
[pipe|queue] {zero|delete|show} [N{,N}]
nat N config {ip IPADDR|if IFNAME|log|deny_in|same_ports|unreg_only|reset|
                reverse|proxy_only|redirect_addr linkspec|
                redirect_port linkspec|redirect_proto linkspec}
set [disable N... enable N...] | move [rule] X to Y | swap X Y | show
...
OPTION: bridged | diverted | diverted-loopback | diverted-output |
        {dst-ip|src-ip} IPADDR | {dst-ip6|src-ip6|dst-ipv6|src-ipv6} IP6ADDR |
        {dst-port|src-port} LIST |
        estab | frag | {gid|uid} N | icmptypes LIST | in | out | ipid LIST |
        iplen LIST | ipoptions SPEC | ipprecedence | ipsec | iptos SPEC |
        ipttl LIST | ipversion VER | keep-state | layer2 | limit ... |
        icmp6types LIST | ext6hdr LIST | flow-id N[,N] | fib FIB |
        mac ... | mac-type LIST | proto LIST | {recv|xmit|via} {IF|IPADDR} |
        setup | {tcpack|tcpseq|tcpwin} NN | tcpflags SPEC | tcpoptions SPEC |
        tcpdatalen LIST | verrevpath | versrcreach | antispoof
15:43:39
#ipfw -h
ipfw syntax summary (but please do read the ipfw(8) manpage):
        ipfw [-abcdefhnNqStTv] <command>
where <command> is one of the following:
add [num] [set N] [prob x] RULE-BODY
{pipe|queue} N config PIPE-BODY
[pipe|queue] {zero|delete|show} [N{,N}]
nat N config {ip IPADDR|if IFNAME|log|deny_in|same_ports|unreg_only|reset|
                reverse|proxy_only|redirect_addr linkspec|
                redirect_port linkspec|redirect_proto linkspec}
set [disable N... enable N...] | move [rule] X to Y | swap X Y | show
...
OPTION: bridged | diverted | diverted-loopback | diverted-output |
        {dst-ip|src-ip} IPADDR | {dst-ip6|src-ip6|dst-ipv6|src-ipv6} IP6ADDR |
        {dst-port|src-port} LIST |
        estab | frag | {gid|uid} N | icmptypes LIST | in | out | ipid LIST |
        iplen LIST | ipoptions SPEC | ipprecedence | ipsec | iptos SPEC |
        ipttl LIST | ipversion VER | keep-state | layer2 | limit ... |
        icmp6types LIST | ext6hdr LIST | flow-id N[,N] | fib FIB |
        mac ... | mac-type LIST | proto LIST | {recv|xmit|via} {IF|IPADDR} |
        setup | {tcpack|tcpseq|tcpwin} NN | tcpflags SPEC | tcpoptions SPEC |
        tcpdatalen LIST | verrevpath | versrcreach | antispoof
15:43:39
#ipfw -h
ipfw syntax summary (but please do read the ipfw(8) manpage):
        ipfw [-abcdefhnNqStTv] <command>
where <command> is one of the following:
add [num] [set N] [prob x] RULE-BODY
{pipe|queue} N config PIPE-BODY
[pipe|queue] {zero|delete|show} [N{,N}]
nat N config {ip IPADDR|if IFNAME|log|deny_in|same_ports|unreg_only|reset|
                reverse|proxy_only|redirect_addr linkspec|
                redirect_port linkspec|redirect_proto linkspec}
set [disable N... enable N...] | move [rule] X to Y | swap X Y | show
...
OPTION: bridged | diverted | diverted-loopback | diverted-output |
        {dst-ip|src-ip} IPADDR | {dst-ip6|src-ip6|dst-ipv6|src-ipv6} IP6ADDR |
        {dst-port|src-port} LIST |
        estab | frag | {gid|uid} N | icmptypes LIST | in | out | ipid LIST |
        iplen LIST | ipoptions SPEC | ipprecedence | ipsec | iptos SPEC |
        ipttl LIST | ipversion VER | keep-state | layer2 | limit ... |
        icmp6types LIST | ext6hdr LIST | flow-id N[,N] | fib FIB |
        mac ... | mac-type LIST | proto LIST | {recv|xmit|via} {IF|IPADDR} |
        setup | {tcpack|tcpseq|tcpwin} NN | tcpflags SPEC | tcpoptions SPEC |
        tcpdatalen LIST | verrevpath | versrcreach | antispoof
15:43:39
#ipfw -h
ipfw syntax summary (but please do read the ipfw(8) manpage):
        ipfw [-abcdefhnNqStTv] <command>
where <command> is one of the following:
add [num] [set N] [prob x] RULE-BODY
{pipe|queue} N config PIPE-BODY
[pipe|queue] {zero|delete|show} [N{,N}]
nat N config {ip IPADDR|if IFNAME|log|deny_in|same_ports|unreg_only|reset|
                reverse|proxy_only|redirect_addr linkspec|
                redirect_port linkspec|redirect_proto linkspec}
set [disable N... enable N...] | move [rule] X to Y | swap X Y | show
...
OPTION: bridged | diverted | diverted-loopback | diverted-output |
        {dst-ip|src-ip} IPADDR | {dst-ip6|src-ip6|dst-ipv6|src-ipv6} IP6ADDR |
        {dst-port|src-port} LIST |
        estab | frag | {gid|uid} N | icmptypes LIST | in | out | ipid LIST |
        iplen LIST | ipoptions SPEC | ipprecedence | ipsec | iptos SPEC |
        ipttl LIST | ipversion VER | keep-state | layer2 | limit ... |
        icmp6types LIST | ext6hdr LIST | flow-id N[,N] | fib FIB |
        mac ... | mac-type LIST | proto LIST | {recv|xmit|via} {IF|IPADDR} |
        setup | {tcpack|tcpseq|tcpwin} NN | tcpflags SPEC | tcpoptions SPEC |
        tcpdatalen LIST | verrevpath | versrcreach | antispoof
15:43:39
#ipfw -h
ipfw syntax summary (but please do read the ipfw(8) manpage):
        ipfw [-abcdefhnNqStTv] <command>
where <command> is one of the following:
add [num] [set N] [prob x] RULE-BODY
{pipe|queue} N config PIPE-BODY
[pipe|queue] {zero|delete|show} [N{,N}]
nat N config {ip IPADDR|if IFNAME|log|deny_in|same_ports|unreg_only|reset|
                reverse|proxy_only|redirect_addr linkspec|
                redirect_port linkspec|redirect_proto linkspec}
set [disable N... enable N...] | move [rule] X to Y | swap X Y | show
...
OPTION: bridged | diverted | diverted-loopback | diverted-output |
        {dst-ip|src-ip} IPADDR | {dst-ip6|src-ip6|dst-ipv6|src-ipv6} IP6ADDR |
        {dst-port|src-port} LIST |
        estab | frag | {gid|uid} N | icmptypes LIST | in | out | ipid LIST |
        iplen LIST | ipoptions SPEC | ipprecedence | ipsec | iptos SPEC |
        ipttl LIST | ipversion VER | keep-state | layer2 | limit ... |
        icmp6types LIST | ext6hdr LIST | flow-id N[,N] | fib FIB |
        mac ... | mac-type LIST | proto LIST | {recv|xmit|via} {IF|IPADDR} |
        setup | {tcpack|tcpseq|tcpwin} NN | tcpflags SPEC | tcpoptions SPEC |
        tcpdatalen LIST | verrevpath | versrcreach | antispoof
15:43:39
#ipfw -h
ipfw syntax summary (but please do read the ipfw(8) manpage):
        ipfw [-abcdefhnNqStTv] <command>
where <command> is one of the following:
add [num] [set N] [prob x] RULE-BODY
{pipe|queue} N config PIPE-BODY
[pipe|queue] {zero|delete|show} [N{,N}]
nat N config {ip IPADDR|if IFNAME|log|deny_in|same_ports|unreg_only|reset|
                reverse|proxy_only|redirect_addr linkspec|
                redirect_port linkspec|redirect_proto linkspec}
set [disable N... enable N...] | move [rule] X to Y | swap X Y | show
...
OPTION: bridged | diverted | diverted-loopback | diverted-output |
        {dst-ip|src-ip} IPADDR | {dst-ip6|src-ip6|dst-ipv6|src-ipv6} IP6ADDR |
        {dst-port|src-port} LIST |
        estab | frag | {gid|uid} N | icmptypes LIST | in | out | ipid LIST |
        iplen LIST | ipoptions SPEC | ipprecedence | ipsec | iptos SPEC |
        ipttl LIST | ipversion VER | keep-state | layer2 | limit ... |
        icmp6types LIST | ext6hdr LIST | flow-id N[,N] | fib FIB |
        mac ... | mac-type LIST | proto LIST | {recv|xmit|via} {IF|IPADDR} |
        setup | {tcpack|tcpseq|tcpwin} NN | tcpflags SPEC | tcpoptions SPEC |
        tcpdatalen LIST | verrevpath | versrcreach | antispoof
15:43:43
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=2.491 ms
64 bytes from 192.168.13.22: icmp_seq=1 ttl=64 time=1.039 ms
64 bytes from 192.168.13.22: icmp_seq=2 ttl=64 time=0.948 ms
64 bytes from 192.168.13.22: icmp_seq=3 ttl=64 time=0.936 ms
64 bytes from 192.168.13.22: icmp_seq=4 ttl=64 time=0.975 ms
64 bytes from 192.168.13.22: icmp_seq=5 ttl=64 time=0.913 ms
64 bytes from 192.168.13.22: icmp_seq=6 ttl=64 time=0.922 ms
64 bytes from 192.168.13.22: icmp_seq=7 ttl=64 time=1.067 ms
64 bytes from 192.168.13.22: icmp_seq=8 ttl=64 time=1.080 ms
...
64 bytes from 192.168.13.22: icmp_seq=70 ttl=64 time=4.075 ms
64 bytes from 192.168.13.22: icmp_seq=71 ttl=64 time=0.949 ms
64 bytes from 192.168.13.22: icmp_seq=72 ttl=64 time=0.990 ms
64 bytes from 192.168.13.22: icmp_seq=73 ttl=64 time=1.103 ms
64 bytes from 192.168.13.22: icmp_seq=74 ttl=64 time=1.262 ms
64 bytes from 192.168.13.22: icmp_seq=75 ttl=64 time=1.147 ms
^C
--- 192.168.13.22 ping statistics ---
76 packets transmitted, 76 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.909/1.505/5.283/1.054 ms
15:43:43
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=2.491 ms
64 bytes from 192.168.13.22: icmp_seq=1 ttl=64 time=1.039 ms
64 bytes from 192.168.13.22: icmp_seq=2 ttl=64 time=0.948 ms
64 bytes from 192.168.13.22: icmp_seq=3 ttl=64 time=0.936 ms
64 bytes from 192.168.13.22: icmp_seq=4 ttl=64 time=0.975 ms
64 bytes from 192.168.13.22: icmp_seq=5 ttl=64 time=0.913 ms
64 bytes from 192.168.13.22: icmp_seq=6 ttl=64 time=0.922 ms
64 bytes from 192.168.13.22: icmp_seq=7 ttl=64 time=1.067 ms
64 bytes from 192.168.13.22: icmp_seq=8 ttl=64 time=1.080 ms
...
64 bytes from 192.168.13.22: icmp_seq=70 ttl=64 time=4.075 ms
64 bytes from 192.168.13.22: icmp_seq=71 ttl=64 time=0.949 ms
64 bytes from 192.168.13.22: icmp_seq=72 ttl=64 time=0.990 ms
64 bytes from 192.168.13.22: icmp_seq=73 ttl=64 time=1.103 ms
64 bytes from 192.168.13.22: icmp_seq=74 ttl=64 time=1.262 ms
64 bytes from 192.168.13.22: icmp_seq=75 ttl=64 time=1.147 ms
^C
--- 192.168.13.22 ping statistics ---
76 packets transmitted, 76 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.909/1.505/5.283/1.054 ms
15:43:43
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=2.491 ms
64 bytes from 192.168.13.22: icmp_seq=1 ttl=64 time=1.039 ms
64 bytes from 192.168.13.22: icmp_seq=2 ttl=64 time=0.948 ms
64 bytes from 192.168.13.22: icmp_seq=3 ttl=64 time=0.936 ms
64 bytes from 192.168.13.22: icmp_seq=4 ttl=64 time=0.975 ms
64 bytes from 192.168.13.22: icmp_seq=5 ttl=64 time=0.913 ms
64 bytes from 192.168.13.22: icmp_seq=6 ttl=64 time=0.922 ms
64 bytes from 192.168.13.22: icmp_seq=7 ttl=64 time=1.067 ms
64 bytes from 192.168.13.22: icmp_seq=8 ttl=64 time=1.080 ms
...
64 bytes from 192.168.13.22: icmp_seq=70 ttl=64 time=4.075 ms
64 bytes from 192.168.13.22: icmp_seq=71 ttl=64 time=0.949 ms
64 bytes from 192.168.13.22: icmp_seq=72 ttl=64 time=0.990 ms
64 bytes from 192.168.13.22: icmp_seq=73 ttl=64 time=1.103 ms
64 bytes from 192.168.13.22: icmp_seq=74 ttl=64 time=1.262 ms
64 bytes from 192.168.13.22: icmp_seq=75 ttl=64 time=1.147 ms
^C
--- 192.168.13.22 ping statistics ---
76 packets transmitted, 76 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.909/1.505/5.283/1.054 ms
15:43:43
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=2.491 ms
64 bytes from 192.168.13.22: icmp_seq=1 ttl=64 time=1.039 ms
64 bytes from 192.168.13.22: icmp_seq=2 ttl=64 time=0.948 ms
64 bytes from 192.168.13.22: icmp_seq=3 ttl=64 time=0.936 ms
64 bytes from 192.168.13.22: icmp_seq=4 ttl=64 time=0.975 ms
64 bytes from 192.168.13.22: icmp_seq=5 ttl=64 time=0.913 ms
64 bytes from 192.168.13.22: icmp_seq=6 ttl=64 time=0.922 ms
64 bytes from 192.168.13.22: icmp_seq=7 ttl=64 time=1.067 ms
64 bytes from 192.168.13.22: icmp_seq=8 ttl=64 time=1.080 ms
...
64 bytes from 192.168.13.22: icmp_seq=70 ttl=64 time=4.075 ms
64 bytes from 192.168.13.22: icmp_seq=71 ttl=64 time=0.949 ms
64 bytes from 192.168.13.22: icmp_seq=72 ttl=64 time=0.990 ms
64 bytes from 192.168.13.22: icmp_seq=73 ttl=64 time=1.103 ms
64 bytes from 192.168.13.22: icmp_seq=74 ttl=64 time=1.262 ms
64 bytes from 192.168.13.22: icmp_seq=75 ttl=64 time=1.147 ms
^C
--- 192.168.13.22 ping statistics ---
76 packets transmitted, 76 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.909/1.505/5.283/1.054 ms
15:43:43
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=2.491 ms
64 bytes from 192.168.13.22: icmp_seq=1 ttl=64 time=1.039 ms
64 bytes from 192.168.13.22: icmp_seq=2 ttl=64 time=0.948 ms
64 bytes from 192.168.13.22: icmp_seq=3 ttl=64 time=0.936 ms
64 bytes from 192.168.13.22: icmp_seq=4 ttl=64 time=0.975 ms
64 bytes from 192.168.13.22: icmp_seq=5 ttl=64 time=0.913 ms
64 bytes from 192.168.13.22: icmp_seq=6 ttl=64 time=0.922 ms
64 bytes from 192.168.13.22: icmp_seq=7 ttl=64 time=1.067 ms
64 bytes from 192.168.13.22: icmp_seq=8 ttl=64 time=1.080 ms
...
64 bytes from 192.168.13.22: icmp_seq=70 ttl=64 time=4.075 ms
64 bytes from 192.168.13.22: icmp_seq=71 ttl=64 time=0.949 ms
64 bytes from 192.168.13.22: icmp_seq=72 ttl=64 time=0.990 ms
64 bytes from 192.168.13.22: icmp_seq=73 ttl=64 time=1.103 ms
64 bytes from 192.168.13.22: icmp_seq=74 ttl=64 time=1.262 ms
64 bytes from 192.168.13.22: icmp_seq=75 ttl=64 time=1.147 ms
^C
--- 192.168.13.22 ping statistics ---
76 packets transmitted, 76 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.909/1.505/5.283/1.054 ms
15:43:43
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=2.491 ms
64 bytes from 192.168.13.22: icmp_seq=1 ttl=64 time=1.039 ms
64 bytes from 192.168.13.22: icmp_seq=2 ttl=64 time=0.948 ms
64 bytes from 192.168.13.22: icmp_seq=3 ttl=64 time=0.936 ms
64 bytes from 192.168.13.22: icmp_seq=4 ttl=64 time=0.975 ms
64 bytes from 192.168.13.22: icmp_seq=5 ttl=64 time=0.913 ms
64 bytes from 192.168.13.22: icmp_seq=6 ttl=64 time=0.922 ms
64 bytes from 192.168.13.22: icmp_seq=7 ttl=64 time=1.067 ms
64 bytes from 192.168.13.22: icmp_seq=8 ttl=64 time=1.080 ms
...
64 bytes from 192.168.13.22: icmp_seq=70 ttl=64 time=4.075 ms
64 bytes from 192.168.13.22: icmp_seq=71 ttl=64 time=0.949 ms
64 bytes from 192.168.13.22: icmp_seq=72 ttl=64 time=0.990 ms
64 bytes from 192.168.13.22: icmp_seq=73 ttl=64 time=1.103 ms
64 bytes from 192.168.13.22: icmp_seq=74 ttl=64 time=1.262 ms
64 bytes from 192.168.13.22: icmp_seq=75 ttl=64 time=1.147 ms
^C
--- 192.168.13.22 ping statistics ---
76 packets transmitted, 76 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.909/1.505/5.283/1.054 ms
15:43:43
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=2.491 ms
64 bytes from 192.168.13.22: icmp_seq=1 ttl=64 time=1.039 ms
64 bytes from 192.168.13.22: icmp_seq=2 ttl=64 time=0.948 ms
64 bytes from 192.168.13.22: icmp_seq=3 ttl=64 time=0.936 ms
64 bytes from 192.168.13.22: icmp_seq=4 ttl=64 time=0.975 ms
64 bytes from 192.168.13.22: icmp_seq=5 ttl=64 time=0.913 ms
64 bytes from 192.168.13.22: icmp_seq=6 ttl=64 time=0.922 ms
64 bytes from 192.168.13.22: icmp_seq=7 ttl=64 time=1.067 ms
64 bytes from 192.168.13.22: icmp_seq=8 ttl=64 time=1.080 ms
...
64 bytes from 192.168.13.22: icmp_seq=70 ttl=64 time=4.075 ms
64 bytes from 192.168.13.22: icmp_seq=71 ttl=64 time=0.949 ms
64 bytes from 192.168.13.22: icmp_seq=72 ttl=64 time=0.990 ms
64 bytes from 192.168.13.22: icmp_seq=73 ttl=64 time=1.103 ms
64 bytes from 192.168.13.22: icmp_seq=74 ttl=64 time=1.262 ms
64 bytes from 192.168.13.22: icmp_seq=75 ttl=64 time=1.147 ms
^C
--- 192.168.13.22 ping statistics ---
76 packets transmitted, 76 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.909/1.505/5.283/1.054 ms
15:43:43
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=2.491 ms
64 bytes from 192.168.13.22: icmp_seq=1 ttl=64 time=1.039 ms
64 bytes from 192.168.13.22: icmp_seq=2 ttl=64 time=0.948 ms
64 bytes from 192.168.13.22: icmp_seq=3 ttl=64 time=0.936 ms
64 bytes from 192.168.13.22: icmp_seq=4 ttl=64 time=0.975 ms
64 bytes from 192.168.13.22: icmp_seq=5 ttl=64 time=0.913 ms
64 bytes from 192.168.13.22: icmp_seq=6 ttl=64 time=0.922 ms
64 bytes from 192.168.13.22: icmp_seq=7 ttl=64 time=1.067 ms
64 bytes from 192.168.13.22: icmp_seq=8 ttl=64 time=1.080 ms
...
64 bytes from 192.168.13.22: icmp_seq=70 ttl=64 time=4.075 ms
64 bytes from 192.168.13.22: icmp_seq=71 ttl=64 time=0.949 ms
64 bytes from 192.168.13.22: icmp_seq=72 ttl=64 time=0.990 ms
64 bytes from 192.168.13.22: icmp_seq=73 ttl=64 time=1.103 ms
64 bytes from 192.168.13.22: icmp_seq=74 ttl=64 time=1.262 ms
64 bytes from 192.168.13.22: icmp_seq=75 ttl=64 time=1.147 ms
^C
--- 192.168.13.22 ping statistics ---
76 packets transmitted, 76 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.909/1.505/5.283/1.054 ms
15:43:43
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=2.491 ms
64 bytes from 192.168.13.22: icmp_seq=1 ttl=64 time=1.039 ms
64 bytes from 192.168.13.22: icmp_seq=2 ttl=64 time=0.948 ms
64 bytes from 192.168.13.22: icmp_seq=3 ttl=64 time=0.936 ms
64 bytes from 192.168.13.22: icmp_seq=4 ttl=64 time=0.975 ms
64 bytes from 192.168.13.22: icmp_seq=5 ttl=64 time=0.913 ms
64 bytes from 192.168.13.22: icmp_seq=6 ttl=64 time=0.922 ms
64 bytes from 192.168.13.22: icmp_seq=7 ttl=64 time=1.067 ms
64 bytes from 192.168.13.22: icmp_seq=8 ttl=64 time=1.080 ms
...
64 bytes from 192.168.13.22: icmp_seq=70 ttl=64 time=4.075 ms
64 bytes from 192.168.13.22: icmp_seq=71 ttl=64 time=0.949 ms
64 bytes from 192.168.13.22: icmp_seq=72 ttl=64 time=0.990 ms
64 bytes from 192.168.13.22: icmp_seq=73 ttl=64 time=1.103 ms
64 bytes from 192.168.13.22: icmp_seq=74 ttl=64 time=1.262 ms
64 bytes from 192.168.13.22: icmp_seq=75 ttl=64 time=1.147 ms
^C
--- 192.168.13.22 ping statistics ---
76 packets transmitted, 76 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.909/1.505/5.283/1.054 ms
15:46:46
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=1.734 ms
^C
--- 192.168.13.22 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.734/1.734/1.734/0.000 ms
15:46:46
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=1.734 ms
^C
--- 192.168.13.22 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.734/1.734/1.734/0.000 ms
15:46:46
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=1.734 ms
^C
--- 192.168.13.22 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.734/1.734/1.734/0.000 ms
15:46:46
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=1.734 ms
^C
--- 192.168.13.22 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.734/1.734/1.734/0.000 ms
15:46:46
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=1.734 ms
^C
--- 192.168.13.22 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.734/1.734/1.734/0.000 ms
15:46:46
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=1.734 ms
^C
--- 192.168.13.22 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.734/1.734/1.734/0.000 ms
15:46:46
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=1.734 ms
^C
--- 192.168.13.22 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.734/1.734/1.734/0.000 ms
15:46:46
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=1.734 ms
^C
--- 192.168.13.22 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.734/1.734/1.734/0.000 ms
15:46:46
#ping 192.168.13.22
PING 192.168.13.22 (192.168.13.22): 56 data bytes
64 bytes from 192.168.13.22: icmp_seq=0 ttl=64 time=1.734 ms
^C
--- 192.168.13.22 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.734/1.734/1.734/0.000 ms
15:46:49
#route del default
del net default
15:46:49
#route del default
del net default
15:46:49
#route del default
del net default

Четверг (12/20/12)

/dev/pts/0
10:45:55
#tcpdump
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on re0, link-type EN10MB (Ethernet), capture size 96 bytes
11:46:02.114635 IP freebsd1.net.nt.ssh > 192.168.15.101.49160: Flags [P.], ack 3891306789, win 8212, length 116
11:46:02.115228 IP 192.168.15.101.49160 > freebsd1.net.nt.ssh: Flags [.], ack 116, win 251, length 0
11:46:02.115642 IP freebsd1.net.nt.ssh > 192.168.15.101.49160: Flags [P.], ack 1, win 8212, length 116
11:46:02.333698 IP 192.168.15.101.49160 > freebsd1.net.nt.ssh: Flags [.], ack 232, win 256, length 0
11:46:02.445191 IP freebsd1.net.nt.41384 > fobos.net.nt.domain: 5207+ A? xgu.ru. (24)
11:46:02.655616 IP fobos.net.nt.domain > freebsd1.net.nt.41384: 5207 1/5/0 A 178.63.229.230 (132)
11:46:02.656133 IP freebsd1.net.nt.51226 > xgu.ru.18030: Flags [S], seq 503942369, win 65535, options [mss 1460,nop,wscale 3,sackOK,TS val 6049605 ecr 0], length 0
11:46:02.695405 IP xgu.ru.18030 > freebsd1.net.nt.51226: Flags [S.], seq 41761598, ack 503942370, win 14480, options [mss 1460,sackOK,TS val 2280208962 ecr 6049605,nop,wscale 4], length 0
11:46:02.695433 IP freebsd1.net.nt.51226 > xgu.ru.18030: Flags [.], ack 1, win 8326, options [nop,nop,TS val 6049609 ecr 2280208962], length 0
11:46:02.695710 IP freebsd1.net.nt.51226 > xgu.ru.18030: Flags [P.], ack 1, win 8326, options [nop,nop,TS val 6049609 ecr 2280208962], length 426
11:46:02.696061 IP freebsd1.net.nt.51226 > xgu.ru.18030: Flags [F.], seq 427, ack 1, win 8326, options [nop,nop,TS val 6049609 ecr 2280208962], length 0
11:46:02.735332 IP xgu.ru.18030 > freebsd1.net.nt.51226: Flags [.], ack 427, win 972, options [nop,nop,TS val 2280208972 ecr 6049609], length 0
11:46:02.770368 IP xgu.ru.18030 > freebsd1.net.nt.51226: Flags [F.], seq 1, ack 428, win 972, options [nop,nop,TS val 2280208981 ecr 6049609], length 0
11:46:02.770392 IP freebsd1.net.nt.51226 > xgu.ru.18030: Flags [.], ack 2, win 8325, options [nop,nop,TS val 6049617 ecr 2280208981], length 0
^C
14 packets captured
27 packets received by filter
0 packets dropped by kernel
10:46:04
#nc
usage: nc [-46DdEhklnrStUuvz] [-e policy] [-I length] [-i interval] [-O length]
          [-P proxy_username] [-p source_port] [-s source_ip_address] [-T ToS]
          [-V rtable] [-w timeout] [-X proxy_protocol]
          [-x proxy_address[:port]] [hostname] [port]
10:46:06
#iptraf
l3script: iptraf: command not found
10:46:10
#trafshow
10:46:34
#vim /etc/defaults/rc.conf
10:46:34
#vim /etc/defaults/rc.conf
прошло 30 минут
11:17:15
#dhc dhc
DAEMON*                 ftpd*                   mountcritremote*        route6d*
FILESYSTEMS*            gbde*                   mountd*                 routed*
LOGIN*                  geli*                   mountlate*              routing*
NETWORKING*             geli2*                  moused*                 rpcbind*
SERVERS*                gptboot*                mroute6d*               rtadvd*
abi*                    gssd*                   mrouted*                rtsold*
accounting*             hastd*                  msgs*                   rwho*
addswap*                hcsecd*                 named*                  savecore*
adjkerntz*              hostapd*                natd*                   sdpd*
amd*                    hostid*                 netif*                  securelevel*
...
ddb*                    ldconfig*               powerd*                 ypbind*
defaultroute*           local*                  ppp*                    yppasswdd*
devd*                   localpkg*               pppoed*                 ypserv*
devfs*                  lockd*                  pwcheck*                ypset*
dhclient*               lpd*                    quota*                  ypupdated*
dmesg*                  mdconfig*               random*                 ypxfrd*
dumpon*                 mdconfig2*              rarpd*                  zfs*
encswap*                mixer*                  resolv*                 zvol*
fsck*                   motd*                   rfcomm_pppd_server*
ftp-proxy*              mountcritlocal*         root*
11:17:27
#cd /usr/ports/

11:18:35
#make search name=dhcp
Port:   dhcp6-20080615_1
Path:   /usr/ports/net/dhcp6
Info:   KAME DHCP6 client, server, and relay
Maint:  ports@FreeBSD.org
B-deps:
R-deps:
WWW:    http://wide-dhcpv6.sourceforge.net/.
Port:   dhcpcd-3.2.3
Path:   /usr/ports/net/dhcpcd
Info:   DHCP client
...
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
Port:   net/isc-dhcp30-relay
Moved:  net/isc-dhcp31-relay
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
Port:   net/isc-dhcp30-server
Moved:  net/isc-dhcp31-server
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
11:18:35
#make search name=dhcp
Port:   dhcp6-20080615_1
Path:   /usr/ports/net/dhcp6
Info:   KAME DHCP6 client, server, and relay
Maint:  ports@FreeBSD.org
B-deps:
R-deps:
WWW:    http://wide-dhcpv6.sourceforge.net/.
Port:   dhcpcd-3.2.3
Path:   /usr/ports/net/dhcpcd
Info:   DHCP client
...
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
Port:   net/isc-dhcp30-relay
Moved:  net/isc-dhcp31-relay
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
Port:   net/isc-dhcp30-server
Moved:  net/isc-dhcp31-server
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
11:18:35
#make search name=dhcp
Port:   dhcp6-20080615_1
Path:   /usr/ports/net/dhcp6
Info:   KAME DHCP6 client, server, and relay
Maint:  ports@FreeBSD.org
B-deps:
R-deps:
WWW:    http://wide-dhcpv6.sourceforge.net/.
Port:   dhcpcd-3.2.3
Path:   /usr/ports/net/dhcpcd
Info:   DHCP client
...
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
Port:   net/isc-dhcp30-relay
Moved:  net/isc-dhcp31-relay
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
Port:   net/isc-dhcp30-server
Moved:  net/isc-dhcp31-server
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
11:18:35
#make search name=dhcp
Port:   dhcp6-20080615_1
Path:   /usr/ports/net/dhcp6
Info:   KAME DHCP6 client, server, and relay
Maint:  ports@FreeBSD.org
B-deps:
R-deps:
WWW:    http://wide-dhcpv6.sourceforge.net/.
Port:   dhcpcd-3.2.3
Path:   /usr/ports/net/dhcpcd
Info:   DHCP client
...
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
Port:   net/isc-dhcp30-relay
Moved:  net/isc-dhcp31-relay
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
Port:   net/isc-dhcp30-server
Moved:  net/isc-dhcp31-server
Date:   2010-07-09
Reason: Has expired: deprecated upstream since March 2009
11:18:48
#make search name=dhcpd
Port:   dhcpdump-1.8
Path:   /usr/ports/net/dhcpdump
Info:   Decode and diagnose sniffed DHCP packets
Maint:  edwin@mavetju.org
B-deps: perl-5.10.1_3
R-deps:
WWW:    http://www.mavetju.org/unix/general.php
11:18:48
#make search name=dhcpd
Port:   dhcpdump-1.8
Path:   /usr/ports/net/dhcpdump
Info:   Decode and diagnose sniffed DHCP packets
Maint:  edwin@mavetju.org
B-deps: perl-5.10.1_3
R-deps:
WWW:    http://www.mavetju.org/unix/general.php
11:18:48
#make search name=dhcpd
Port:   dhcpdump-1.8
Path:   /usr/ports/net/dhcpdump
Info:   Decode and diagnose sniffed DHCP packets
Maint:  edwin@mavetju.org
B-deps: perl-5.10.1_3
R-deps:
WWW:    http://www.mavetju.org/unix/general.php
11:18:48
#make search name=dhcpd
Port:   dhcpdump-1.8
Path:   /usr/ports/net/dhcpdump
Info:   Decode and diagnose sniffed DHCP packets
Maint:  edwin@mavetju.org
B-deps: perl-5.10.1_3
R-deps:
WWW:    http://www.mavetju.org/unix/general.php
прошло 20 минут
11:39:45
#make search name=bind
Port:   xapian-bindings-1.0.22
Path:   /usr/ports/databases/xapian-bindings
Info:   Bindings allowing Xapian to be used from various programming languages
Maint:  gslin@gslin.org
B-deps: libiconv-1.13.1_1 libxml2-2.7.8_1 pcre-8.12 php5-5.3.5 pkg-config-0.25_1 python26-2.6.6 ruby-1.8.7.302,1 xapian-core-1.0.22,1
R-deps: libiconv-1.13.1_1 libxml2-2.7.8_1 pcre-8.12 php5-5.3.5 pkg-config-0.25_1 python26-2.6.6 ruby-1.8.7.302,1 xapian-core-1.0.22,1
WWW:    http://www.xapian.org/
Port:   cbind-6
Path:   /usr/ports/devel/cbind
Info:   Translator for "thin" Ada bindings to C
...
Date:   2010-01-18
Reason: Has expired: has been broken for 3 months
Port:   dns/bind9
Moved:
Date:   2010-12-01
Reason: EOL - Update to dns/bind97 or dns/bind96
Port:   dns/bind95
Moved:
Date:   2011-01-01
Reason: Entered EOL 2010-09 - Update to dns/bind97 or dns/bind96
прошла 41 минута
12:21:19
#make search name=bind9
Port:   bind9-sdb-ldap-9.4.3.1
Path:   /usr/ports/dns/bind9-sdb-ldap
Info:   The well known Bind9, patched for use of an LDAP based backend
Maint:  Hugo@Meiland.nl
B-deps: openldap-client-2.4.23
R-deps: openldap-client-2.4.23
WWW:    http://www.venaas.no/ldap/bind-sdb/
Port:   bind9-sdb-postgresql-9.4.3.3
Path:   /usr/ports/dns/bind9-sdb-postgresql
Info:   Bind9, patched for use with a PostgreSQL-based backend
...
Date:   2008-12-31
Reason: DLZ patches are now in bind 9.4 distribution
Port:   dns/bind9
Moved:
Date:   2010-12-01
Reason: EOL - Update to dns/bind97 or dns/bind96
Port:   dns/bind95
Moved:
Date:   2011-01-01
Reason: Entered EOL 2010-09 - Update to dns/bind97 or dns/bind96
12:21:39
#cd dns/

12:22:00
#ls -l
total 298
-rw-r--r--  1 root  wheel  3846 Jan 30  2011 Makefile
drwxr-xr-x  3 root  wheel   512 Feb 18  2011 adns
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 ares
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 autotrust
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 bind-tools
drwxr-xr-x  3 root  wheel   512 Feb 18  2011 bind9-sdb-ldap
drwxr-xr-x  3 root  wheel   512 Feb 18  2011 bind9-sdb-postgresql
drwxr-xr-x  3 root  wheel   512 Feb 18  2011 bind94
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 bind94-geoip
...
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 tinystats
drwxr-xr-x  3 root  wheel   512 Feb 18  2011 totd
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 udns
drwxr-xr-x  3 root  wheel   512 Feb 18  2011 unbound
drwxr-xr-x  3 root  wheel   512 Feb 18  2011 updatedd
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 vizone
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 walker
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 zkt
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 zonecheck
drwxr-xr-x  2 root  wheel   512 Feb 18  2011 zonenotify
12:22:02
#cd bind98/

12:22:02
#cd bind98/

12:22:02
#cd bind98/

12:22:02
#cd bind98/

12:22:44
#make install clean
checking for cc option to accept ISO C89... none needed
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
...
/usr/local/bin/nslookup
/usr/local/sbin/dnssec-settime
      If there are vulnerabilities in these programs there may be a security
      risk to the system. FreeBSD makes no guarantee about the security of
      ports included in the Ports Collection. Please type 'make deinstall'
      to deinstall the port if this is a concern.
      For more information, and contact details about the security
      status of this software, see the following webpage:
https://www.isc.org/software/bind
===>  Cleaning for bind98-devel-9.8.0.b1
12:22:44
#make install clean
checking for cc option to accept ISO C89... none needed
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
...
/usr/local/bin/nslookup
/usr/local/sbin/dnssec-settime
      If there are vulnerabilities in these programs there may be a security
      risk to the system. FreeBSD makes no guarantee about the security of
      ports included in the Ports Collection. Please type 'make deinstall'
      to deinstall the port if this is a concern.
      For more information, and contact details about the security
      status of this software, see the following webpage:
https://www.isc.org/software/bind
===>  Cleaning for bind98-devel-9.8.0.b1
12:22:44
#make install clean
checking for cc option to accept ISO C89... none needed
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
...
/usr/local/bin/nslookup
/usr/local/sbin/dnssec-settime
      If there are vulnerabilities in these programs there may be a security
      risk to the system. FreeBSD makes no guarantee about the security of
      ports included in the Ports Collection. Please type 'make deinstall'
      to deinstall the port if this is a concern.
      For more information, and contact details about the security
      status of this software, see the following webpage:
https://www.isc.org/software/bind
===>  Cleaning for bind98-devel-9.8.0.b1
12:28:42
#ls /etc/namedb/
dynamic         master          named.conf      named.root      slave           working
12:28:42
#ls /etc/namedb/
dynamic         master          named.conf      named.root      slave           working
12:28:42
#ls /etc/namedb/
dynamic         master          named.conf      named.root      slave           working
12:28:42
#ls /etc/namedb/
dynamic         master          named.conf      named.root      slave           working
12:28:42
#ls /etc/namedb/
dynamic         master          named.conf      named.root      slave           working
12:28:42
#ls /etc/namedb/
dynamic         master          named.conf      named.root      slave           working
12:28:42
#ls /etc/namedb/
dynamic         master          named.conf      named.root      slave           working
12:28:42
#ls /etc/namedb/
dynamic         master          named.conf      named.root      slave           working
12:28:42
#ls /etc/namedb/
dynamic         master          named.conf      named.root      slave           working
12:29:58
#vim /etc/namedb/named.conf
12:29:58
#vim /etc/namedb/named.conf
12:29:58
#vim /etc/namedb/named.conf
12:29:58
#vim /etc/namedb/named.conf
12:29:58
#vim /etc/namedb/named.conf
12:29:58
#vim /etc/namedb/named.conf
12:29:58
#vim /etc/namedb/named.conf
прошло 30 минут
12:59:59
#zone "16.172.in-addr.arpa" { type master; file "/etc/namedb/master/empty.db"; };
Makefile        distinfo        pkg-descr       pkg-plist
12:59:59
#zone "16.172.in-addr.arpa" { type master; file "/etc/namedb/master/empty.db"; };
Makefile        distinfo        pkg-descr       pkg-plist
12:59:59
#zone "16.172.in-addr.arpa" { type master; file "/etc/namedb/master/empty.db"; };
Makefile        distinfo        pkg-descr       pkg-plist
12:59:59
#zone "16.172.in-addr.arpa" { type master; file "/etc/namedb/master/empty.db"; };
Makefile        distinfo        pkg-descr       pkg-plist
12:59:59
#zone "16.172.in-addr.arpa" { type master; file "/etc/namedb/master/empty.db"; };
Makefile        distinfo        pkg-descr       pkg-plist
12:59:59
#zone "16.172.in-addr.arpa" { type master; file "/etc/namedb/master/empty.db"; };
Makefile        distinfo        pkg-descr       pkg-plist
12:59:59
#zone "16.172.in-addr.arpa" { type master; file "/etc/namedb/master/empty.db"; };
Makefile        distinfo        pkg-descr       pkg-plist
13:00:00
#cd /etc/namedb

13:00:00
#cd /etc/namedb

13:00:00
#cd /etc/namedb

13:00:00
#cd /etc/namedb

13:00:00
#cd /etc/namedb

13:00:00
#cd /etc/namedb

13:00:00
#cd /etc/namedb

13:00:08
#ls -l
total 26
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 dynamic
drwxr-xr-x  2 root  wheel    512 Feb 18  2011 master
-rw-r--r--  1 root  wheel  13982 Feb 18  2011 named.conf
-rw-r--r--  1 root  wheel   3085 Feb 18  2011 named.root
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 slave
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 working
13:00:08
#ls -l
total 26
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 dynamic
drwxr-xr-x  2 root  wheel    512 Feb 18  2011 master
-rw-r--r--  1 root  wheel  13982 Feb 18  2011 named.conf
-rw-r--r--  1 root  wheel   3085 Feb 18  2011 named.root
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 slave
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 working
13:00:08
#ls -l
total 26
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 dynamic
drwxr-xr-x  2 root  wheel    512 Feb 18  2011 master
-rw-r--r--  1 root  wheel  13982 Feb 18  2011 named.conf
-rw-r--r--  1 root  wheel   3085 Feb 18  2011 named.root
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 slave
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 working
13:00:08
#ls -l
total 26
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 dynamic
drwxr-xr-x  2 root  wheel    512 Feb 18  2011 master
-rw-r--r--  1 root  wheel  13982 Feb 18  2011 named.conf
-rw-r--r--  1 root  wheel   3085 Feb 18  2011 named.root
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 slave
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 working
13:00:08
#ls -l
total 26
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 dynamic
drwxr-xr-x  2 root  wheel    512 Feb 18  2011 master
-rw-r--r--  1 root  wheel  13982 Feb 18  2011 named.conf
-rw-r--r--  1 root  wheel   3085 Feb 18  2011 named.root
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 slave
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 working
13:00:08
#ls -l
total 26
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 dynamic
drwxr-xr-x  2 root  wheel    512 Feb 18  2011 master
-rw-r--r--  1 root  wheel  13982 Feb 18  2011 named.conf
-rw-r--r--  1 root  wheel   3085 Feb 18  2011 named.root
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 slave
drwxr-xr-x  2 bind  wheel    512 Feb 18  2011 working

Статистика

Время первой команды журнала15:38:58 2012-12-18
Время последней команды журнала13:00:08 2012-12-20
Количество командных строк в журнале101
Процент команд с ненулевым кодом завершения, % 0.99
Процент синтаксически неверно набранных команд, % 0.99
Суммарное время работы с терминалом *, час 0.66
Количество командных строк в единицу времени, команда/мин 2.54
Частота использования команд
ping18|===============| 15.65%
ls16|=============| 13.91%
make13|===========| 11.30%
cd13|===========| 11.30%
vim9|=======| 7.83%
ipfw9|=======| 7.83%
Set8|======| 6.96%
}7|======| 6.09%
file7|======| 6.09%
zone7|======| 6.09%
route3|==| 2.61%
dhc1|| 0.87%
iptraf1|| 0.87%
trafshow1|| 0.87%
tcpdump1|| 0.87%
nc1|| 0.87%
____
*) Интервалы неактивности длительностью 30 минут и более не учитываются

Справка

Для того чтобы использовать LiLaLo, не нужно знать ничего особенного: всё происходит само собой. Однако, чтобы ведение и последующее использование журналов было как можно более эффективным, желательно иметь в виду следующее:
  1. В журнал автоматически попадают все команды, данные в любом терминале системы.

  2. Для того чтобы убедиться, что журнал на текущем терминале ведётся, и команды записываются, дайте команду w. В поле WHAT, соответствующем текущему терминалу, должна быть указана программа script.

  3. Команды, при наборе которых были допущены синтаксические ошибки, выводятся перечёркнутым текстом:
    $ l s-l
    bash: l: command not found
    

  4. Если код завершения команды равен нулю, команда была выполнена без ошибок. Команды, код завершения которых отличен от нуля, выделяются цветом.
    $ test 5 -lt 4
    Обратите внимание на то, что код завершения команды может быть отличен от нуля не только в тех случаях, когда команда была выполнена с ошибкой. Многие команды используют код завершения, например, для того чтобы показать результаты проверки

  5. Команды, ход выполнения которых был прерван пользователем, выделяются цветом.
    $ find / -name abc
    find: /home/devi-orig/.gnome2: Keine Berechtigung
    find: /home/devi-orig/.gnome2_private: Keine Berechtigung
    find: /home/devi-orig/.nautilus/metafiles: Keine Berechtigung
    find: /home/devi-orig/.metacity: Keine Berechtigung
    find: /home/devi-orig/.inkscape: Keine Berechtigung
    ^C
    

  6. Команды, выполненные с привилегиями суперпользователя, выделяются слева красной чертой.
    # id
    uid=0(root) gid=0(root) Gruppen=0(root)
    

  7. Изменения, внесённые в текстовый файл с помощью редактора, запоминаются и показываются в журнале в формате ed. Строки, начинающиеся символом "<", удалены, а строки, начинающиеся символом ">" -- добавлены.
    $ vi ~/.bashrc
    2a3,5
    >    if [ -f /usr/local/etc/bash_completion ]; then
    >         . /usr/local/etc/bash_completion
    >        fi
    

  8. Для того чтобы изменить файл в соответствии с показанными в диффшоте изменениями, можно воспользоваться командой patch. Нужно скопировать изменения, запустить программу patch, указав в качестве её аргумента файл, к которому применяются изменения, и всавить скопированный текст:
    $ patch ~/.bashrc
    В данном случае изменения применяются к файлу ~/.bashrc

  9. Для того чтобы получить краткую справочную информацию о команде, нужно подвести к ней мышь. Во всплывающей подсказке появится краткое описание команды.

    Если справочная информация о команде есть, команда выделяется голубым фоном, например: vi. Если справочная информация отсутствует, команда выделяется розовым фоном, например: notepad.exe. Справочная информация может отсутствовать в том случае, если (1) команда введена неверно; (2) если распознавание команды LiLaLo выполнено неверно; (3) если информация о команде неизвестна LiLaLo. Последнее возможно для редких команд.

  10. Большие, в особенности многострочные, всплывающие подсказки лучше всего показываются браузерами KDE Konqueror, Apple Safari и Microsoft Internet Explorer. В браузерах Mozilla и Firefox они отображаются не полностью, а вместо перевода строки выводится специальный символ.

  11. Время ввода команды, показанное в журнале, соответствует времени начала ввода командной строки, которое равно тому моменту, когда на терминале появилось приглашение интерпретатора

  12. Имя терминала, на котором была введена команда, показано в специальном блоке. Этот блок показывается только в том случае, если терминал текущей команды отличается от терминала предыдущей.

  13. Вывод не интересующих вас в настоящий момент элементов журнала, таких как время, имя терминала и других, можно отключить. Для этого нужно воспользоваться формой управления журналом вверху страницы.

  14. Небольшие комментарии к командам можно вставлять прямо из командной строки. Комментарий вводится прямо в командную строку, после символов #^ или #v. Символы ^ и v показывают направление выбора команды, к которой относится комментарий: ^ - к предыдущей, v - к следующей. Например, если в командной строке было введено:

    $ whoami
    
    user
    
    $ #^ Интересно, кто я?
    
    в журнале это будет выглядеть так:
    $ whoami
    
    user
    
    Интересно, кто я?

  15. Если комментарий содержит несколько строк, его можно вставить в журнал следующим образом:

    $ whoami
    
    user
    
    $ cat > /dev/null #^ Интересно, кто я?
    
    Программа whoami выводит имя пользователя, под которым 
    мы зарегистрировались в системе.
    -
    Она не может ответить на вопрос о нашем назначении 
    в этом мире.
    
    В журнале это будет выглядеть так:
    $ whoami
    user
    
    Интересно, кто я?
    Программа whoami выводит имя пользователя, под которым
    мы зарегистрировались в системе.

    Она не может ответить на вопрос о нашем назначении
    в этом мире.
    Для разделения нескольких абзацев между собой используйте символ "-", один в строке.

  16. Комментарии, не относящиеся непосредственно ни к какой из команд, добавляются точно таким же способом, только вместо симолов #^ или #v нужно использовать символы #=

  17. Содержимое файла может быть показано в журнале. Для этого его нужно вывести с помощью программы cat. Если вывод команды отметить симоволами #!, содержимое файла будет показано в журнале в специально отведённой для этого секции.
  18. Для того чтобы вставить скриншот интересующего вас окна в журнал, нужно воспользоваться командой l3shot. После того как команда вызвана, нужно с помощью мыши выбрать окно, которое должно быть в журнале.
  19. Команды в журнале расположены в хронологическом порядке. Если две команды давались одна за другой, но на разных терминалах, в журнале они будут рядом, даже если они не имеют друг к другу никакого отношения.
    1
        2
    3   
        4
    
    Группы команд, выполненных на разных терминалах, разделяются специальной линией. Под этой линией в правом углу показано имя терминала, на котором выполнялись команды. Для того чтобы посмотреть команды только одного сенса, нужно щёкнуть по этому названию.

О программе

LiLaLo (L3) расшифровывается как Live Lab Log.
Программа разработана для повышения эффективности обучения Unix/Linux-системам.
(c) Игорь Чубин, 2004-2008

$Id$