Xgu.ru теперь в Контакте  — приходите и подключайтесь.
Пока мы работаем над следующими видео, вы можете подключиться в Контакте. Познакомимся и обсудим новые страницы и ролики.

Vk-big.pngYoutube-big.jpeg

Cisco/Troubleshooting

Материал из Xgu.ru

Перейти к: навигация, поиск
stub.png
Данная страница находится в разработке.
Эта страница ещё не закончена. Информация, представленная здесь, может оказаться неполной или неверной.

Если вы считаете, что её стоило бы доработать как можно быстрее, пожалуйста, скажите об этом.

Автор: Наташа Самойленко

Эта страница посвящена поиску неисправностей в настройках и работе коммутаторов и маршрутизаторов под управлением IOS.

Страница может пригодиться для подготовки к экзамену TSHOOT. Страница TSHOOT посвящена экзамену. На ней описан сам экзамен, возможные сложности, топология, оценка времени, пару советов по сдаче и ссылки на полезные материалы.

На странице Cisco ASA/Troubleshooting описываются механизмы и команды, которые могут использоваться для поиска неисправностей при настройке Cisco ASA.

Содержание

[править] Управление отображением команд в CLI

[править] Фильтрация вывода команд

[править] include

Первоначальный вывод (частичный):

dyn1# show processes cpu              
CPU utilization for five seconds: 1%/0%; one minute: 2%; five minutes: 3%
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process 
   1           4         3       1333  0.00%  0.00%  0.00%   0 Chunk Manager    
   2     1842240    253294       7273  0.16%  0.16%  0.16%   0 Load Meter       
   3           0         1          0  0.00%  0.00%  0.00%   0 chkpt message ha 
   4     4626336    221474      20888  0.00%  0.50%  0.35%   0 Check heaps      
   5         928       276       3362  0.00%  0.00%  0.00%   0 Pool Manager     
   6           0         2          0  0.00%  0.00%  0.00%   0 Timers           
   7           0         2          0  0.00%  0.00%  0.00%   0 ATM AutoVC Perio 
   8           0         2          0  0.00%  0.00%  0.00%   0 ATM VC Auto Crea 
   9        5292     21102        250  0.00%  0.00%  0.00%   0 IPC Dynamic Cach 
  10           0         1          0  0.00%  0.00%  0.00%   0 IPC Zone Manager 
  11       81404   1265509         64  0.00%  0.00%  0.00%   0 IPC Periodic Tim 
  12       68528   1265509         54  0.00%  0.00%  0.00%   0 IPC Deferred Por 
  13           4         1       4000  0.00%  0.00%  0.00%   0 IPC Seat Manager 
  14           0         1          0  0.00%  0.00%  0.00%   0 IPC BackPressure 
  15       66740   1265509         52  0.00%  0.00%  0.00%   0 EnvMon           
  16           0         1          0  0.00%  0.00%  0.00%   0 OIR Handler      
  17           0         1          0  0.00%  0.00%  0.00%   0 Crash writer     
  18        1664     28053         59  0.00%  0.00%  0.00%   0 ARP Input        
  19           0         2          0  0.00%  0.00%  0.00%   0 ATM Idle Timer   
  20           0         2          0  0.00%  0.00%  0.00%   0 AAA high-capacit 
  21           0         1          0  0.00%  0.00%  0.00%   0 AAA_SERVER_DEADT 

Отобразить только те строки, в которых встречается слово BGP:

dyn1# show processes cpu | include BGP
 175      119076   2804506         42  0.00%  0.00%  0.00%   0 BGP Router       
 176      140408    163366        859  0.00%  0.00%  0.00%   0 BGP I/O          
 177     2982572     90228      33055  0.00%  0.55%  0.31%   0 BGP Scanner

[править] exclude

Первоначальный вывод:

dyn1# sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.20.1    YES NVRAM  up                    up
FastEthernet1/0            192.168.1.1     YES NVRAM  up                    up
FastEthernet2/0            192.168.13.1    YES NVRAM  up                    up
Loopback0                  197.1.1.1       YES NVRAM  up                    up
Loopback1                  197.1.8.1       YES NVRAM  up                    up
Loopback3                  199.1.1.1       YES manual up                    up

Исключить из вывода строки со словом Loopback:

dyn1# sh ip int br | exclude Loopback
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.20.1    YES NVRAM  up                    up
FastEthernet1/0            192.168.1.1     YES NVRAM  up                    up
FastEthernet2/0            192.168.13.1    YES NVRAM  up                    up

Аналогично можно отфильтровать, например, интерфейсы на которых не назначены IP-адреса:

dyn1# sh ip int br | exclude unassigned

[править] begin

Вывести конфигурацию начиная со слова router:

dyn1# sh run | begin router
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
 network 199.0.0.0 0.255.255.255 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 bgp bestpath med missing-as-worst
 network 192.168.1.0
 network 192.168.13.0
 network 197.1.0.0 mask 255.255.0.0
 network 199.1.1.0
 aggregate-address 192.168.1.0 255.255.255.0 summary-only
 neighbor 192.168.20.8 remote-as 8
 neighbor 192.168.20.8 soft-reconfiguration inbound
 neighbor 192.168.20.8 prefix-list private in
 neighbor 192.168.20.9 remote-as 9
 neighbor 192.168.20.9 soft-reconfiguration inbound
 neighbor 192.168.20.9 prefix-list private in
 neighbor 199.2.2.2 remote-as 100
 neighbor 199.2.2.2 update-source Loopback3
 neighbor 199.3.3.3 remote-as 100
 neighbor 199.3.3.3 update-source Loopback3
 neighbor 199.4.4.4 remote-as 100
 neighbor 199.4.4.4 update-source Loopback3
 no auto-summary
!         

[править] section

Отобразить раздел конфигурационного файла:

dyn1#sh run | section router ospf
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
 network 199.0.0.0 0.255.255.255 area 0

[править] Условие "или"

Отобразить строки в которых встречаются слова "Administrative Mode" или "Gi":

dyn# sh interface switchport | i Administrative Mode|Gi

[править] Перенаправление вывода команды

Перенаправление вывода команды на TFTP-сервер без отображения её вывода в консоли:

dyn# show tech-support | redirect tftp://192.168.1.100/tech-support.txt

Перенаправление вывода команды на TFTP-сервер и вывод команды в консоли:

dyn# show tech-support | tee tftp://192.168.1.100/tech.txt

Добавление вывода команды к уже существующему файлу:

dyn# show ip route | append tftp://192.168.1.100/basic.txt

[править] Фильтрация sh ip route

Просмотр маршрутов полученных по OSPF:

dyn1# sh ip route ospf 
     199.3.3.0/24 is variably subnetted, 2 subnets, 2 masks
O       199.3.3.3/32 [110/3] via 192.168.1.2, 1w5d, FastEthernet1/0
O    192.168.21.0/24 [110/4] via 192.168.1.2, 1w5d, FastEthernet1/0
     199.2.2.0/24 is variably subnetted, 2 subnets, 2 masks
O       199.2.2.2/32 [110/2] via 192.168.1.2, 1w5d, FastEthernet1/0
O    192.168.7.0/24 [110/4] via 192.168.1.2, 1w5d, FastEthernet1/0
     192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
O       192.168.1.8/30 [110/3] via 192.168.1.2, 1w5d, FastEthernet1/0
O       192.168.1.4/30 [110/2] via 192.168.1.2, 1w5d, FastEthernet1/0
     199.4.4.0/24 is variably subnetted, 2 subnets, 2 masks
O       199.4.4.4/32 [110/4] via 192.168.1.2, 1w5d, FastEthernet1/0

Посмотреть присутствует ли сеть в таблице маршрутизации (если маршрут существует):

dyn1# sh ip route 192.168.10.0
Routing entry for 192.168.10.0/24
  Known via "bgp 100", distance 200, metric 0
  Tag 8, type internal
  Last update from 192.168.7.8 1w5d ago
  Routing Descriptor Blocks:
  * 192.168.7.8, from 199.4.4.4, 1w5d ago
      Route metric is 0, traffic share count is 1
      AS Hops 2
      Route tag 8

Посмотреть присутствует ли сеть в таблице маршрутизации (если маршрута в таблице нет):

dyn1# sh ip route 192.168.2.0 
% Network not in table

Просмотр маршрутов, которые начинаются на указанный префикс (в примере 192.168.0.0/16):

dyn1# sh ip route 192.168.0.0 255.255.0.0 longer-prefixes   
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.13.0/24 is directly connected, FastEthernet2/0
B    192.168.14.0/24 [200/0] via 192.168.7.8, 1w5d
B    192.168.15.0/24 [200/0] via 192.168.7.8, 1w5d
B    192.168.8.0/24 [200/0] via 192.168.7.8, 1w5d
B    192.168.9.0/24 [200/0] via 192.168.7.8, 1w5d
B    192.168.111.0/24 [200/0] via 192.168.7.8, 1w5d
B    192.168.10.0/24 [200/0] via 192.168.7.8, 1w5d
B    192.168.11.0/24 [200/0] via 192.168.7.8, 1w5d
O    192.168.21.0/24 [110/4] via 192.168.1.2, 1w5d, FastEthernet1/0
C    192.168.20.0/24 is directly connected, FastEthernet0/0
B    192.168.6.0/24 [200/0] via 192.168.7.8, 1w5d
B    192.168.112.0/24 [200/0] via 192.168.7.8, 1w5d
O    192.168.7.0/24 [110/4] via 192.168.1.2, 1w5d, FastEthernet1/0
     192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
O       192.168.1.8/30 [110/3] via 192.168.1.2, 1w5d, FastEthernet1/0
C       192.168.1.0/30 is directly connected, FastEthernet1/0
S       192.168.1.0/24 is directly connected, Null0
O       192.168.1.4/30 [110/2] via 192.168.1.2, 1w5d, FastEthernet1/0

Суммарная информация о таблице маршрутизации:

dyn1# sh ip route summary 
IP routing table name is Default-IP-Routing-Table(0)
IP routing table maximum-paths is 16
Route Source    Networks    Subnets     Overhead    Memory (bytes)
connected       5           1           432         816
static          1           1           144         272
ospf 1          2           5           504         952
  Intra-area: 7 Inter-area: 0 External-1: 0 External-2: 0
  NSSA External-1: 0 NSSA External-2: 0
bgp 100         9           3           864         1632
  External: 0 Internal: 12 Local: 0
internal        4                                   4624
Total           21          10          1944        8296

[править] Управление конфигурацией

Замена текущей конфигурации указанным файлом (происходит именно замена, а не совмещение файлов):

 router# configure replace ftp://192.168.1.1/dyn1_bgp

[править] Archive

[1]

[править] Проверка доступности хоста или сервиса

[править] ping

Параметры команды ping:

  • data — specify data pattern
  • df-bit — установить в IP-пакете бит do not fragment
  • repeat — указать количество повторов
  • size — указать размер пакета
  • source — указать адрес или имя отправителя
  • timeout — значение интервала таймаут
  • validate — validate reply data

Пример использования:

dyn1# ping 192.168.1.10 repeat 7 source 197.1.1.1 timeout 5 size 1500

Type escape sequence to abort.
Sending 7, 1500-byte ICMP Echos to 192.168.1.10, timeout is 5 seconds:
Packet sent with a source address of 197.1.1.1 
!!!!!!!
Success rate is 100 percent (7/7), round-trip min/avg/max = 600/759/900 ms


Символы в выводе результатов ping и их значения:

Символ Описание
! Каждый восклицательный знак означает получение ответа
. Таймаут в ожидании ответа
U Получатель недоступен
C A congestion experienced packet was received.
I User interrupted test.
M A destination unreachable error protocol data unit (PDU) was received (Type 3) MTU required but DF bit set (code 4) with the "Next-Hop MTU" set to a non-zero value. If the "Next-hop MTU" is zero then `U' is printed.
? Неизвестный тип пакета
& Время жизни пакета истекло

[править] Расширенный ping

dyn1# ping
Protocol [ip]:
Target IP address: 192.168.1.10
Repeat count [5]: 1
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]:
Set DF bit in IP header? [no]: yes
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]: y
Sweep min size [36]: 1450
Sweep max size [18024]: 1550
Sweep interval [1]:
Type escape sequence to abort.
Sending 101, [1450..1550]-byte ICMP Echos to 192.168.1.10, timeout is 2 seconds:
Packet sent with the DF bit set
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!...................
...............................
Success rate is 50 percent (51/101), round-trip min/avg/max = 12/572/1148 ms

[править] traceroute

Символы в выводе результатов traceroute и их значения:

Символ Описание
* Истек таймаут ожидания ответа
A Пакет административно запрещен (например, настроен ACL)
H Получатель недоступен

[править] layer 2 traceroute

[править] telnet

Команда ping используется для проверки работы 3 уровня. Для проверки 4 уровня, можно использовать команду telnet. Для этого, после указания IP-адреса, необходимо указать номер порта сервиса, который проверяется.

Например, проверить включен ли HTTP-сервер на хосте 192.168.1.10 (результат Open говорит о том, что сервис запущен):

dyn1# telnet 192.168.1.10 80
Trying 192.168.1.10, 80 ... Open

^C
HTTP/1.1 400 Bad Request
Date: Wed, 17 Mar 2010 08:40:35 GMT
Server: cisco-IOS
Accept-Ranges: none

400 Bad Request

[Connection to 192.168.1.10 closed by foreign host]

Аналогично, если сервис не запущен:

dyn1# telnet 192.168.1.6 80 
Trying 192.168.1.6, 80 ... 
% Connection refused by remote host

[править] Проверка самого устройства

[править] CEF

Основная страница: CEF

[править] Проверка аппаратной части

show processes cpu
show memory
show interfaces
show controllers

[править] Анализ, реагирование и отправка событий на внешний сервер

[править] Зеркалирование трафика

Настройка источника трафика:

sw1(config)# monitor session 1 source interface fastethernet 0/10 both

Настройка получателя трафика (порт, к которому подключен анализатор трафика):

sw1(config)# monitor session 1 destination interface fastethernet 0/1

[править] Удаленное зеркалирование (RSPAN)

Настройка удаленного зеркалирования на коммутаторе с которого отправляется трафик:

sw1(config)# monitor session 1 source interface fa 0/10
sw1(config)# monitor session 1 destination remote vlan 100 reflector-port fa 0/1

Настройка удаленного зеркалирования на коммутаторе который получает трафик:

sw1(config)# monitor session 1 source remote vlan 100 
sw1(config)# monitor session 1 destination interface fa 0/8
show monitor

[править] NetFlow

Пример настройки NetFlow:

interface FastEthernet0/0
 ip address 192.168.20.1 255.255.255.0
 ip flow ingress
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.252
 ip flow ingress
!
ip flow-export source Loopback0
ip flow-export version 5
ip flow-export destination 192.168.1.10 5000

Просмотр информации:

dyn1# sh ip cache flow 
IP packet size distribution (48 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .895 .000 .104 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 4456704 bytes
  2 active, 65534 inactive, 28 added
  479 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 402056 bytes
  2 active, 16382 inactive, 22 added, 22 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-BGP             17      0.0         1    51      0.0       0.6      15.6
ICMP                 9      0.0         1    70      0.0       3.5      15.7
Total:              26      0.0         1    57      0.0       1.6      15.7

SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Fa1/0         199.4.4.4       Local         199.1.1.1       06 6120 00B3     2 
Fa1/0         192.168.1.10    Local         197.1.1.1       01 0000 0303     1 

Очистить статистику:

dyn1# clear ip flow stats 

[править] SNMP

[править] Настройка отправки trap

Настройка сервера (NMS):

snmp-server host 192.168.1.10 version 2c xguru

Включить отправку всех traps:

snmp-server enable traps

Включить отправку traps для определенных протоколов (например для BGP и OSPF):

snmp-server enable traps bgp
snmp-server enable traps ospf

Включение traps для OSPF включает несколько их подвидов, поэтому конфигурация выглядит так:

dyn1# sh run | inc traps ospf
snmp-server enable traps ospf state-change
snmp-server enable traps ospf errors
snmp-server enable traps ospf retransmit
snmp-server enable traps ospf lsa
snmp-server enable traps ospf cisco-specific state-change nssa-trans-change
snmp-server enable traps ospf cisco-specific state-change shamlink interface-old
snmp-server enable traps ospf cisco-specific state-change shamlink neighbor
snmp-server enable traps ospf cisco-specific errors
snmp-server enable traps ospf cisco-specific retransmit
snmp-server enable traps ospf cisco-specific lsa

[править] Embedded Event Manager (EEM)

Основная страница: Embedded Event Manager

[править] Протоколы

[править] ARP

Просмотр ARP-кеша:

dyn1# sh ip arp 
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.13.1            -   0016.3e01.0039  ARPA   FastEthernet2/0
Internet  192.168.1.1             -   0016.3e01.001d  ARPA   FastEthernet1/0
Internet  192.168.1.2             1   0016.3e01.0101  ARPA   FastEthernet1/0
Internet  192.168.20.8            1   0016.3e01.07c1  ARPA   FastEthernet0/0
Internet  192.168.20.9            1   0016.3e01.08c1  ARPA   FastEthernet0/0
Internet  192.168.20.1            -   0016.3e01.0001  ARPA   FastEthernet0/0

Очистка ARP-кеша:

dyn1# clear arp-cache 

[править] First Hop Redundancy Protocol (FHRP)

Более подробное описание протоколов на соответствующих страницах. Тут собрана общая информация о протоколах, которая может помочь при поиске неисправностей.

Некоторые характеристики для сравнения протоколов (тут или тут можно посмотреть похожий вариант сравнения)

Характеристика протокола HSRP (2 версия) VRRP GLBP
Проприетарный протокол Cisco? Да Нет Да
IP-адрес интерфейса может использоваться как виртуальный IP-адрес? Нет Да Нет
Несколько маршрутизаторов в группе могут передавать трафик одновременно? Нет Нет Да
Режим preempt по умолчанию включен? Нет Да Нет
Название ролей маршрутизаторов Один Active, один Standby, один или более Listening Один Master, один или более Backup Один Active Virtual Gateway (AVG), до четырех Active Virtual Forwarder (AVF)
Multicast IP-адрес 224.0.0.102 224.0.0.18 224.0.0.102
Виртуальный MAC-адрес 0000:0C9F:Fxxx

(xxx — номер группы)

0000:5E00:01xx

(xx — номер группы)

0007.b400.yyxx

(yy — номер группы, xx — номер маршрутизатора в группе)

Hello интервал по умолчанию 3 секунды 1 секунда 3 секунды
Holdtime по умолчанию10 секунд 3 + (256 - Priority)/256 10 секунд
Приоритет интерфейса по умолчанию 100 100 100
Сообщения протокола Hello, Coup, Resign Advertisement Hello ...

В каждом разделе приведен пример базовых настроек протоколов.

[править] HSRP

Understanding and Troubleshooting HSRP Problems in Catalyst Switch Networks

[править] VRRP

[править] GLBP

[править] Поиск неисправностей в настройках маршрутизации

[править] Общие команды

События таблицы маршрутизации:

debug ip routing

[править] ip route profile

dyn2(config)# ip route profile 
dyn2#sh ip route profile 
IP routing table change statistics:
Frequency of changes in a 5 second sampling interval
-------------------------------------------------------------
Change/   Fwd-path  Prefix   Nexthop  Pathcount  Prefix
interval  change    add      change   change     refresh
-------------------------------------------------------------
0         1         1        1        1          1         
1         0         0        0        0          0         
2         0         0        0        0          0         
3         0         0        0        0          0         
4         0         0        0        0          0         
5         0         0        0        0          0         
10        0         0        0        0          0         
15        0         0        0        0          0         
20        0         0        0        0          0         
25        0         0        0        0          0         
30        0         0        0        0          0         
55        0         0        0        0          0         
80        0         0        0        0          0         
105       0         0        0        0          0         
130       0         0        0        0          0         
155       0         0        0        0          0         
280       0         0        0        0          0         
405       0         0        0        0          0         

[править] Troubleshooting EIGRP

show ip eigrp interfaces
show ip eigrp neighbors
show ip eigrp topology

Вывод всех пакетов EIGRP, которыми маршрутизатор обменивается с соседями:

debug eigrp packets

Вывод информации, которая содержится в пакетах EIGRP и как маршрутизатор их обрабатывает:

debug ip eigrp

[править] Troubleshooting OSPF

[править] Просмотр информации

Отображение всех интерфейсов, которые настроены для работы по OSPF

dyn2#sh ip ospf interface
Loopback3 is up, line protocol is up
  Internet Address 199.2.2.2/24, Area 0
  Process ID 1, Router ID 199.2.2.2, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
FastEthernet1/0 is up, line protocol is up
  Internet Address 192.168.1.5/30, Area 0
  Process ID 1, Router ID 199.2.2.2, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 199.3.3.3, Interface address 192.168.1.6
  Backup Designated router (ID) 199.2.2.2, Interface address 192.168.1.5
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 199.3.3.3  (Designated Router)
  Suppress hello for 0 neighbor(s)
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.1.2/30, Area 0
  Process ID 1, Router ID 199.2.2.2, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 199.1.1.1, Interface address 192.168.1.1
  Backup Designated router (ID) 199.2.2.2, Interface address 192.168.1.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:09
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 3
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 199.1.1.1  (Designated Router)
  Suppress hello for 0 neighbor(s)

Параметр brief в sh ip ospf interface позволяет вывести информацию в более сжатом виде:

dyn2# sh ip ospf interface brief 
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Lo3          1     0               199.2.2.2/24       1     LOOP  0/0
Fa1/0        1     0               192.168.1.5/30     1     BDR   1/1
Fa0/0        1     0               192.168.1.2/30     1     BDR   1/1

Соседи и состояние отношений соседства:

Neighbor ID     Pri   State           Dead Time   Address         Interface
199.3.3.3         1   FULL/DR         00:00:31    192.168.1.6     FastEthernet1/0
199.1.1.1         1   FULL/DR         00:00:39    192.168.1.1     FastEthernet0/0

Информация о том как часто маршрутизатор запускал алгоритм SPF:

dyn2# sh ip ospf statistics

OSPF process ID 1
------------------------------------------

  Area 0: SPF algorithm executed 7 times

  Summary OSPF SPF statistic

  SPF calculation time
Delta T   Intra D-Intra Summ    D-Summ  Ext     D-Ext   Total   Reason
2w2d   8        0       0       0       0       0       8       R, N, X
2w2d   8        0       0       0       0       0       8       R,
2w1d   4        4       0       0       0       0       8       R, N,
2w1d   0        0       0       0       0       0       0       R,
2w1d   4        0       0       0       0       0       4       R, N,
2w1d   4        0       0       0       0       0       4       R, N,
2w1d   8        0       0       0       0       0       8       R, N,
1d15h   8       0       0       0       0       0       16      R, N, SN, SA, X
1d15h   0       0       0       0       0       0       0       R, N, SN, SA, X
1d15h   0       0       0       0       0       0       0       R, N, SN, SA, X

Просмотр информации о virtual link:

show ip ospf virtual-links

[править] Команды отладки (debug)

В реальном времени вывести информацию о том когда выполняется алгоритм SPF (предварительно интерфейс соседа был отключен, а на время выполнения команды debug интерфейс был включен):

dyn2# debug ip ospf monitor
*Mar 19 08:08:03.464: OSPF: reset throttling to 0ms
*Mar 19 08:08:04.620: %OSPF-5-ADJCHG: Process 1, Nbr 199.3.3.3 on FastEthernet1/0 from LOADING to FULL, Loading Done
dyn2#
*Mar 19 08:08:04.620: OSPF: Schedule SPF in area 0
      Change in LS ID 199.3.3.3, LSA type R, , spf-type Full
*Mar 19 08:08:04.624: OSPF: Schedule SPF in area 0
      Change in LS ID 192.168.1.6, LSA type N, , spf-type Full
*Mar 19 08:08:04.628: OSPF: reset throttling to 5000ms
*Mar 19 08:08:04.628: OSPF: schedule SPF: spf_time 2w2d wait_interval 5000ms
*Mar 19 08:08:05.120: OSPF: reset throttling to 0ms
*Mar 19 08:08:05.120: OSPF: wait_interval 5000ms next wait_interval 5000ms
*Mar 19 08:08:05.124: OSPF: Schedule SPF in area 0
      Change in LS ID 199.2.2.2, LSA type R, , spf-type Full
*Mar 19 08:08:05.124: OSPF: reset throttling to 0ms
dyn2#
*Mar 19 08:08:05.124: OSPF: Schedule SPF in area 0
      Change in LS ID 199.2.2.2, LSA type N, , spf-type Full
dyn2#
*Mar 19 08:08:09.628: OSPF: Begin SPF at 1444907.028ms, process time 13200ms
*Mar 19 08:08:09.628:       spf_time 2w2d, wait_interval 5000ms
*Mar 19 08:08:09.636: OSPF: wait_interval 10000ms next wait_interval 10000ms
*Mar 19 08:08:09.636: OSPF: End SPF at 1444907.036ms, Total elapsed time 8ms
*Mar 19 08:08:09.636:       Schedule time 2w2d, Next wait_interval 10000ms
*Mar 19 08:08:09.636:       Intra: 0ms, Inter: 0ms, External: 0ms
*Mar 19 08:08:09.636:       R: 2, N: 2, Stubs: 4
*Mar 19 08:08:09.640:       SN: 0, SA: 0, X5: 0, X7: 0
*Mar 19 08:08:09.640:       SPF suspends: 0 intra, 0 total

dyn2#
*Mar 19 08:08:10.104: OSPF: Schedule SPF in area 0
      Change in LS ID 199.3.3.3, LSA type R, , spf-type Full
dyn2#
*Mar 19 08:08:19.636: OSPF: Begin SPF at 1444917.036ms, process time 13220ms
*Mar 19 08:08:19.636:       spf_time 2w2d, wait_interval 10000ms
*Mar 19 08:08:19.648: OSPF: wait_interval 10000ms next wait_interval 10000ms
*Mar 19 08:08:19.648: OSPF: End SPF at 1444917.048ms, Total elapsed time 12ms
*Mar 19 08:08:19.648:       Schedule time 2w2d, Next wait_interval 10000ms
*Mar 19 08:08:19.648:       Intra: 12ms, Inter: 0ms, External: 0ms
*Mar 19 08:08:19.652:       R: 4, N: 3, Stubs: 8
*Mar 19 08:08:19.652:       SN: 0, SA: 0, X5: 0, X7: 0
*Mar 19 08:08:19.652:       SPF suspends: 0 intra, 0 total

Отображение пакетов OSPF в реальном времени:

dyn2# debug ip ospf packet 
OSPF packet debugging is on
dyn2#
*Mar 19 08:10:43.360: OSPF: rcv. v:2 t:1 l:48 rid:199.3.3.3
      aid:0.0.0.0 chk:D536 aut:0 auk: from FastEthernet1/0
dyn2#
*Mar 19 08:10:46.960: OSPF: rcv. v:2 t:1 l:48 rid:199.1.1.1
      aid:0.0.0.0 chk:D742 aut:0 auk: from FastEthernet0/0
dyn2#
*Mar 19 08:10:53.172: OSPF: rcv. v:2 t:1 l:48 rid:199.3.3.3
      aid:0.0.0.0 chk:D536 aut:0 auk: from FastEthernet1/0

Отображение информации об установке отношений соседства (и выбора DR и BDR):

dyn2# debug ip ospf adj  
dyn2#
*Mar 19 08:14:04.120: OSPF: Rcv DBD from 199.3.3.3 on FastEthernet1/0 seq 0x10D9 opt 0x52 flag 0x7 len 32  mtu 1500
state INIT
*Mar 19 08:14:04.120: OSPF: 2 Way Communication to 199.3.3.3 on FastEthernet1/0, 
state 2WAY
*Mar 19 08:14:04.120: OSPF: Neighbor change Event on interface FastEthernet1/0
*Mar 19 08:14:04.120: OSPF: DR/BDR election on FastEthernet1/0
*Mar 19 08:14:04.120: OSPF: Elect BDR 199.3.3.3
*Mar 19 08:14:04.120: OSPF: Elect DR 199.2.2.2
*Mar 19 08:14:04.120:        DR: 199.2.2.2 (Id)   BDR: 199.3.3.3 (Id)
*Mar 19 08:14:04.120: OSPF: Send DBD to 199.3.3.3 on FastEthernet1/0 seq 0xD6B opt 0x52 flag 0x7 len 32
*Mar 19 08:14:04.120: OSPF: NBR Negotiation Done. We are the SLAVE
*Mar 19 08:14:04.124: OSPF: Send DBD to 199.3.3.3 on FastEthernet1/0 seq 0x10D9 opt 0x52  flag 0x2 len 152
*Mar 19 08:14:04.132: OSPF: Rcv DBD from 199.3.3.3 on FastEthernet1/0 seq 0x10DA opt 0x52  flag 0x3 len 172  mtu 1500
state EXCHANGE
*Mar 19 08:14:04.132: OSPF: Send DBD to 199.3.3.3
dyn2#on FastEthernet1/0 seq 0x10DA opt 0x52 flag 0x0 len 32
*Mar 19 08:14:04.132: OSPF: Database request to 199.3.3.3
*Mar 19 08:14:04.132: OSPF: sent LS REQ packet to 192.168.1.6, length 24
*Mar 19 08:14:04.140: OSPF: Rcv DBD from 199.3.3.3 on FastEthernet1/0 seq 0x10DB opt 0x52 flag 0x1 len 32  mtu 1500
state EXCHANGE
*Mar 19 08:14:04.140: OSPF: Exchange Done with 199.3.3.3 on FastEthernet1/0
*Mar 19 08:14:04.140: OSPF: Send DBD to 199.3.3.3 on FastEthernet1/0 seq 0x10DB opt 0x52 flag 0x0 len 32
*Mar 19 08:14:04.144: OSPF: No full nbrs to build Net Lsa for interface FastEthernet1/0
*Mar 19 08:14:04.144: OSPF: Build network LSA for FastEthernet1/0, router ID 199.2.2.2
*Mar 19 08:14:04.144: OSPF: Build network LSA for FastEthernet1/0, router ID 199.2.2.2
*Mar 19 08:14:04.144: OSPF: Synchronized with 199.3.3.3 on FastEthernet1/0,
state FULL
*Mar 19 08:14:04.148: %OSPF-5-ADJCHG: Process 1, Nbr 199.3.3.3 on FastEthernet1/0 from LOADING to FULL, Loading Done
dyn2#
*Mar 19 08:14:04.664: OSPF: Build router LSA for area 0, router ID 199.2.2.2, seq 0x8000028C
dyn2#
*Mar 19 08:14:07.952: OSPF: Neighbor change Event on interface FastEthernet1/0
*Mar 19 08:14:07.952: OSPF: DR/BDR election on FastEthernet1/0
*Mar 19 08:14:07.952: OSPF: Elect BDR 199.3.3.3
*Mar 19 08:14:07.956: OSPF: Elect DR 199.2.2.2
*Mar 19 08:14:07.956:        DR: 199.2.2.2 (Id)   BDR: 199.3.3.3 (Id)
*Mar 19 08:14:07.956: OSPF: Neighbor change Event on interface FastEthernet1/0
*Mar 19 08:14:07.956: OSPF: DR/BDR election on FastEthernet1/0
*Mar 19 08:14:07.956: OSPF: Elect BDR 199.3.3.3
*Mar 19 08:14:07.960: OSPF: Elect DR 199.2.2.2
*Mar 19 08:14:07.960:        DR: 199.2.2.2 (Id)   BDR: 199.3.3.3 (Id)
dyn2#
*Mar 19 08:14:09.144: OSPF: Build network LSA for FastEthernet1/0, router ID 199.2.2.2
*Mar 19 08:14:09.144: OSPF: Build network LSA for FastEthernet1/0, router ID 199.2.2.2
dyn2# debug ip ospf events

[править] IP services

[править] NAT

router# sh ip nat translations 
router# sh ip nat statistics
router# debug ip nat

[править] DHCP

router# show ip dhcp binding
router# show ip dhcp conflict
router# show ip dhcp server statistics
router# clear ip dhcp binding [ip-address]

[править] NTP

[править] IP-телефония, видео

[править] QoS

[править] AutoQoS

router(config-if)# auto qos voip [trust]
router# show auto qos voip [interface <id>]
switch(config-if)# auto qos voip cisco-phone

[править] AutoQoS Enterprise

Запустить процесс обнаружения:

router(config-if)# auto discovery qos [trust]

Посмотреть предложенные настройки:

router# show auto discovery qos

Применить настройки:

router(config-if)# auto qos

[править] Multicast

[править] IPv6

Включение маршрутизации IPv6 трафика:

ipv6 unicast-routing

[править] RIPng

ipv6 router rip testRIPng

interface fa0/0
 ipv6 rip testRIPng enable

[править] OSPFv3

ipv6 router ospf 1
 router-id 192.168.1.1

interface fa0/0
 ipv6 ospf 1 area 0

[править] Туннели

[править] IPv6IP

interface Tunnel 0
 ipv6 address ...
 tunnel source 192.168.1.1
 tunnel destination 192.168.3.1
 tunnel mode ipv6ip

[править] VPN

[править] Фильтрация вывода команд debug

В ситуации когда на маршрутизаторе настроены несколько туннелей, а нерабочий туннель один, сложно использовать команды debug без фильтрации. Количество отображаемой информации будет очень большим.

Для того чтобы отфильтровать вывод команд используется команда debug crypto condition:

debug crypto condition [connid integer engine-id integer] [flowid integer engine-id integer] 
[fvrf string] [ivrf string] [peer [group string] [hostname string] [ipv4 ipaddress] 
[subnet subnet mask] [username string]] [spi integer] reset] 

Параметры команды:

  • connid integer engine-id integer
  • flowid integer engine-id integer
  • fvrf string
  • ivrf string
  • peer [group string]
  • peer [hostname string]
  • peer [ipv4 ipaddress]
  • peer [subnet subnet mask]
  • peer [username string]
  • spi integer
  • reset

Необходимо включить команду debug crypto condition с соответствующим параметром и команду отладки, вывод которой необходимо фильтровать.

Например, если необходимо посмотреть сообщения debug для первой фазы IPsec только для туннеля установленного с адресом 192.168.3.3:

debug crypto condition peer ipv4 192.168.3.3
debug crypto isakmp

Отключать debug надо в обратной последовательности: сначала основную команду, а потом команду фильтрации:

no debug crypto isakmp
no debug crypto condition 


asa# show crypto debug-condition

[править] Advanced services

[править] IP SLA

[править] Утилиты

  • Cisco Dynamic Configuration Tool

[править] Команда test

test crypto isakmp ipv4 10.0.1.1 10.0.2.1 esp

[править] Дополнительная информация

Troubleshooting routing:

OSPF:

Switch troubleshooting: