Xgu.ru теперь в Контакте  — приходите и подключайтесь.
Пока мы работаем над следующими видео, вы можете подключиться в Контакте. Познакомимся и обсудим новые страницы и ролики.

Vk-big.pngYoutube-big.jpeg

Cisco 871

Материал из Xgu.ru

Перейти к: навигация, поиск
Cisco ISR 800-й серии

Cisco 871 — интегрированный маршрутизатор (Integrated Serivce Router, ISR) компании Cisco. Сейчас уже снят с производства, на смену ему пришла модель Cisco 881.

Компания Cisco рассматривает этот маршрутизатор как решение, подходящее для работы в:

  • маленьких офисах и удалённых филиалах;
  • сетях малого и среднего бизнеса для обеспечения безопасного Интернет-соединения и построения безопасной беспроводной сети;
  • для сервис-провайдеров, предоставляющих широкополосный и беспроводной доступ своим клиентам.

На этой странице описывается процедура настройки маршрутизатора Cisco ISR 871.

Содержание

[править] Особенности маршрутизатора

Схематическое изображение маршрутизатора Cisco ISR 871

У маршрутизатора ISR 871 есть встроенный коммутатор на 4 порта (fa0-fa3) и 1 интерфейс 3го уровня (fa4).

Настройки 3го уровня, например, задание IP-адреса, для портов fa0-fa3 применяются к интерфейсу vlan 1. Также возможно создать несколько vlan и назначить их на порты fa0-fa3. Таким образом, на каждом порту может быть свой ip адрес, что дает возможность использовать до 4-х провайдеров Интернет (ISP). В том числе с динамическим переключением между провайдеров и балансировкой нагрузки.

[править] Пример задачи

Клиенты из локальной сети должны получать адреса по DHCP и иметь возможность выходить в Интернет.

Клиенты подключены через интерфейсы fa0-fa3; все клиенты находятся в VLAN 1; Интернет-канал подключен на порт fa4.

На маршрутизаторе необходимо настроить:

  • NAT
    • Адрес на внешнем интерфейсе (fa4) выдается динамически
    • Транслироваться должны любые адреса из локальной сети
    • Брандмауэр ip inspect
  • DHCP-сервер
    • Сервер должен выдавать адреса из диапазона 192.168.1.211-192.168.1.254
    • Выдавать адрес маршрута по умолчанию и DNS-сервера

[править] Конфигурация маршрутизатора

!
version 12.4
!
hostname Router
!
!
ip subnet-zero
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.210
!
ip dhcp pool LOCAL
   network 192.168.1.0 255.255.255.0
   dns-server 62.80.160.130 193.193.193.100 
   default-router 192.168.1.100 
!
!
ip inspect name Internet http timeout 3600
ip inspect name Internet icmp
ip inspect name Internet ftp timeout 3600
ip inspect name Internet tcp timeout 3600
ip inspect name Internet h323 timeout 3600
ip inspect name Internet smtp timeout 3600
ip inspect name Internet udp timeout 15
!
!
crypto pki trustpoint TP-self-signed-2657071675
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2657071675
 revocation-check none
 rsakeypair TP-self-signed-2657071675
!
!
crypto pki certificate chain TP-self-signed-2657071675
 certificate self-signed 01 nvram:IOS-Self-Sig#3503.cer
username Admin privilege 15 password 0 p@$$w0rd
!
! 
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 ip address dhcp
 ip nat outside
 ip inspect Internet out
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Vlan1
 ip address 192.168.1.100 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip classless
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface FastEthernet4 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!

[править] Дополнительная информация

Источник — «http://www.xgu.ru/wiki/Cisco_871»