Xgu.ru теперь в Контакте  — приходите и подключайтесь.
Пока мы работаем над следующими видео, вы можете подключиться в Контакте. Познакомимся и обсудим новые страницы и ролики.

Vk-big.pngYoutube-big.jpeg

OSPF в Cisco/Example

Материал из Xgu.ru

Перейти к: навигация, поиск

На этой странице описываются примеры настройки OSPF.

Подробнее о синтаксисе команд и возможностях OSPF на странице OSPF в Cisco.

[править] Пример базовой настройки OSPF для нескольких зон

Ospf.jpg

Настройка OSPF на R1:

R1(config)# router ospf 1
R1(config-router)# network 192.168.12.0 0.0.0.255 area 0
R1(config-router)# network 192.168.13.0 0.0.0.255 area 0
R1(config-router)# network 192.168.1.0 0.0.0.255 area 1
R1(config-router)# network 192.168.15.0 0.0.0.255 area 1

Настройка OSPF на R2:

R2(config)# router ospf 1
R2(config-router)# network 10.0.0.0 0.255.255.255 area 0
R2(config-router)# network 192.168.12.0 0.0.0.255 area 0

Настройка OSPF на R3:

R3(config)# router ospf 1
R3(config-router)# network 10.3.0.0 0.0.255.255 area 3
R3(config-router)# network 10.0.23.0 0.0.0.255 area 0
R3(config-router)# network 192.168.13.0 0.0.0.255 area 0

Настройка OSPF на R4:

R4(config)# router ospf 1
R4(config-router)# network 192.168.1.0 0.0.0.255 area 1

Настройка OSPF на R5:

R5(config)# router ospf 1
R5(config-router)# network 192.168.15.0 0.0.0.255 area 1

Настройка OSPF на R6:

R6(config)# router ospf 1
R6(config-router)# network 10.3.1.0 0.0.0.255 area 3

Настройка OSPF на R7:

R7(config)# router ospf 1
R7(config-router)# network 10.3.2.0 0.0.0.255 area 3

Команды просмотра:

sh ip protocols 
sh ip route 
sh ip ospf 
sh ip ospf neighbor
sh ip ospf interface fa0/1
sh ip ospf database

Команды отладки:

debug ip ospf adj
debug ip ospf packet
debug ip ospf event