Xgu.ru теперь в Контакте  — приходите и подключайтесь.
Пока мы работаем над следующими видео, вы можете подключиться в Контакте. Познакомимся и обсудим новые страницы и ролики.

Vk-big.pngYoutube-big.jpeg

OSPF в ProCurve

Материал из Xgu.ru

Перейти к: навигация, поиск
stub.png
Данная страница находится в разработке.
Эта страница ещё не закончена. Информация, представленная здесь, может оказаться неполной или неверной.

Если вы считаете, что её стоило бы доработать как можно быстрее, пожалуйста, скажите об этом.

Автор: Наташа Самойленко

На этой странице описывается процедура настройки протокола OSPF на коммутаторах ProCurve.

В пределах этот страницы термин "маршрутизатор" будет относиться как к маршрутизаторам, так и к коммутаторам 3го уровня.

Содержание

[править] Базовые настройки

[править] Выбор идентификатора маршрутизатора (Router ID)

Router ID (RID) можно назначить административно выполнив команду:

switch(config)# ip router-id 10.0.1.1

Если RID не был назначен административно, то он выбирается автоматически, в зависимости от настроек коммутатора, по таким правилам:

  1. Настроен один loopback-интерфейс и несколько VLANов с различными адресами:
    • Адрес присвоенный loopback-интерфейсу будет Router ID.
  2. Настроен один loopback-интерфейс с несколькими IP-адресами:
    • Наименьший IP-адрес присвоенный loopback-интерфейсу будет Router ID.
  3. Настроены несколько loopback-интерфейсов с несколькими IP-адресами в каждом:
    • Наименьший IP-адрес присвоенный loopback-интерфейсу с наименьшим номером будет Router ID.
  4. Настроены несколько VLAN'ов с одним IP-адресом в каждом VLAN:
    • IP-адрес VLAN'а который станет активным первым будет Router ID.
  5. Настроены несколько VLAN'ов с несколькими IP-адресами в каждом VLAN:
    • Наименьший IP-адрес VLAN'а который станет активным первым будет Router ID.

[править] Включение OSPF

В коммутаторах HP OSPF включается отдельной командой, не при первой заходе в режим router ospf. Засчет этого есть возможность настраивать OSPF полностью, а затем его включить. Аналогично, при отключении, не удаляются существующие настройки.

Включение OSPF

switch(config)# router ospf enable

Если OSPF отключен, то вывод команд связанных с OSPF, будет таким:

sw1(ospf)# sh ip ospf

 OSPF Configuration Information

  OSPF protocol  : disabled

Переход в режим настройки OSPF и создание зоны 0 (backbone area):

switch(config)# router ospf
switch(ospf)# area 0

Включение OSPF в VLAN 7:

switch(config)# vlan 7 ip ospf area 0

Включение OSPF на loopback-интерфейсах:

switch(config)# interface loopback 0
switch(lo-0)# ip ospf all

После включения OSPF на интерфейсе (VLAN'е) маршрутизатор:

  • Начинает отправлять hello-сообщения через этот интерфейс для установления отношений соседства;
  • Включает сеть интерфейса в LSA, которые он отправляет соседям.

[править] Изменения параметров интерфейса

[править] Passive interface

Если на каком-то интерфейсе маршрутизатора нет соседей с которыми он может обмениваться информацией по протоколу OSPF, то интерфейс может быть настроен как passive:

switch(config)# vlan 7
switch(vlan-7)# ip ospf 
switch(vlan-7)# ip ospf passive

Если интерфейс passive, то маршрутизатор не отправляет сообщения OSPF через этот интерфейс, но сеть в которой находится этот интерфейс отсылается в обновлениях соседям.

[править] Стоимость интерфейса

Назначение интерфейсам cost (по умолчанию для всех интерфейсов OSPF cost=1):

switch(vlan-7)# ip ospf cost 10

[править] Настройка нескольких зон

[править] Суммирование межзональных маршрутов

[править] Суммирование внешних маршрутов

В коммутаторах HP ProCurve нет аналога команды Cisco summary-address для суммирования внешних маршрутов OSPF.

Для того чтобы анонсировать суммарный маршрут для внешних сетей в OSPF, необходимо:

  • настроить статический суммарный маршрут, в котором вместо next-hop указано reject (или blackhole)
  • настроить перераспределение статических маршрутов с фильтром.

Например, если на маршрутизаторе есть такие статические маршруты:

ip route 172.16.1.0 255.255.255.0 10.1.100.100
ip route 172.16.2.0 255.255.255.0 10.1.100.100
ip route 172.16.3.0 255.255.255.0 10.1.100.100
ip route 172.16.4.0 255.255.255.0 10.1.100.100
ip route 172.16.5.0 255.255.255.0 10.1.100.100

Можно просуммировать их, например, в сеть 172.16.0.0/16.

Создание суммарного статического маршрута:

ip route 172.16.0.0/16 reject

Настройка перераспределения статических маршрутов с фильтрацией::

ip prefix-list SUMM seq 5 permit 172.16.0.0/16

route-map STATIC permit seq 10
   match ip address prefix-list SUMM

router ospf redistribute static route-map STATIC

[править] Анонсирование маршрута по умолчанию

В коммутаторах HP ProCurve нет аналога команды Cisco default-information-originate.

Для того чтобы анонсировать маршрут по умолчанию в OSPF, необходимо настроить перераспределение маршрутов.

Например, если на маршрутизаторе есть статический маршрут по умолчанию, то можно сделать перераспределение статических маршрутов в OSPF. Так как, статических маршрутов на маршрутизаторе может быть несколько, то необходимо настроить фильтрацию маршрутов (если остальные статические маршруты не должны попасть в OSPF).

Пример настройки:

ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip prefix-list DEF seq 10 permit 0.0.0.0/0
route-map STATIC permit seq 20
   match ip address prefix-list DEF
router ospf redistribute static route-map STATIC

Этот пример работает аналогично команде default-information-originate.

Если необходимо создать аналог команде default-information-originate always (чтобы маршрут по умолчанию анонсировался даже если его нет на маршрутизаторе), то можно сделать так:

ip route 0.0.0.0 0.0.0.0 reject
ip prefix-list DEF seq 10 permit 0.0.0.0/0
route-map STATIC permit seq 20
   match ip address prefix-list DEF
router ospf redistribute static route-map STATIC

[править] Настройка разных тупиковых зон

Настройка тупиковой зоны:

switch(ospf)# area <area-id> stub <cost>

Параметр cost определяет какая стоимость будет присвоена суммарному маршруту, который анонсируется в тупиковую зону.

[править] Просмотр информации OSPF

[править] Информация об интерфейсах

Просмотр информации об интерфейсах на которых включен OSPF:

sw5400(config)# sh ip ospf interface          

 OSPF Interface Status

  IP Address      Status   Area ID         State   Auth-type Cost  Pri Passive
  --------------- -------- --------------- ------- --------- ----- --- -------
  10.0.100.12     enabled  backbone        BDR     none      1     1   no     
  10.1.0.2        enabled  backbone        LOOP    none      1     1   no     
  10.1.64.2       enabled  backbone        BDR     none      10    1   no     
  10.1.66.1       enabled  backbone        DR      none      10    1   no     
  10.1.67.1       enabled  backbone        DR      none      10    1   no     

Подробная информация о конкретном интерфейсе, на котором включен OSPF:

sw5400(config)# sh ip ospf interface vlan 64

 OSPF configuration and statistics for VLAN 64

 OSPF Interface Status for 10.1.64.2

  IP Address      : 10.1.64.2           Status  : enabled 
  Area ID         : backbone       

  State  : BDR                          Auth-type : none  
  Cost   : 10                           Chain     :                            
  Type   : BCAST                        Priority  : 1  

  Transit Delay     : 1                 Retrans Interval  : 5   
  Hello Interval    : 10                Rtr Dead Interval : 40        
  Designated Router : 10.1.64.1         Events            : 0         
  Backup Desig. Rtr : 10.1.64.2         Passive           : no 

Информация о loopback-интерфейсе, на котором включён OSPF:

sw5400(config)# sh ip ospf interface 10.1.0.2 

 OSPF Interface Status for 10.1.0.2

  IP Address      : 10.1.0.2            Status  : enabled 
  Area ID         : backbone       

  State  : LOOP                         Auth-type : none  
  Cost   : 1                            Chain     :                            
  Type   : NBMA                         Priority  : 1  

  Transit Delay     : 1                 Retrans Interval  : 5   
  Hello Interval    : 10                Rtr Dead Interval : 40        
  Designated Router :                   Events            : 0         
  Backup Desig. Rtr :                   Passive           : no 

[править] База данных состояния каналов (LSDB)

База данных состояния каналов (показывает LSA type 1, 2, 3, 4):

sw5400(config)# show ip ospf link-state 
 OSPF Link State Database for Area 0.0.0.0

                             Advertising                                
  LSA Type   Link State ID   Router ID       Age  Sequence #  Checksum  
  ---------- --------------- --------------- ---- ----------- ----------
  Router     10.0.100.100    10.0.100.100    785  0x80000009  0x0000df75
  Router     10.1.0.1        10.1.0.1        262  0x8000000b  0x00002418
  Router     10.1.0.2        10.1.0.2        29   0x80000009  0x000044d6
  Network    10.0.100.12     10.1.0.2        29   0x80000007  0x00001d9f
  Summary    10.1.0.0        10.1.0.1        131  0x80000003  0x0000c015
  Summary    10.1.0.0        10.1.0.2        1829 0x80000002  0x0000dada
  Summary    10.2.0.0        10.0.100.100    866  0x80000002  0x00006517
  Summary    10.3.0.0        10.0.100.100    862  0x80000002  0x00005922
 
 OSPF Link State Database for Area 0.0.0.1

                             Advertising                                
  LSA Type   Link State ID   Router ID       Age  Sequence #  Checksum  
  ---------- --------------- --------------- ---- ----------- ----------
  Router     10.1.0.1        10.1.0.1        281  0x8000000f  0x00005bbe
  Router     10.1.0.2        10.1.0.2        30   0x8000000e  0x0000cf0a
  Router     10.1.0.3        10.1.0.3        235  0x8000000d  0x00002f75
  Router     10.1.0.4        10.1.0.4        290  0x8000000d  0x00007218
  Network    10.1.64.2       10.1.0.2        39   0x80000006  0x0000ac15
  Network    10.1.65.2       10.1.0.3        260  0x80000006  0x00008757
  Network    10.1.66.2       10.1.0.4        295  0x80000006  0x00008e4c
  Network    10.1.67.2       10.1.0.3        250  0x80000006  0x00007f5c
  Network    10.1.68.2       10.1.0.4        310  0x80000006  0x00006a6f
  Summary    10.0.0.0        10.1.0.1        125  0x80000003  0x000086bd
  Summary    10.0.0.0        10.1.0.2        40   0x80000003  0x00009e84
  Summary    10.2.0.0        10.1.0.1        886  0x80000002  0x00007ac7
  Summary    10.2.0.0        10.1.0.2        880  0x80000002  0x0000928e
  Summary    10.3.0.0        10.1.0.1        883  0x80000002  0x00006ed2
  Summary    10.3.0.0        10.1.0.2        882  0x80000002  0x00008699
  AsbSummary 10.0.100.100    10.1.0.1        797  0x80000001  0x0000403c
  AsbSummary 10.0.100.100    10.1.0.2        793  0x80000001  0x00005803

В выводе команды поле Age — указывает сколько LSA находится в базе данных с момента получения (в секундах):

  • Каждый раз когда LSA приходят повторно, счётчик сбивается в ноль.
  • LSA отправляются каждые 30 минут.
  • Если время хранения LSA в базе данных состояния каналов достигнет 3600 секунд, то это LSA будет удалено из базы.
  • Когда маршрутизатор запускает алгоритм SPF, он не использует LSA у которых время хранения в LSDB более чем 1800 секунд.

Информация о внешних сетях (type 5 LSA):

sw5400(config)# sh ip ospf external-link-state 

 OSPF External LSAs

  Link State ID   Router ID       Age  Sequence #  Checksum  
  --------------- --------------- ---- ----------- ----------
  10.9.9.0        10.0.100.100    936  0x80000001  0x00008158

[править] Соседи

Соседи маршрутизатора:

sw5400# sh ip ospf neighbor 

 OSPF Neighbor Information

                                                         Rxmt         Helper 
  Router ID       Pri IP Address      NbIfState State    QLen  Events Status 
  --------------- --- --------------- --------- -------- ----- ------ -------
  10.1.0.1        1   10.0.100.11     DR        FULL     0     6      None   
  10.0.100.100    1   10.0.100.100              FULL     0     6      None   
  10.1.0.1        1   10.1.64.1       DR        FULL     0     6      None   
  10.1.0.4        1   10.1.66.2       BDR       FULL     0     7      None   
  10.1.0.3        1   10.1.67.2       BDR       FULL     0     6      None   


[править] Аутентификация

Настройка аутентификации MD5 в VLAN:

sw(config)# key-chain cisco
sw(config)# key-chain cisco key 10 key-string cisco 
sw(config)# vlan 1 ip ospf md5-auth-key-chain cisco 

[править] Балансировка нагрузки

По умолчанию поддерживается балансировка нагрузки между 4 маршрутами с равной метрикой (cost одинаковый).

Распределение нагрузки выполняется по сетям. То есть, если есть два альтернативных маршрута с одинаковой метрикой и есть, например, 4 сети, то трафик из 2х сетей будет передаваться по одному маршруту, а из двух других — по другому. Имеется в виду не весь маршрут от отправителя до получателя, а то, какому next-hop маршрутизатору будет отправлен трафик.

[править] Virtual-link

[править] Перераспределение маршрутов (route redistribution)

Отправлять маршруты RIP по протоколу OSPF:

switch(ospf)# redistribute rip

Внешние (external) маршруты хранятся в отдельной базе данных:

switch(config)# show ip ospf external-link-state

[править] Соответствие стандартам

По умолчанию коммутаторы ProCurve работают в режиме совместимости со стандартом RFC1583. RFC1583 описывает OSPFv2, эта версия RFC была заменена RFC2178, а затем текущей версией RFC2328. На всех маршрутизаторах в пределах автономной системы этот режим должен быть одинаковым.

Если все маршрутизаторы поддерживают RFC2328, то совместимость со стандартом RFC1583 надо отключать (тогда маршрутизаторы работают в соответствии с RFC2328):

switch(config)# router ospf
switch(ospf)# no rfc1583-compatibility

Посмотреть текущий режим совместимости:

switch# show ip ospf general

 OSPF General Status

  OSPF protocol           : enabled 
  Router ID               : 10.1.0.1       
  RFC 1583 compatability  : non-compatible

  Intra-area distance     : 110        
  Inter-area distance     : 110        
  AS-external distance    : 110        

  Default import metric      : 10         
  Default import metric type : external type 2

  Area Border               : yes
  AS Border                 : no 
  External LSA Count        : 0          
  External LSA Checksum Sum : 0          
  Originate New LSA Count   : 91         
  Receive New LSA Count     : 139        


Источник — «http://xgu.ru/wiki/OSPF_%D0%B2_ProCurve»