Xgu.ru теперь в Контакте  — приходите и подключайтесь.
Пока мы работаем над следующими видео, вы можете подключиться в Контакте. Познакомимся и обсудим новые страницы и ролики.

Vk-big.pngYoutube-big.jpeg

PIM в Cisco

Материал из Xgu.ru

Перейти к: навигация, поиск
stub.png
Данная страница находится в разработке.
Эта страница ещё не закончена. Информация, представленная здесь, может оказаться неполной или неверной.

Если вы считаете, что её стоило бы доработать как можно быстрее, пожалуйста, скажите об этом.

Автор: Наташа Самойленко

На этой странице описывается настройка PIM на маршрутизаторах Cisco.

Так как тема достаточно обширная, то многое вынесено на отдельные страницы, а на этой собраны те настройки, которые актуальны для всех режимов работы PIM.

Оборудование Cisco поддерживает несколько вариантов протокола PIM:

Кроме PIM-DM, все остальные варианты работают на основе PIM-SM. А работа PIM-SSM основана на IGMPv3.

Как правило, настройки протокола достаточно просты, при соблюдении некоторых условий и понимании принципов работы. Проще всего работать с PIM, когда область работы PIM совпадает с протоколом маршрутизации, который используется в сети. Так как PIM использует unicast таблицу маршрутизации для проверки RPF, такое совпадение доменов маршрутизации упрощает работу с PIM.


Содержание

[править] Включение маршрутизации мультикаст

Независимо от режима PIM, первое, что нужно сделать, включить маршрутизацию мультикаст:

router(config)# ip multicast-routing

Далее, в зависимости от режима работы PIM, надо включить PIM на всех интерфейсах, через которые может маршрутизироваться мультикаст, а также на интерфейсах к которым подключены источники и клиенты.

Note-icon.gif

При включении PIM на интерфейсе автоматически включается и IGMP.

Фактически, включать IGMP нужно только на интерфейсах к которым подключены клиенты. Но включение IGMP на всех транзитных участках сети позволяет работать, например, утилите mtrace.

[править] Режимы работы мультикаст групп

Мультикаст трафик в PIM маршрутизируется в соответствии с правилами режима, который настроен для конкретной мультикаст группы.

Реализация PIM в Cisco поддерживает такие режимы мультикаст групп:

На маршрутизаторах Cisco одновременно могут работать группы всех четырех режимов.

Чаще всего, встречается ситуация, когда на основе домена PIM-SM, должны работать также группы в режиме BIDIR-PIM и PIM-SSM. Если все три протокола должны работать в сети одновременно, то разграничение их работы выполняется назначением разным протоколам разных диапазонов групп. То есть, в итоге, именно адрес группы определяет каким образом будет обрабатываться трафик, по правилам какого протокола.

[править] PIM Dense Mode (PIM-DM)

Трафик, которые передается в режиме Dense, сначала флудится по всему домену мультикаст, а зачем исключаются ветви дерева, где нет желающих получать трафик.

В Cisco режим dense включается для групп:

  • для всех групп, если на интерфейсах включен режим dense
  • для групп 224.0.1.39 и 224.0.1.40, если на интерфейсах включен режим sparse-dense
    • если на интерфейсах включен PIM в режиме sparse-dense, то все группы, для которых у текущей RP нет соответствия, также будут работать в режиме dense

В таблице маршрутизации мультикаст всегда добавляются интерфейсы, которые работают в режиме dense. Мультикаст трафик передается через все интерфейсы в списке исходящих интерфейсов (по умолчанию это все интерфейсы, кроме RPF-интерфейса). В процессе исключения из дерева (при отправке сообщений Prune), интерфейсы удаляются. Они могут быть снова добавлены при отправке сообщений Graft, которые указывают на то, что есть желающие получать рассылку группы.

Основная страница: PIM-DM в Cisco

[править] PIM Sparse Mode (PIM-SM)

Работа режима sparse построена вокруг rendezvous point (RP). RP это точка, к которой строятся деревья от клиентов, которые хотят получать трафик определенной группы (RPT-деревья).

Также RP в PIM-SM отвечает за процесс регистрации источника, который состоит в том, что маршрутизатор, который ближе всех находится к источнику трафика, отправляется сообщение на RP, с указанием адреса источника и группы (фактически сам мультикаст пакет отправленный источником).

Когда источник зарегистрирован, и уже есть или появляются позже клиенты, которые хотят получать трафик определенной группы, задача RP построить SPT-дерево к источнику.

В PIM-SM оба дерева, и RPT и SPT, односторонние. То есть, трафик может передаваться по ним только в одном направлении. В SPT от источника к RP, а в RPT от RP к клиентам.

Основная страница: PIM-SM в Cisco

[править] PIM Bidirectional Mode (BIDIR-PIM)

В BIDIR-PIM работа протокола построена вокруг RP, как и в PIM-SM. Но в BIDIR-PIM используются только shared tree с вершиной в RP, и не используются SPT-деревья.

Кроме того, BIDIR-PIM RPT-деревья двунаправленные, то есть, трафик по ним может передаваться в двух направлениях.

В этом режиме IP-адрес RP используется всеми маршрутизаторами в домене для построения топологии без петель. Так как в BIDIR-PIM нет процедуры регистрации, и нет SPT, то трафик от источника идет по RPT-дереву до RP. И для того чтобы определить какому маршрутизатору разрешено передавать трафик вверх по RPT-дереву, в каждом сегменте выбирается маршрутизатор, который находится "ближе" всех в RP. Этот маршрутизатор называется Designated Forwarder (DF).

По мере появления клиентов, которые хотят получать трафик, маршрутизаторы строят RPT-дерево к RP, которая отвечает за эту группу, отправляя сообщения Join.

В итоге, в BIDIR-PIM трафик передается только по RPT-дереву.

BIDIR-PIM работает на основе PIM-SM. В том смысле, что на интерфейсах маршрутизаторов включается режим sparse. А затем включается режим BIDIR и указывается какой диапазон групп будет работать в этом режиме.

Основная страница: BIDIR-PIM в Cisco

[править] PIM Source Specific Multicast Mode (PIM-SSM)

Режим PIM-SSM работает с IGMPv3. Так как в IGMPv3 появилась возможность клиентам указывать от какого источника они хотят получать рассылку, то в PIM-SSM не нужны RP и, соответственно, нет RPT-деревьев. Маршрутизаторы, получив запрос от клиента, сразу видят рассылку какой группы клиент хочет получать и могут строить SPT-дерево непосредственно к источнику.

В этом аспекте PIM-SSM работает как PIM-SM, используя сообщения Join для построения дерева SPT.

Так как, как правило, PIM-SSM работает на основе существующего домена PIM-SM, то маршрутизаторы должны понимать, что для ряда групп не надо регистрировать источник на RP, что они работают в режиме SSM. Это указывается явно, при включении SSM режима. По умолчанию, группы диапазона 232.0.0.0/8 работают в режиме SSM.

Основная страница: PIM-SSM в Cisco

[править] Общие настройки для разных режимов PIM

[править] Проверка RPF

Проверка RPF — одно из самых важных понятий для PIM. Подробнее о сути проверки RPF, вариантах влияния на нее и настройках в Cisco:

Основная страница: RPF

[править] Настройка интервала отправки Hello-сообщений

По умолчанию сообщения hello отправляются каждые 30 секунд на адрес 224.0.0.13 (All-PIM-Routers).

Изменение интервала отправки hello-сообщений:

dyn1(config-if)# ip pim query-interval 60

Просмотр информации о значении интервала на интерфейсе:

dyn2#sh ip pim int fa0/0

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
192.168.1.2      FastEthernet0/0          v2/D   1      60     1      192.168.1.1

[править] Выбор DR

Хотя DR играет разную роль, в разных версиях PIM, настройка приоритета, для выбора маршрутизатора, который будет DR и принцип выбора, одинаковы для всех версий.

Note-icon.gif

В режиме PIM-DM выбор DR необходим только в том случае, если используется IGMPv1.

По умолчанию у всех маршрутизаторов приоритет 1, поэтому DR выбирается на основании IP-адреса:

  • маршрутизатор у которого больше IP-адрес, становится DR.

Настройка приоритета для выбора DR:

dyn1(config-if)# ip pim dr-priority 10

Просмотр информации о приоритете интерфейса:

dyn1# sh ip pim int fa0/0

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
192.168.1.1      FastEthernet0/0          v2/D   1      30     10     192.168.1.1

Просмотр информации о приоритете соседа:

dyn1#sh ip pim neighbor
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
192.168.1.2       FastEthernet0/0          03:13:39/00:01:30 v2    1 / S

[править] Просмотр информации PIM

[править] IP multicast routing table

Посмотреть содержимое таблицы IP multicast routing table:

dyn3# show ip mroute [group-address] [summary] [count ] [active <kbps>]

Параметры команды:

  • summary — отображает суммарную информацию о каждой записи в таблице
  • count — отображает статистику о группе и источнике
  • active — отображает rate с которым активные источники передают информацию

Флаги в таблице mroute:

Флаг Значение Описание
D dense Entry is operating in dense mode.
S sparse Entry is operating in sparse mode.
C connected Участник multicast группы находится в непосредственно присоединенной сети.
L local Маршрутизатор сам является участником multicast группы.
P pruned Маршрут был удален (prune).
R RP-bit set Indicates that the (S,G) entry is pointing toward the RP. The RP is typically in a pruned state along the shared tree after a downstream router has switched to SPT for a particular source.
F register flag Indicates that the software is registering for a multicast source.
T SPT-bit set Indicates that packets have been received on the shortest-path source

tree.

J join SPT
  • Для записи (*, G) флаг указывает, что количество данных передаваемых по RPT превысило предел SPT-Threshold (по умолчанию 0) установленный для данной группы. Когда флаг J установлен, следующий пакет полученный по RPT дереву, инициирует отправку сообщения Join (S, G) по направлению к источнику и маршрутизатор присоединяется к SPT дереву.
  • Для записи (S, G) флаг указывает, что запись была создана потому что SPT-Threshold, установленный для данной группы, был превышен. Когда флаг J установлен для (S, G) записей, маршрутизатор отслеживает количество трафика, который передается по SPT. Маршрутизатор пытается переключиться назад на RPT для конкретного источника, если количество трафика, который передается по SPT, ниже SPT-Threshold более одной минуты.

Note-icon.gif

Как только на интерфейсе включен PIM, в таблице маршрутизации multicast сразу создается запись (*, 224.0.1.40). Это запись называется родительской (parent entry)

[править] Информация об интерфейсах и соседях

Информация об интерфейсах настроенных для работы PIM:

dyn3# show ip pim interface [type number] [count]

Информация о соседях:

dyn3# show ip pim neighbor [type number]

Информация о multicast маршрутизаторе (если не указывать адрес, то о локальном маршрутизаторе, с указанием адреса — о соседе):

dyn3# mrinfo [hostname | address]

[править] Информация о RP

Показать активные RP:

dyn3# show ip pim rp [group-name | group-address | mapping]

[править] Информация о RPF

Отобразить как IP multicast делает RPF:

dyn3# show ip rpf  <address | name>

[править] Проверка

[править] Multicast Routing Monitor

[1] [2]

[править] Примеры настройки

Схема сети:

Multicast.png

[править] Создание статического маршрута для multicast трафика

Может быть ситуация, когда маршрут протокола динамической маршрутизации проходит через интерфейсы на которых не включен PIM.

Например, для выбранной схемы, PIM-DM включён на всех интерфейсах dyn, кроме интерфейса fa0/0 dyn3 и интерфейса fa1/0 dyn2.

А на маршрутизаторе dyn3, маршрут OSPF к сети 192.168.1.0/24 проходит через интерфейсы на которых выключен PIM-DM:

dyn3# sh ip route 192.168.1.0
Routing entry for 192.168.1.0/24
  Known via "ospf 1", distance 110, metric 2, type intra area
  Last update from 192.168.2.2 on FastEthernet0/0, 00:09:17 ago
  Routing Descriptor Blocks:
  * 192.168.2.2, from 192.168.7.1, 00:09:17 ago, via FastEthernet0/0
      Route metric is 2, traffic share count is 1

Для проверки настроек PIM-DM интерфейс fa1/0 dyn5 назначен участником группы 224.1.1.1:

interface FastEthernet1/0
 ip address 192.168.6.5 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 224.1.1.1

Проверка прохождения multicast трафика:

dyn1# ping 224.1.1.1 repeat 3

Type escape sequence to abort.
Sending 3, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:
...

Проверка RPF на dyn5:

dyn5#sh ip rpf 192.168.1.1
RPF information for ? (192.168.1.1)
 RPF interface: FastEthernet0/0
 RPF neighbor: ? (192.168.5.3)
 RPF route/mask: 192.168.1.0/24
 RPF type: unicast (ospf 1)
 RPF recursion count: 0
 Doing distance-preferred lookups across tables


Проверка RPF на dyn3:

dyn3# sh ip rpf 192.168.1.1
RPF information for ? (192.168.1.1) failed, no route exists

Исправить ситуацию можно, изменив стоимость для OSPF, так чтобы лучший маршрут был через интерфейс на котором включён PIM, или настроить статический маршрут для multicast трафика.

Настройка статического маршрута на dyn3:

dyn3(config)# ip mroute 192.168.1.1 255.255.255.255 192.168.3.2

Note-icon.gif

Несмотря на название статический маршрут для multicast трафика, фактически это не маршрут, а возможность указать дополнительный путь позволяющий пройти проверку RPF.

Просмотр информации о добавленном маршруте:

dyn3#sh ip mroute static 
Mroute: 192.168.1.1/32, RPF neighbor: 192.168.3.2
  Protocol: none, distance: 0, route-map: none

Повторная проверка RPF на dyn3:

dyn3# sh ip rpf 192.168.1.1
RPF information for ? (192.168.1.1)
 RPF interface: FastEthernet1/0
 RPF neighbor: ? (192.168.3.2)
 RPF route/mask: 192.168.1.1/32
 RPF type: static
 RPF recursion count: 0
 Doing distance-preferred lookups across tables

Проверка прохождения multicast трафика:

dyn1# ping 224.1.1.1 repeat 3

Type escape sequence to abort.
Sending 3, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

Reply to request 0 from 192.168.5.5, 836 ms
Reply to request 1 from 192.168.5.5, 336 ms
Reply to request 2 from 192.168.5.5, 408 ms

[править] Auto-RP, режим PIM sparse-dense, фильтрация RP

[править] Настройка режим PIM sparse-dense

На всех интерфейсах dynamips настроен режим PIM sparse-dense:

dyn1(config)# interface FastEthernet0/0
dyn1(config-if)# ip pim sparse-dense-mode

Так как dyn4 и dyn5 будут выполнять роль RP, а dyn3 роль mapping agent, то на их loopback-интерфейсах тоже включён режим PIM sparse-dense:

dyn1(config)# interface lo 0
dyn1(config-if)# ip pim sparse-dense-mode

[править] Настройка RP, RP mapping agent

Настройка dyn4 как RP для групп 224.4.4.4 и 224.5.5.5:

dyn4(config)# ip pim send-rp-announce Loopback0 scope 6 group-list 20 interval 10
dyn4(config)# access-list 20 permit 224.4.4.4
dyn4(config)# access-list 20 permit 224.5.5.5

Настройка dyn5 как RP для групп 224.4.4.4 и 224.5.5.5:

dyn5(config)# ip pim send-rp-announce Loopback0 scope 6 group-list 20 interval 10
dyn5(config)# access-list 20 permit 224.4.4.4
dyn5(config)# access-list 20 permit 224.5.5.5

Настройка dyn3 как RP mapping agent:

dyn3(config)# ip pim send-rp-discovery Loopback0 scope 6

[править] Фильтрация RP

Настройка фильтрации RP на dyn3.

Настройка dyn4 как RP для группы 224.4.4.4:

dyn3(config)# ip pim rp-announce-filter rp-list 4 group-list 44
dyn3(config)# access-list 4 permit 4.4.4.4 
dyn3(config)# access-list 44 permit 224.4.4.4

Настройка dyn5 как RP для группы 224.5.5.5:

dyn3(config)# ip pim rp-announce-filter rp-list 5 group-list 55
dyn3(config)# access-list 5 permit 5.5.5.5                     
dyn3(config)# access-list 55 permit 224.5.5.5

[править] Просмотр информации

dyn#sh ip multicast 
  Multicast Routing: enabled
  Multicast Multipath: disabled
  Multicast Route limit: No limit
  Multicast Triggered RPF check: enabled
  Multicast Fallback group mode: Dense
  Multicast DVMRP Interoperability: disabled
  Number of multicast boundaries configured with filter-autorp option: 0
dyn#sh ip multicast interface 
FastEthernet0/0 is up, line protocol is up
  Internet address is 192.168.5.5/24
  Multicast routing: enabled
  Multicast switching: fast
  Multicast packets in/out: 3540/300
  Multicast TTL threshold: 0
  Multicast Tagswitching: disabled
Serial0/1 is up, line protocol is up
  Internet address is 192.168.4.5/24
  Multicast routing: enabled
  Multicast switching: fast
  Multicast packets in/out: 4648/5
  Multicast TTL threshold: 0
  Multicast Tagswitching: disabled
Serial0/0 is up, line protocol is up
  Internet address is 192.168.3.5/24
  Multicast routing: enabled
  Multicast switching: fast
  Multicast packets in/out: 4359/107
  Multicast TTL threshold: 0
  Multicast Tagswitching: disabled
dyn#sh ip pim rp mapping 
PIM Group-to-RP Mappings

Acl: 1, Static
    RP: 1.1.5.5 (?)

[править] Безопасность

[править] Ограничения для таблицы маршрутизации multicast

Ограничение количества маршрутов в таблице:

dyn1(config)# ip multicast route-limit 5 

[править] Multicast scoping

Multicast scoping это возможность определения границ распространения multicast трафика.

Методы multicast scoping:

  • TTL scoping — маршрутизатор сравнивает значение TTL в multicast пакете со значением TTL, которое настроено на каждом исходящем интерфейсе. Маршрутизатор передает пакет только через те интерфейсы на которых настроенное значение TTL меньше или равно значению TTL в пакете. На маршрутизаторах Cisco по умолчанию значение TTL на интерфейсе равно 0.
  • Administrative scoping

[править] Фильтрация соседа

dyn2(config)# access-list 10 deny 192.168.1.1
dyn2(config)# int fa0/0
dyn2(config-if)# ip pim neighbor-filter 10 

Посмотреть настройки фильтра на интерфейсе:

dyn2# sh ip pim interface fa0/0 detail
FastEthernet0/0 is up, line protocol is up
 Internet address is 192.168.1.2/24
 Multicast switching: fast
 Multicast packets in/out: 11/0
 Multicast TTL threshold: 0
 PIM: enabled
   PIM version: 2, mode: sparse-dense
   PIM DR: 192.168.1.2 (this system)
   PIM neighbor count: 0
   PIM Hello/Query interval: 30 seconds
   PIM State-Refresh processing: enabled
   PIM State-Refresh origination: disabled
   PIM NBMA mode: disabled
   PIM ATM multipoint signalling: disabled
   PIM domain border: disabled
   PIM neighbor filter: 10
 Multicast Tagswitching: disabled


[править] Поиск неисправностей

[править] Команды просмотра информации

Multicast2.png

В примерах 192.168.2.2 это источник трафика, а 192.168.6.5 клиент, группа 239.1.1.1.

dyn3#sh ip pim rp               
Group: 239.1.1.1, RP: 192.168.2.1, uptime 00:00:54, expires never
Group: 224.0.1.40, RP: 192.168.2.1, uptime 00:00:54, expires never
dyn3#sh ip pim rp mapping 
PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static
    RP: 192.168.2.1 (?)
dyn3#
dyn1#show ip rpf 192.168.2.2
RPF information for ? (192.168.2.2)
  RPF interface: FastEthernet1/0
  RPF neighbor: ? (192.168.2.2) - directly connected
  RPF route/mask: 192.168.2.0/24
  RPF type: multicast (connected)
  Doing distance-preferred lookups across tables
  RPF topology: ipv4 multicast base
dyn5#sh ip rpf 192.168.2.2
RPF information for ? (192.168.2.2)
  RPF interface: FastEthernet0/0
  RPF neighbor: ? (192.168.5.3)
  RPF route/mask: 192.168.2.0/24
  RPF type: unicast (ospf 1)
  Doing distance-preferred lookups across tables
  RPF topology: ipv4 multicast base, originated from ipv4 unicast base
dyn3#sh ip mroute count 
IP Multicast Statistics
3 routes using 1578 bytes of memory
2 groups, 0.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.1.1.1, Source count: 1, Packets forwarded: 19, Packets received: 19
  RP-tree: Forwarding: 0/0/0/0, Other: 0/0/0
  Source: 192.168.2.2/32, Forwarding: 19/0/1000/1, Other: 19/0/0

Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
dyn3#sh ip mrib route
IP Multicast Routing Information Base
Entry flags: L - Domain-Local Source, E - External Source to the Domain,
    C - Directly-Connected Check, S - Signal, IA - Inherit Accept, D - Drop
    ET - Data Rate Exceeds Threshold,K - Keepalive,DDE - Data Driven Event
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
    NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
    II - Internal Interest, ID - Internal Disinterest, LI - Local Interest,
    LD - Local Disinterest, MD - mCAC Denied

(*,224.0.0.0/4) Flags: C

(*,224.0.1.40) RPF nbr: 192.168.2.1 Flags: C
  FastEthernet1/0 Flags: F NS
  FastEthernet0/0 Flags: A IC NS

(*,239.1.1.1) RPF nbr: 192.168.2.1 Flags: C
  FastEthernet1/0 Flags: F NS
  FastEthernet0/0 Flags: A

(192.168.2.2,239.1.1.1) RPF nbr: 192.168.2.2 Flags:
  FastEthernet0/0 Flags: A
  FastEthernet1/0 Flags: F NS
dyn5#sh ip mrib route
IP Multicast Routing Information Base
Entry flags: L - Domain-Local Source, E - External Source to the Domain,
    C - Directly-Connected Check, S - Signal, IA - Inherit Accept, D - Drop
    ET - Data Rate Exceeds Threshold,K - Keepalive,DDE - Data Driven Event
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
    NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
    II - Internal Interest, ID - Internal Disinterest, LI - Local Interest,
    LD - Local Disinterest, MD - mCAC Denied

(*,224.0.0.0/4) Flags: C

(*,224.0.1.40) RPF nbr: 192.168.5.3 Flags: C
  FastEthernet1/0 Flags: F IC NS
  FastEthernet0/0 Flags: A NS

(*,239.1.1.1) RPF nbr: 192.168.5.3 Flags: C
  FastEthernet1/0 Flags: F IC NS
  FastEthernet0/0 Flags: A NS

(192.168.2.2,239.1.1.1) RPF nbr: 192.168.5.3 Flags:
  FastEthernet0/0 Flags: A
  FastEthernet1/0 Flags: F IC NS

[править] PIM-SM

dyn3#sh ip pim rp               
Group: 239.1.1.1, RP: 192.168.2.1, v2, uptime 00:00:29, expires 00:02:05
Group: 224.0.1.40, RP: 192.168.2.1, uptime 00:04:25, expires never
dyn3#sh ip pim rp-hash 239.1.1.1
  RP 192.168.2.1 (?), v2
    Info source: 192.168.2.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:00:33, expires: 00:02:01
  PIMv2 Hash Value (mask 0.0.0.0)
    RP 192.168.2.1, via bootstrap, priority 0, hash value 1446683153
dyn3#sh ip pim rp mapping       
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 192.168.2.1 (?), v2
    Info source: 192.168.2.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:00:55, expires: 00:01:39
Group(s): 224.0.0.0/4, Static
    RP: 192.168.2.1 (?)
dyn3#


dyn3#sh ip pim bsr-router 
PIMv2 Bootstrap information
  BSR address: 192.168.2.1 (?)
  Uptime:      00:03:12, BSR Priority: 0, Hash mask length: 0
  Expires:     00:01:59

[править] Команды debug

dyn# debug ip mpacket   

[править] Сообщения

Сообщение, которое появляется на RP, когда она получает сообщение о регистрации источника, который административно запрещен настроенными правилами:

%PIM-4-INVALID_SRC_REG: Received Register from 192.168.0.1 for (192.168.16.46, 224.10.10.10), not willing to be RP

В данном случае такие настройки:

ip pim accept-register route-map ACCEPT

route-map ACCEPT deny 10
 match ip address SOURCES
route-map ACCEPT permit 50

ip access-list extended SOURCES
 deny   ip host 192.168.16.6 any
 permit ip 192.168.16.0 0.0.0.255 any

[править] Утилиты

Multicast2.png

[править] mrinfo

dyn1# mrinfo 
192.168.1.1 [version  15.0] [flags: PMA]:
  192.168.1.1 -> 0.0.0.0 [1/0/pim/querier/leaf]
  192.168.2.1 -> 192.168.2.4 [1/0/pim]
  192.168.2.1 -> 192.168.2.3 [1/0/pim]
  192.168.2.1 -> 192.168.2.2 [1/0/pim]
  192.168.3.1 -> 192.168.3.2 [1/0/pim]
dyn5# mrinfo
192.168.5.5 [version  15.0] [flags: PMA]:
  192.168.5.5 -> 192.168.5.3 [1/0/pim/querier]
  192.168.6.5 -> 0.0.0.0 [1/0/pim/querier/leaf]
  192.168.7.5 -> 0.0.0.0 [1/0/pim/querier/leaf]
dyn1# mrinfo 192.168.2.4
192.168.2.4 [version  15.0] [flags: PMA]:
  192.168.2.4 -> 192.168.2.1 [1/0/pim/querier]
  192.168.2.4 -> 192.168.2.3 [1/0/pim/querier]
  192.168.2.4 -> 192.168.2.2 [1/0/pim/querier]
  192.168.4.4 -> 192.168.4.2 [1/0/pim/querier]
  192.168.8.4 -> 192.168.8.6 [1/0/pim]

[править] mtrace

dyn1#mtrace 192.168.2.2 192.168.6.5 239.1.1.1
Type escape sequence to abort.
Mtrace from 192.168.2.2 to 192.168.6.5 via group 239.1.1.1
From source (?) to destination (?)
Querying full reverse path... 
 0  192.168.6.5
-1  192.168.5.5 None  [192.168.2.0/24]
-2  192.168.5.3 PIM  [192.168.2.0/24]
-3  192.168.2.2 PIM Prune sent upstream [192.168.2.2/32]

[3]

[править] mstat

dyn1#mstat 192.168.2.2 192.168.6.5 239.1.1.1
Type escape sequence to abort.
Mtrace from 192.168.2.2 to 192.168.6.5 via group 239.1.1.1
From source (?) to destination (?)
Waiting to accumulate statistics......
Results after 10 seconds:

  Source        Response Dest   Packet Statistics For     Only For Traffic
192.168.2.2     192.168.2.1     All Multicast Traffic     From 192.168.2.2
     |       __/  rtt 804  ms   Lost/Sent = Pct  Rate     To 239.1.1.1
     v      /     hop 1235 ms   ---------------------     --------------------
192.168.2.2     ? Prune sent upstream
     |     ^      ttl   0   
     v     |      hop -7   s     -3/0 = --%      0 pps    0/0 = --%  0 pps
192.168.2.3     
192.168.5.3     ? 
     |     ^      ttl   1   
     v     |      hop 7027 ms    0/2 = --%      0 pps    0/0 = --%  0 pps
192.168.5.5     ? 
     |      \__   ttl   2   
     v         \  hop -432 ms        0         0 pps           0    0 pps
192.168.6.5     192.168.2.1     
  Receiver      Query Source

[править] Дополнительная информация