Xgu.ru теперь в Контакте  — приходите и подключайтесь.
Пока мы работаем над следующими видео, вы можете подключиться в Контакте. Познакомимся и обсудим новые страницы и ролики.

Vk-big.pngYoutube-big.jpeg

VRRP в ProCurve

Материал из Xgu.ru

Перейти к: навигация, поиск
stub.png
Данная страница находится в разработке.
Эта страница ещё не закончена. Информация, представленная здесь, может оказаться неполной или неверной.

Если вы считаете, что её стоило бы доработать как можно быстрее, пожалуйста, скажите об этом.

Автор: Наташа Самойленко

В пределах страницы термин "маршрутизатор" будет применяться и к коммутатору, использующему протокол VRRP и с включенной функцией ip routing.

Содержание

[править] Настройка VRRP на коммутаторах ProCurve

VRRP поддерживается на коммутаторах 3500, 5400 (с premium лицензией) и на 6200, 8200 (без лицензии).

Некоторые правила настройки VRRP на коммутаторах ProCurve:

  • Если в VLAN'е настроен только один IP-адрес, то для этого VLAN'а разрешен только один VR (виртуальный маршрутизатор).
  • Если в VLAN'е настроено несколько адресов (multinetted VLAN), то может быть настроено по одному VR для каждой сети.
  • Максимальное количество виртуальных маршрутизаторов -- 32, с любыми комбинациями Master и Backup.

[править] Настройка VRRP Master и Backup router

Включение VRRP (должен быть включен ip routing):

switch(config)# router vrrp

Предварительная IP конфигурация VLAN

  • на мастер коммутаторе
# show ip                                                                                        
                       |                                            Proxy ARP                            
  VLAN                 | IP Config  IP Address      Subnet Mask     Std  Local                           
  -------------------- + ---------- --------------- --------------- ----------                           
  DEFAULT_VLAN         | Manual     10.1.0.47    255.255.255.0      No    No                            
  servers              | Manual     10.0.5.1     255.255.255.0      No    No                            
  • на резервном коммутаторе
# show ip                                                                                        
                       |                                            Proxy ARP                            
  VLAN                 | IP Config  IP Address      Subnet Mask     Std  Local                           
  -------------------- + ---------- --------------- --------------- ----------                           
  DEFAULT_VLAN         | Manual     10.1.0.48    255.255.255.0      No    No                            
  servers              | Manual     10.0.5.2     255.255.255.0      No    No                            

Настройка VRRP в VLAN 5, создание конфигурационного контекста VRID 5:

switch(config)# vlan 5
switch(vlan-5)# vrrp vrid 5
switch(vlan-5-vrid-5)#

Настройка роли owner и virtual IP address 10.0.5.1 (адрес присвоенный коммутатору):

switch(vlan-5-vrid-5)# owner
switch(vlan-5-vrid-5)# virtual-ip-address 10.0.5.1/24

Настройка роли backup и virtual IP address 10.0.5.1 (адрес, который указывался на master router, как virtual IP address):

switch(vlan-5-vrid-5)# backup
switch(vlan-5-vrid-5)# virtual-ip-address 10.0.5.1/24 

Включение VRRP для VRID:

switch(vlan-5-vrid-5)# enable

Аналогичные операции надо повторить для всех VLAN, в которых будет использоваться VRRP.

[править] Настройка дополнительных параметров

Когда VR активен, то нельзя изменить такие параметры:

  • priority
  • advertisement interval
  • preempt mode
  • virtual IP address

Для того чтобы их можно было изменить, надо выключить VRRP для конкретного VRID.

[править] Preempt Mode

Preempt Mode настраивается только на Backup Router.

Если Master маршрутизатор вышел из строя, а Backup-маршрутизатор с наивысшим значением приоритета временно не доступен, то роль Master возьмет на себя Backup-маршрутизатор со следующим наивысшим значением приоритета.

Режим preempt влияет на то, станет ли Backup-маршрутизатор с наивысшим приоритетом Master-маршрутизатором, после того как вернется в рабочее состояние.

Если режим включен (по умолчанию режим включён), то в случае возвращения Backup-маршрутизатора с более высоким приоритетом в рабочее состояние, он станет Master-маршрутизатором.

Если отключить этот режим, то Backup Router, который заменил вышедший из строя Master Router, будет сохранять свою роль Master, даже когда вернётся в рабочее состояние Backup-маршрутизатор с более высоким приоритетом.

[править] Пинг виртуального IP-адреса Backup-маршрутизатора

В версии K.14.47 появилась возможность пинговать IP-адрес Backup-маршрутизатора. Эта возможность не является частью RFC 3768. Согласно RFC 3768, только владелец IP-адреса может отвечать на запросы ICMP.

После включения этой возможности Backup-маршрутизатор работающий в роли Master, может отвечать на ICMP-запросы, которые идут на виртуальный IP-адрес. Если Backup-маршрутизатор не выполняет роль Master, то он отбрасывает все пакеты, которые приходят на виртуальный IP-адрес.

По умолчанию эта возможность отключена.

Разрешить Backup-маршрутизатору отвечать на ICMP-запросы:

sw(config)# router vrrp virtual-ip-ping 

После включения этой команды, все виртуальные маршрутизаторы, которые не являются владельцами IP-адреса и которым не запрещено явно отправлять ответы на ICMP-запросы, отвечают на пришедшие ICMP-запросы, если они выполняют роль Master.

Для конкретного виртуального маршрутизатора можно отключить эту возможность:

sw(config)# vlan 100 vrrp vrid 1
sw(vlan-100-vrid-1)# backup 
sw(vlan-100-vrid-1)# virtual-ip-address 192.168.100.1/24
sw(vlan-100-vrid-1)# no virtual-ip-ping 
sw(vlan-100-vrid-1)# enable 
[править] Просмотр настроек

Глобальные настройки VRRP после включения возможности отправки ICMP-ответов Backup-маршрутизаторами:

sw(config)# sh vrrp config  global 

VRRP Global Configuration Information

 VRRP Enabled   : Yes         
 Traps Enabled  : Yes         
 Virtual Routers Respond To Ping Requests : Yes

Просмотр настроек для VLAN 100:

sw(config)# sh vrrp vlan 100 config 

VRRP Virtual Router Configuration Information

 Vlan ID : 100         
 Virtual Router ID : 1           

 Administrative Status [Disabled] : Enabled     
 Mode [Uninitialized] : Backup      
 Priority [100] : 100         
 Advertisement Interval [1] : 1           
 Preempt Mode [True] : True        
 Preempt Delay Time [0] : 0           
 Respond To Virtual IP Ping Requests [Yes] : No 
 Primary IP Address : Lowest

 IP Address      Subnet Mask    
 --------------- ---------------
 192.168.100.1   255.255.255.0  

Просмотр настроек для VLAN 200:

sw(config)# sh vrrp vlan 200 config 

VRRP Virtual Router Configuration Information

 Vlan ID : 200         
 Virtual Router ID : 1           

 Administrative Status [Disabled] : Enabled     
 Mode [Uninitialized] : Backup      
 Priority [100] : 100         
 Advertisement Interval [1] : 1           
 Preempt Mode [True] : True        
 Preempt Delay Time [0] : 0           
 Respond To Virtual IP Ping Requests [Yes] : Yes
 Primary IP Address : Lowest

 IP Address      Subnet Mask    
 --------------- ---------------
 192.168.200.1   255.255.255.0

[править] Варианты дизайна сетей

[править] VRRP и STP

  • Маршрутизатор, который выполняет роль VRRP Master, должен быть STP Root Bridge.
  • Маршрутизатор, который выполняет роль VRRP Backup, должен быть STP Backup Root Bridge.
  • Через порты, заблокированные STP (в состоянии blocked), коммутатор может принимать VRRP advertisement, но через эти порты он не отправляет полученные advertisement.

[править] VRRP и MSTP

[править] Пример сети с использованием VRRP и MSTP

Топология тестовой сети
[править] Настройки IP в тестовой сети

Настройки IP на коммутаторе sw3500:

sw3500# sh ip

  IP Routing : Enabled                                   

  VLAN                 | IP Config  IP Address      Subnet Mask     Proxy ARP
  -------------------- + ---------- --------------- --------------- ---------
  DEFAULT_VLAN         | Manual     10.1.1.1        255.255.255.0   No No 
  VLAN10               | Manual     10.1.10.1       255.255.255.0   No No 
  VLAN20               | Manual     10.1.20.1       255.255.255.0   No No 
  VLAN30               | Manual     10.1.30.2       255.255.255.0   No No
  VLAN40               | Manual     10.1.40.2       255.255.255.0   No No

Настройки IP на коммутаторе sw5400:

sw5400(config)# sh ip

  IP Routing : Enabled                                        

  VLAN                 | IP Config  IP Address      Subnet Mask     Proxy ARP
  -------------------- + ---------- --------------- --------------- ---------
  DEFAULT_VLAN         | Manual     10.1.1.2        255.255.255.0   No No
  VLAN10               | Manual     10.1.10.2       255.255.255.0   No No
  VLAN20               | Manual     10.1.20.2       255.255.255.0   No No
  VLAN30               | Manual     10.1.30.1       255.255.255.0   No No
  VLAN40               | Manual     10.1.40.1       255.255.255.0   No No
[править] Настройки MSTP

Настройки MSTP на коммутаторах sw3500, sw5400, sw4, sw5:

# show spanning-tree mst-config 

 MST Configuration Identifier Information

  MST Configuration Name : vrrp                            
  MST Configuration Revision : 1    
  MST Configuration Digest : 0xCA136A235706B316C8DB8F921067A68F

  IST Mapped VLANs : 1

  Instance ID Mapped VLANs                                             
  ----------- ---------------------------------------------------------
  1           10,20
  2           30,40

Для MST instanse 1:

  • sw3500 — Root Bridge (priority 0)
  • sw5400 — Backup Root Bridge (priority 1)

Для MST instanse 2:

  • sw3500 — Backup Root Bridge (priority 1)
  • sw5400 — Root Bridge (priority 0)
[править] Настройки VRRP

Настройки VRRP на коммутаторах:

VLAN Owner Backup VRID Virtual IP Address
1 sw3500 sw5400 1 10.1.1.1 /24
10 sw3500 sw5400 10 10.1.10.1 /24
20 sw3500 sw5400 20 10.1.20.1 /24
30 sw5400 sw3500 30 10.1.30.1 /24
40 sw5400 sw3500 40 10.1.40.1 /24


[править] Просмотр настроек

Виртуальные MAC-адреса:

sw5400(config)# sh arp

 IP ARP table

  IP Address       MAC Address       Type    Port
  ---------------  ----------------- ------- ----
  10.1.1.1         00005e-000101     dynamic A3  
  10.1.10.1        00005e-00010a     dynamic A3  
  10.1.20.1        00005e-000114     dynamic A3  


sw3500# sh arp

 IP ARP table

  IP Address       MAC Address       Type    Port
  ---------------  ----------------- ------- ----
  10.1.30.1        00005e-00011e     dynamic 3   
  10.1.40.1        00005e-000128     dynamic 3   

Настройки VRRP на коммутаторе sw3500 в VLAN 1:

sw3500# sh vrrp vlan 1 config 

 VRRP Virtual Router Configuration Information

  Vlan ID : 1           
  Virtual Router ID : 1           

  Administrative Status [Disabled] : Enabled     
  Mode [Uninitialized] : Owner       
  Priority [100] : 255         
  Advertisement Interval [1] : 1           
  Preempt Mode [True] : True        
  Preempt Delay Time [0] : 0           
  Primary IP Address : Lowest

  IP Address      Subnet Mask    
  --------------- ---------------
  10.1.1.1        255.255.255.0  

[править] Проверка работы VRRP

При обычной работе сети, когда все коммутаторы доступны, трафик с коммутатора sw4 в другие сети передается через коммутатор sw3500, так как он Master VRRP Router для VLAN 1:

sw3500(config)# sh vrrp vlan 1 

 VRRP Virtual Router Statistics Information

  Vlan ID                  : 1           
  Virtual Router ID        : 1           
  State                    : Master      
  Up Time                  : 48 mins   
  Virtual MAC Address      : 00005e-000101
  Master's IP Address      : 10.1.1.1       
  Associated IP Addr Count : 1          Near Failovers            : 0         
  Advertise Pkts Rx        : 0          Become Master             : 1         
  Zero Priority Rx         : 0          Zero Priority Tx          : 0         
  Bad Length Pkts          : 0          Bad Type Pkts             : 0         
  Mismatched Interval Pkts : 0          Mismatched Addr List Pkts : 0         
  Mismatched IP TTL Pkts   : 0          Mismatched Auth Type Pkts : 0         

Соответственно, в таблице ARP будет такая запись:

sw4(config)# sh arp

 IP ARP table

  IP Address      MAC Address       Type    Port
  --------------- ----------------- ------- ----
  10.1.1.1        00005e-000101     dynamic 23  

Коммутатор sw5400 выполняет роль Backup VRRP Router, если коммутатор sw3500 доступен:

sw5400(config)# sh vrrp vlan 1

 VRRP Virtual Router Statistics Information

  Vlan ID                  : 1           
  Virtual Router ID        : 1           
  State                    : Backup      
  Up Time                  : 74 mins   
  Virtual MAC Address      : 00005e-000101
  Master's IP Address      : 10.1.1.1       
  Associated IP Addr Count : 1          Near Failovers            : 2         
  Advertise Pkts Rx        : 3751       Become Master             : 4         
  Zero Priority Rx         : 0          Zero Priority Tx          : 0         
  Bad Length Pkts          : 0          Bad Type Pkts             : 0         
  Mismatched Interval Pkts : 0          Mismatched Addr List Pkts : 0         
  Mismatched IP TTL Pkts   : 0          Mismatched Auth Type Pkts : 0         

С компьютера m1 пингуется m4 и в это время перегружается коммутатор sw3500. Несколько ответов пропадает, а потом sw5400 становится Master VRRP Router и пинг возобновляется.

m1:~# ping 10.1.40.40
PING 10.1.40.40 (10.1.40.40) 56(84) bytes of data.
64 bytes from 10.1.40.40: icmp_seq=1 ttl=63 time=0.273 ms
64 bytes from 10.1.40.40: icmp_seq=2 ttl=63 time=0.334 ms
64 bytes from 10.1.40.40: icmp_seq=3 ttl=63 time=0.235 ms
64 bytes from 10.1.40.40: icmp_seq=4 ttl=63 time=0.288 ms
64 bytes from 10.1.40.40: icmp_seq=5 ttl=63 time=0.296 ms
64 bytes from 10.1.40.40: icmp_seq=6 ttl=63 time=0.248 ms
64 bytes from 10.1.40.40: icmp_seq=7 ttl=63 time=0.281 ms
64 bytes from 10.1.40.40: icmp_seq=11 ttl=63 time=0.258 ms
64 bytes from 10.1.40.40: icmp_seq=12 ttl=63 time=0.273 ms
64 bytes from 10.1.40.40: icmp_seq=13 ttl=63 time=0.288 ms
64 bytes from 10.1.40.40: icmp_seq=14 ttl=63 time=0.263 ms
64 bytes from 10.1.40.40: icmp_seq=15 ttl=63 time=0.291 ms
64 bytes from 10.1.40.40: icmp_seq=16 ttl=63 time=0.264 ms

--- 10.1.40.40 ping statistics ---
16 packets transmitted, 13 received, 18% packet loss, time 15008ms
rtt min/avg/max/mdev = 0.235/0.276/0.334/0.027 ms
m1:~# traceroute 10.1.40.40
traceroute to 10.1.40.40 (10.1.40.40), 30 hops max, 40 byte packets
 1   (10.1.10.2)  0.514 ms  0.496 ms  0.588 ms
 2   (10.1.40.40)  0.423 ms  0.418 ms  0.410 ms


Теперь sw5400 стал Master VRRP Router для VLAN 1:

sw5400(config)# sh vrrp vlan 1

 VRRP Virtual Router Statistics Information

  Vlan ID                  : 1           
  Virtual Router ID        : 1           
  State                    : Master      
  Up Time                  : 77 mins   
  Virtual MAC Address      : 00005e-000101
  Master's IP Address      : 10.1.1.2       
  Associated IP Addr Count : 1          Near Failovers            : 2         
  Advertise Pkts Rx        : 3851       Become Master             : 5         
  Zero Priority Rx         : 0          Zero Priority Tx          : 0         
  Bad Length Pkts          : 0          Bad Type Pkts             : 0         
  Mismatched Interval Pkts : 0          Mismatched Addr List Pkts : 0         
  Mismatched IP TTL Pkts   : 0          Mismatched Auth Type Pkts : 0         

Таблица ARP:

sw4(config)# sh arp

 IP ARP table

  IP Address      MAC Address       Type    Port
  --------------- ----------------- ------- ----
  10.1.1.1        00005e-000101     dynamic 24  

Так как все маршрутизаторы в одной группе VRRP разделяют один и тот же виртуальный MAC-адрес, то адрес не изменился. Изменился только порт через который он доступен, так как теперь это порт ведущий к коммутатору sw5400.

Пока коммутатор sw3500 недоступен, адреса 10.1.1.1, 10.1.10.1, 10.1.20.1 пинговаться не будут. Но трафик отправленный на эти адреса, как на шлюзы по умолчанию, передаваться будет.

Icon-caution.gif

Начиная с версии K.14.47 появилась возможность пинговать IP-адрес присвоенный виртуальному маршрутизатору, даже если владелец (owner) IP-адреса недоступен. О настройке этой возможности выше на этой странице.

Так как sw3500 владелец IP-адреса, который ассоциирован с виртуальным маршрутизатором, то после перезагрузки он опять станет Master-маршрутизатором.

[править] Конфигурационные файлы коммутаторов

sw3500:


Running configuration:

; J8692A Configuration Editor; Created on release #K.13.25

hostname "sw3500" 
module 1 type J86xxA 
interface 7 
   disable
exit
ip routing 
snmp-server community "public" Unrestricted 
vlan 1 
   name "DEFAULT_VLAN" 
   untagged 1-24 
   ip address 10.1.1.1 255.255.255.0 
   exit 
vlan 10 
   name "VLAN10" 
   ip address 10.1.10.1 255.255.255.0 
   tagged 1,3 
   exit 
vlan 20 
   name "VLAN20" 
   ip address 10.1.20.1 255.255.255.0 
   tagged 3,5 
   exit 
vlan 30 
   name "VLAN30" 
   ip address 10.1.30.2 255.255.255.0 
   tagged 1,3 
   exit 
vlan 40 
   name "VLAN40" 
   ip address 10.1.40.2 255.255.255.0 
   tagged 3,5 
   exit 
router vrrp
spanning-tree
spanning-tree config-name "vrrp"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 10 20
spanning-tree instance 1 priority 0
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 priority 1
spanning-tree priority 0
vlan 1
   vrrp vrid 1
      owner
      virtual-ip-address 10.1.1.1 255.255.255.0
      priority 255
      enable
      exit
   exit
vlan 10
   vrrp vrid 10
      owner
      virtual-ip-address 10.1.10.1 255.255.255.0
      priority 255
      enable
      exit
   exit
vlan 20
   vrrp vrid 20
      owner
      virtual-ip-address 10.1.20.1 255.255.255.0
      priority 255
      enable
      exit
vlan 20
   vrrp vrid 20
      owner
      virtual-ip-address 10.1.20.1 255.255.255.0
      priority 255
      enable
      exit
   exit
vlan 30
   vrrp vrid 30
      backup
      virtual-ip-address 10.1.30.1 255.255.255.0
      enable
      exit
   exit
vlan 40
   vrrp vrid 40
      backup
      virtual-ip-address 10.1.40.1 255.255.255.0
      enable
      exit
   exit

sw5400:

Running configuration:

; J8697A Configuration Editor; Created on release #K.13.23

hostname "5400" 
module 1 type J8705A 
interface A7 
   disable
exit
ip routing 
snmp-server community "public" Unrestricted 
vlan 1 
   name "DEFAULT_VLAN" 
   untagged A1-A24 
   ip address 10.1.1.2 255.255.255.0 
   exit 
vlan 10 
   name "VLAN10" 
   ip address 10.1.10.2 255.255.255.0 
   tagged A3,A5 
   exit 
vlan 20 
   name "VLAN20" 
   ip address 10.1.20.2 255.255.255.0 
   tagged A1,A3 
   exit 
vlan 30 
   name "VLAN30" 
   ip address 10.1.30.1 255.255.255.0 
   tagged A3,A5 
   exit 
vlan 40 
   name "VLAN40" 
   ip address 10.1.40.1 255.255.255.0 
   tagged A1,A3 
   exit 
router vrrp
spanning-tree
spanning-tree config-name "vrrp"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 10 20
spanning-tree instance 1 priority 1
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 priority 0
spanning-tree priority 1
vlan 1
   vrrp vrid 1
      backup
      virtual-ip-address 10.1.1.1 255.255.255.0
      enable
      exit
   exit
vlan 10
   vrrp vrid 10
      backup
      virtual-ip-address 10.1.10.1 255.255.255.0
      enable
      exit
   exit
vlan 20
   vrrp vrid 20
      backup
      virtual-ip-address 10.1.20.1 255.255.255.0
      enable
      exit
   exit
vlan 30
   vrrp vrid 30
      owner
      virtual-ip-address 10.1.30.1 255.255.255.0
      priority 255
      enable
      exit
   exit
vlan 40
   vrrp vrid 40
      owner
      virtual-ip-address 10.1.40.1 255.255.255.0
      priority 255
      enable
      exit
   exit

sw4:


Running configuration:

; J4906A Configuration Editor; Created on release #M.10.41

hostname "sw4" 
interface 1 
   disable
exit
interface 7 
   disable
exit
ip default-gateway 10.1.1.1 
snmp-server community "public" Unrestricted 
vlan 1 
   name "DEFAULT_VLAN" 
   untagged 13-48 
   ip address 10.1.1.3 255.255.255.0 
   no untagged 1-12 
   exit 
vlan 10 
   name "VLAN10" 
   untagged 1-6 
   no ip address 
   tagged 23-24 
   exit 
vlan 30 
   name "VLAN30" 
   untagged 7-12 
   no ip address 
   tagged 23-24 
   exit 
vlan 20 
   name "VLAN20" 
   no ip address 
   exit 
vlan 40 
   name "VLAN40" 
   no ip address 
   exit 
spanning-tree
spanning-tree protocol-version MSTP
spanning-tree config-name "vrrp"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 10 20
spanning-tree instance 2 vlan 30 40


sw5:


Running configuration:

; J4905A Configuration Editor; Created on release #M.10.41

hostname "sw5" 
interface 1 
   disable
exit
interface 7 
   disable
exit
ip default-gateway 10.1.1.1 
snmp-server community "public" Unrestricted 
vlan 1 
   name "DEFAULT_VLAN" 
   untagged 13-26 
   ip address 10.1.1.4 255.255.255.0 
   no untagged 1-12 
   exit 
vlan 20 
   name "VLAN20" 
   untagged 1-6 
   no ip address 
   tagged 23-24 
   exit 
vlan 40 
   name "VLAN40" 
   untagged 7-12 
   no ip address 
   tagged 23-24 
   exit 
vlan 10 
   name "VLAN10" 
   no ip address 
   exit 
vlan 30 
   name "VLAN30" 
   no ip address 
   exit 
spanning-tree
spanning-tree protocol-version MSTP
spanning-tree config-name "vrrp"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 10 20
spanning-tree instance 2 vlan 30 40


Источник — «http://xgu.ru/wiki/VRRP_%D0%B2_ProCurve»