Xgu.ru теперь в Контакте  — приходите и подключайтесь.
Пока мы работаем над следующими видео, вы можете подключиться в Контакте. Познакомимся и обсудим новые страницы и ролики.

Vk-big.pngYoutube-big.jpeg

HSRP в Cisco

Материал из Xgu.ru

Перейти к: навигация, поиск
stub.png
Данная страница находится в разработке.
Эта страница ещё не закончена. Информация, представленная здесь, может оказаться неполной или неверной.

Если вы считаете, что её стоило бы доработать как можно быстрее, пожалуйста, скажите об этом.


На этой странице описывается настройка протокола HSRP на маршрутизаторах и коммутаторах Cisco.

HSRP настраивается одинаково на маршрутизаторах и коммутаторах 3го уровня, настройки выполняются на интерфейсах 3го уровня. На маршрутизаторе это могут быть физические интерфейсы или подынтерфейсы, а на коммутаторе 3го уровня интерфейсы переведенные в режим работы на 3 уровне или SVI-интерфейсы (interface vlan).


Содержание

[править] Настройка на маршрутизаторах и коммутаторах

[править] Пример топологии

HSRP.png

[править] Включение HSRP на интерфейсе

Создание групп и назначение виртуальных IP-адресов на маршрутизаторах (включение HSRP):

dyn1(config-if)# standby [group-number] ip [ip-address [secondary]] 

Если не указывать номер группы в команде standby ip, то будет использоваться номер 0.

Note-icon.gif

В HSRP существует ещё большое количество настроек, которые могут быть выполнены после включения HSRP на интерфейсе. Однако, рекомендуется сначала выполнить все настройки (например, аутентификация, таймеры), а затем включить HSRP на интерфейсе.

Пример настройки двух групп для dyn1 и dyn3 (настройки одинаковые на обоих маршрутизаторах):

dyn1(config)# int fa0/0
dyn1(config-if)# standby 1 ip 192.168.1.11
dyn1(config-if)# standby 3 ip 192.168.1.33

Note-icon.gif

Хотя, для того чтобы HSRP работал достаточно указать виртуальный IP-адрес только на одном маршрутизаторе, Cisco рекомендует указывать адрес на всех маршрутизаторах.

[править] Изменение версии протокола

По умолчанию используется версия 1.

dyn3(config-if)# standby version 2

[править] Задание имени группы

Пример настройки имени для группы 1 на маршрутизаторе dyn1:

dyn1(config-if)# standby 1 name DYN1-Act

Имя группы имеет локальное значение.

Имя группы используется для связки HSRP с другими функциями маршрутизатора. Например, при использовании HSRP вместе с IPsec или NAT.

[править] Настройка приоритета маршрутизатора

Настройка приоритета. Диапазон значений от 0 до 255 (по умолчанию значение 100):

dyn1(config-if)# standby [group-number] priority <priority> [preempt [delay <delay>]] 

Изменение приоритета по умолчанию для группы 1 на dyn1 (на dyn3 аналогично изменен приоритет для группы 3):

dyn1(config)# int fa0/0
dyn1(config-if)# standby 1 priority 101

[править] Настройка preempt

Режим preempt позволяет маршрутизатору с более высоким приоритетом перехватывать роль active маршрутизатора. По умолчанию режим preempt выключен.

Команда preempt:

dyn1(config-if)# standby [group-number] preempt [delay <minimum <delay> | reload <delay> | sync <delay>>]

Параметры команды:

  • delay -- позволяет указать задержку перехвата роли маршрутизатора. При включении у маршрутизатора ещё не заполнена таблица маршрутизации. Если он сразу перехватит роль active маршрутизатора, то, возможно, он не сможет передавать трафик некоторое время. Задержка позволяет маршрутизатору заполнить таблицу маршрутизации. По умолчанию значение параметра 0, то есть, маршрутизатор перехватывает роль немедленно.

Включение режима preempt:

dyn1(config-if)# standby preempt

[править] Виртуальный MAC-адрес

dyn1(config-if)# standby [group-number] mac-address <mac-address>
dyn1(config-if)# standby use-bia [scope <interface>]

[править] Track

dyn1(config-if)# standby [group-number] track <type number> [interface-priority] 

Параметры команды:

  • interface-priority -- значение на которое приоритет маршрутизатора понизится, если интерфейс недоступен и повысится снова когда интерфейс поднимется. По умолчанию значение 10.

[править] Пример настройки

Пример настройки для маршрутизатора dyn1. Отслеживается состояние интерфейса fa1/0. Если интерфейс не работает, то все HSRP-группы на интерфейсе fa0/0 будут выключены.

Настройка track:

dyn1(config)# track 1 interface fa1/0 line-protocol

Настройка выключения группы 1:

dyn1(config)# int fa0/0
dyn1(config-if)# standby 1 track 1 shutdown 

Просмотр информации:

dyn1# sh track  br
Track   Object                           Parameter        Value Last Change
1       interface   FastEthernet1/0      line-protocol    Up    00:05:52

Если теперь выключить интерфейс fa1/0, то группы 1 и 3 на интерфейсе fa0/0 перейдут в состояние Init:

dyn1# sh stand br   
                   P indicates configured to preempt.
                   |
Interface Grp  Pri P State   Active          Standby         Virtual IP
Fa0/0     1    101 P Init    unknown         192.168.1.3     192.168.1.11
Fa0/0     3    100 P Init    192.168.1.3     unknown         192.168.1.33

[править] Настройка таймеров

Значение таймеров для всех маршрутизаторов в одной группе должно быть одинаковое. Значения таймеров маршрутизатор может получить от active маршрутизатора.

Изменение таймеров HSRP на интерфейсе:

dyn1(config-if)# standby [group-number] timers <hellotime> <holdtime>

Параметры команды:

  • hellotime -- по умолчанию 3 секунды. Значение в секундах, диапазон значений от 1 до 255;
  • holdtime -- по умолчанию 10 секунд. Значение в секундах, диапазон значений от 1 до 255.

Изменение таймеров для группы 1 на dyn1:

dyn1(config-if)# standby 1 timers 5 15

Так как dyn1 для группы 1 является active маршрутизатором, то аналогичные значения таймеров в этой группе будут и для dyn3.

Если, например, изменить таймеры на маршрутизаторе dyn1 для группы 3, в то время как он не является для неё active маршрутизатором, то реально использоваться будут таймеры пришедшие от active маршрутизатора (dyn3). Если dyn1 станет active в группе 3, то тогда будут использоваться настроенные таймеры.

Пример отображения информации о dyn1, когда для группы 3 он является standby и таймеры отличные от настроенных на active:

dyn1# show standby 
FastEthernet0/0 - Group 1
 State is Active
   5 state changes, last state change 00:21:37
 Virtual IP address is 192.168.1.11
 Active virtual MAC address is 0000.0c07.ac01
   Local virtual MAC address is 0000.0c07.ac01 (v1 default)
 Hello time 5 sec, hold time 15 sec
   Next hello sent in 4.312 secs
 Preemption disabled
 Active router is local
 Standby router is 192.168.1.3, priority 100 (expires in 12.904 sec)
 Priority 101 (configured 101)
 IP redundancy name is "hsrp-Fa0/0-1" (default)
FastEthernet0/0 - Group 3
 State is Standby
   4 state changes, last state change 00:21:21
 Virtual IP address is 192.168.1.33
 Active virtual MAC address is 0000.0c07.ac03
   Local virtual MAC address is 0000.0c07.ac03 (v1 default)
 Hello time 3 sec (cfgd 5 sec), hold time 10 sec (cfgd 15 sec)
   Next hello sent in 0.556 secs
 Preemption disabled
 Active router is 192.168.1.3, priority 101 (expires in 8.216 sec)
 Standby router is local
 Priority 100 (default 100)
 IP redundancy name is "hsrp-Fa0/0-3" (default)
dyn1#

[править] Настройка аутентификации

Пример настройки аутентификации для двух групп на маршрутизаторе dyn1:

dyn1(config-if)# standby 1 authentication Cisco
dyn1(config-if)# standby 3 authentication Cisco

[править] Настройка параметров HSRP Gratuitous ARP

dyn1(config-if)# standby arp gratuitous
dyn1(config-if)# standby send arp

Note-icon.gif

Версия IOS.

[править] Задержка включения HSRP на интерфейсе

dyn1(config-if)# standby delay minimum <min-seconds> reload <reload-seconds>

[править] Отправка trap протокола HSRP

dyn1(config)# snmp-server enable traps hsrp 
dyn1(config)# snmp-server host 192.168.2.100 public hsrp

[править] Просмотр информации

Варианты команд просмотра настроек:

dyn1# show standby ?
  FastEthernet  FastEthernet IEEE 802.3
  Port-channel  Ethernet Channel of interfaces
  all           Include groups in disabled state
  brief         Brief output
  capability    HSRP capability
  delay         Group initialisation delay
  internal      Internal HSRP information
  neighbors     HSRP neighbors
  redirect      HSRP ICMP redirect information
  |             Output modifiers
  <cr>

Просмотр краткой информации о группах:

dyn1# show standby brief 
                   P indicates configured to preempt.
                   |
Interface Grp  Pri P State   Active          Standby         Virtual IP
Fa0/0     1    101 P Active  local           192.168.1.3     192.168.1.11
Fa0/0     3    100 P Standby 192.168.1.3     local           192.168.1.33

Просмотр информации о всех включенных группах HSRP:

dyn1# show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active
    13 state changes, last state change 01:35:21
    Track object 1 state Up
  Virtual IP address is 192.168.1.11
  Active virtual MAC address is 0016.3e01.0001
    Local virtual MAC address is 0016.3e01.0001 (bia)
  Hello time 5 sec, hold time 15 sec
    Next hello sent in 0.368 secs
  Authentication text "Cisco"
  Preemption enabled
  Active router is local
  Standby router is 192.168.1.3, priority 100 (expires in 13.056 sec)
  Priority 101 (configured 101)
  IP redundancy name is "DYN1-Act" (cfgd)
FastEthernet0/0 - Group 3 (version 2)
  State is Standby
    22 state changes, last state change 01:34:53
    Track object 1 state Up
  Virtual IP address is 192.168.1.33
  Active virtual MAC address is 0016.3e01.0201
    Local virtual MAC address is 0016.3e01.0001 (bia)
  Hello time 5 sec, hold time 15 sec
    Next hello sent in 4.196 secs
  Authentication text "Cisco"
  Preemption enabled
  Active router is 192.168.1.3, priority 101 (expires in 11.880 sec)
  Standby router is local
  Priority 100 (default 100)
  IP redundancy name is "DYN3-Act" (cfgd)

Просмотр информации группе 1 на интерфейсе fa0/0:

dyn1# show standby fa 0/0 1
FastEthernet0/0 - Group 1 (version 2)
  State is Active
    13 state changes, last state change 01:41:46
    Track object 1 state Up
  Virtual IP address is 192.168.1.11
  Active virtual MAC address is 0016.3e01.0001
    Local virtual MAC address is 0016.3e01.0001 (bia)
  Hello time 5 sec, hold time 15 sec
    Next hello sent in 0.792 secs
  Authentication text "Cisco"
  Preemption enabled
  Active router is local
  Standby router is 192.168.1.3, priority 100 (expires in 13.412 sec)
  Priority 101 (configured 101)
  IP redundancy name is "DYN1-Act" (cfgd)

Просмотр информации о настроенных значениях задержки:

dyn1# sh standby delay 
Interface          Minimum Reload 
FastEthernet0/0    1       5      

Просмотр информации о соседях:

dyn1# show standby neighbors 
HSRP neighbors on FastEthernet0/0
  192.168.1.3
    Active groups: 3
    Standby groups: 1

Просмотр информации о настройках ICMP redirect:

dyn1# show standby redirect 
Interface          Redirects Unknown   Adv      Holddown
FastEthernet0/0    enabled   enabled   30       180     

Active                Hits  Interface Group Virtual IP            Virtual MAC
local                 0     Fa0/0     1     192.168.1.11          0016.3e01.0001
192.168.1.3           0     Fa0/0     3     192.168.1.33          0016.3e01.0201

[править] Пример настройки HSRP на коммутаторах 3го уровня

Topology HSRP.png

На рисунке изображена топология, которая будет использоваться в данном примере. Настройка HSRP будет выполняться для коммутаторов DSW1 и DSW2.

На коммутаторах DSW1 и DSW2 порты Po1, Po2 и Po3 это агрегированные каналы (EtherChannel), которые переведены в режим 3го уровня и не описаны в настройках.

[править] IP-адресация и VLAN

На рисунке отмечены VLAN:

  • VLAN 101 (зелёный)
  • VLAN 102 (красный)
  • VLAN 103 (синий)
  • VLAN 104 (оранжевый)

Принципы назначения адресов одинаковы для всех VLAN, меняется только третий октет в адресах. Адресация на примере VLAN 101:

  • Сеть 10.0.1.0/24
  • Адрес 10.0.1.1 используется как шлюз по умолчанию для хостов. Это виртуальный адрес HSRP группы
  • По DHCP хостам выдаются адреса 10.0.1.50-254 и шлюз 10.0.1.1. IP-адрес DHCP-сервера 10.0.100.100
  • Адреса 10.0.1.2 и 10.0.1.3 используются DSW1 и DSW2, соответственно

[править] Spanning-tree

Топология построена таким образом, чтобы в ней не было петель на канальном уровне. Однако, на коммутаторах включен Rapid-PVST+ для защиты от случайных петель.

[править] Настройка HSRP на примере VLAN 101 коммутатора DSW1

interface Vlan101

# IP-адрес VLAN 101
 ip address 10.0.1.2 255.255.255.0

# IP-адрес DHCP-сервера
 ip helper-address 10.0.100.100

# Настройка виртуального IP-адреса. Он раздается хостам по DHCP как шлюз по умолчанию
 standby 1 ip 10.0.1.1

# По умолчанию приоритет 100.
# Для того чтобы маршрутизатор стал Active для этого VLAN, настроен более высокий приоритет
 standby 1 priority 120

# Режим preempt разрешает маршрутизатору с бОльшим приоритетом перехватывать роль Active
 standby 1 preempt

# Для того чтобы Backup-маршрутизатор быстрее становился Active,
# в случае выхода из строя предыдущего Active, понижены таймеры (по умолчанию таймеры 3 и 10 секунд)
 standby 1 timers 1 3

# Настроено отслеживание состояние интерфейсов, которые ведут к ядру сети.
# Если статус одного из интерфейсов станет down, то приоритет маршрутизатора понизится на 20.
# Если оба интерфейса -- станет равным 80.
 standby 1 track Port-channel1 20
 standby 1 track Port-channel2 20

[править] Конфигурация коммутаторов

[править] DSW1 и DSW2

!
hostname DSW1
!
!
ip routing
!
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 101,102
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 103,104
 switchport mode trunk
!
!
interface Vlan101
 ip address 10.0.1.2 255.255.255.0
 ip helper-address 10.0.100.100
 standby 1 ip 10.0.1.1
 standby 1 timers 1 3
 standby 1 priority 120
 standby 1 preempt
 standby 1 track Port-channel1 20
 standby 1 track Port-channel2 20
!
interface Vlan102
 ip address 10.0.2.2 255.255.255.0
 ip helper-address 10.0.100.100
 standby 1 ip 10.0.2.1
 standby 1 timers 1 3
 standby 1 priority 120
 standby 1 preempt
 standby 1 track Port-channel1 20
 standby 1 track Port-channel2 20
!
interface Vlan103
 ip address 10.0.3.2 255.255.255.0
 ip helper-address 10.0.100.100
 standby 1 ip 10.0.3.1
 standby 1 timers 1 3
 standby 1 preempt
!
interface Vlan104
 ip address 10.0.4.2 255.255.255.0
 ip helper-address 10.0.100.100
 standby 1 ip 10.0.4.1
 standby 1 timers 1 3
 standby 1 preempt


!
hostname DSW2
!
!
ip routing
!
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 103,104
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 101,102
 switchport mode trunk
!
!
interface Vlan101
 ip address 10.0.1.3 255.255.255.0
 ip helper-address 10.0.100.100
 standby 1 ip 10.0.1.1
 standby 1 timers 1 3
 standby 1 preempt
!
interface Vlan102
 ip address 10.0.2.3 255.255.255.0
 ip helper-address 10.0.100.100
 standby 1 ip 10.0.2.1
 standby 1 timers 1 3
 standby 1 preempt
!
interface Vlan103
 ip address 10.0.3.3 255.255.255.0
 ip helper-address 10.0.100.100
 standby 1 ip 10.0.3.1
 standby 1 timers 1 3
 standby 1 priority 120
 standby 1 preempt
 standby 1 track Port-channel1 20
 standby 1 track Port-channel2 20
!
interface Vlan104
 ip address 10.0.4.3 255.255.255.0
 ip helper-address 10.0.100.100
 standby 1 ip 10.0.4.1
 standby 1 timers 1 3
 standby 1 priority 120
 standby 1 preempt
 standby 1 track Port-channel1 20
 standby 1 track Port-channel2 20

[править] ASW1 и ASW2

!
hostname ASW1
!
!
interface FastEthernet0/1
 switchport mode access
 switchport access vlan 101
!
interface FastEthernet0/2
 switchport mode access
 switchport access vlan 102
!
!
interface GigabitEthernet0/23
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 101,102
 switchport mode trunk
!
interface GigabitEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 101,102
 switchport mode trunk
!
!
hostname ASW2
!
!
interface FastEthernet0/1
 switchport mode access
 switchport access vlan 103
!
interface FastEthernet0/2
 switchport mode access
 switchport access vlan 104
!
!
interface GigabitEthernet0/23
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 103,104
 switchport mode trunk
!
interface GigabitEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 103,104
 switchport mode trunk
!

[править] NAT и HSRP

Использование HSRP вместе с трансляцией адресов описано на странице Cisco NAT.

[править] Конфигурация маршрутизаторов

[править] dyn1

!
version 12.4
!
hostname dyn1
!
track 1 interface FastEthernet1/0 line-protocol
! 
!
!
interface Loopback0
 ip address 1.1.1.1 255.0.0.0
!         
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 standby use-bia
 standby version 2
 standby 1 ip 192.168.1.11
 standby 1 timers 5 15
 standby 1 priority 101
 standby 1 preempt
 standby 1 authentication Cisco
 standby 1 name DYN1-Act
 standby 1 track 1 shutdown
 standby 3 ip 192.168.1.33
 standby 3 timers 5 15
 standby 3 preempt
 standby 3 authentication Cisco
 standby 3 name DYN3-Act
 standby 3 track 1 shutdown
!         
interface FastEthernet1/0
 ip address 192.168.2.1 255.255.255.0

[править] dyn3

!
version 12.4
!
hostname dyn3
!
track 1 interface FastEthernet1/0 line-protocol
!
!
interface Loopback0
 ip address 3.3.3.3 255.0.0.0
!
interface FastEthernet0/0
 ip address 192.168.1.3 255.255.255.0
 standby use-bia
 standby version 2
 standby 1 ip 192.168.1.11
 standby 1 timers 5 15
 standby 1 authentication Cisco
 standby 1 name DYN1-Act
 standby 3 ip 192.168.1.33
 standby 3 timers 5 15
 standby 3 priority 101
 standby 3 authentication Cisco
 standby 3 name DYN3-Act
!
interface FastEthernet1/0
 ip address 192.168.2.3 255.255.255.0
!

[править] Дополнительная информация

Источник — «http://xgu.ru/wiki/HSRP_%D0%B2_Cisco»