Xgu.ru теперь в Контакте  — приходите и подключайтесь.
Пока мы работаем над следующими видео, вы можете подключиться в Контакте. Познакомимся и обсудим новые страницы и ролики.

Vk-big.pngYoutube-big.jpeg

DHCP

Материал из Xgu.ru

Перейти к: навигация, поиск
stub.png
Данная страница находится в разработке.
Эта страница ещё не закончена. Информация, представленная здесь, может оказаться неполной или неверной.

Если вы считаете, что её стоило бы доработать как можно быстрее, пожалуйста, скажите об этом.


DHCP (Dynamic Host Configuration Protocol/протокол динамической конфигурации узла) — это сетевой протокол, позволяющий компьютерам автоматически получать IP-адрес и другие параметры, необходимые для работы в сети TCP/IP.

Содержание

[править] Настройка DHCP-сервера на маршрутизаторе Cisco

[править] Включение DHCP-сервера на маршрутизаторе Cisco

По умолчанию на маршрутизаторах Cisco включена функциональная возможность DHCP-сервера.

Если же она не активирована, то это возможно сделать командой:

Router(config)# service dhcp

Отключить данную функциональную возможность:

Router(config)# no service dhcp 

[править] Базовые настройки DHCP-сервера на маршрутизаторе Cisco

  1. Настройка соединения между коммутатором и маршрутизатором
  2. Настройка DHCP-сервера

Пример топологии (данная топология не является рекомендацией, а используется просто в качестве примера):

Dhcp dot1q.jpeg

Необходимо настроить порт коммутатора fa0/11 для передачи трафика нескольких VLAN маршрутизатору.

На интерфейсе маршрутизатора fa0/0:

  1. Создать интерфейс для каждого VLAN'а (подсети)
  2. Настроить инкапсуляцию 802.1q и указать номер VLAN'а
  3. Задать на них адрес из соответствующей подсети

Подробное описание процедуры настройки VLAN'ов на коммутаторах и маршрутизаторах Cisco можно прочитать на странице VLAN.

[править] Настройка пула DHCP

Настройка DHCP-пула на маршрутизаторе (аналогичным образом настраиваются пулы для каждой подсети) и указание шлюза по умолчанию для клиентов:

Router(config)# service dhcp
Router(config)# ip dhcp pool guest                             
Router(config-pool)# network 192.168.20.0 255.255.255.0
Router(config-pool)# default-router 192.168.20.1                

Как дополнительные параметры в пуле можно описать:

  1. Имя домена для DHCP-клиента - domain-name
  2. DNS-сервер - dns-server
  3. Сервер WINS для сетей microsoft - netbios-name-server
Router(config-pool)# domain-name test.kv.ua                    
Router(config-pool)# dns-server 192.168.20.101
Router(config-pool)# netbios-name-server 192.168.20.101
[править] Исключение IP-адресов

Исключить из пула адрес интерфейса маршрутизатора и DNS-сервера:

Router(config)# ip dhcp excluded-address 192.168.20.1
Router(config)# ip dhcp excluded-address 192.168.20.101

[править] Ручное резервирование IP-адресов

Есть возможность вручную сопоставить определенный MAC-адрес с необходимым IP-адресом.

Router(config)# ip dhcp pool Test
Router(config-pool)#host 192.168.2.4 255.255.255.0
Router(config-pool)#client-identifier 0100.0476.106c.bc
Router(config-pool)#client-name Test

В данной конструкции необходимо указать:

  1. адрес, который будет сопоставлен с физическим адресом: host address [mask | prefix-length]
  2. физический адрес (идентификатор) сетевой карты: client-identifier unique-identifier
  3. имя клиента: client-name name

Icon-caution.gif

Для microsoft сетей идентификатором данной сети является 01 ПЕРЕД MAC-адресом. Для UNIX сетей необходимо проставлять 00

То есть, для компьютера с MAC-адресом 00.04.76.10.6c.bc, который работает в среде Windows строчка client-identifier будет выглядеть как:

Router(config-pool)#client-identifier 0100.0476.106c.bc

Для компьютера с MAC-адресом 00.04.76.10.6c.bc который работает в среде UNIX строчка client-identifier будет выглядеть как:

Router(config-pool)#client-identifier 0000.0476.106c.bc

Пример:

Router(config)#ip dhcp pool glh-pc-5443
Router(config-pool)#host 10.84.130.10 255.255.255.0
Router(config-pool)#client-identifier 0100.2264.15c4.96
Router(config-pool)#client-name glh-pc-5443
Router(config-pool)#domain-name glh.sm.aval

Router(config)#ip dhcp pool glh-pc-5436
Router(config-pool)#host 10.84.130.15 255.255.255.0
Router(config-pool)#client-identifier 0100.2264.15c3.64
Router(config-pool)#client-name glh-pc-5436
Router(config-pool)#domain-name glh.sm.aval

Router(config)#ip dhcp pool glh-pc-2342
Router(config-pool)#host 10.84.130.42 255.255.255.0
Router(config-pool)#client-identifier 0100.0cf1.7ffd.03
Router(config-pool)#client-name glh-pc-2342
Router(config-pool)#domain-name glh.sm.aval

Router(config)#ip dhcp pool glh-pc-2325
Router(config-pool)#host 10.84.130.101 255.255.255.0
Router(config-pool)#client-identifier 0100.07e9.594f.bf
Router(config-pool)#client-name glh-pc-2325
Router(config-pool)#domain-name glh.sm.aval

Note-icon.gif

Для каждого статического соответствия необходимо создавать отдельный пул.

[править] Настройка агента DHCP базы данных

База данных DHCP-агента может находится как на любом сетевом ресурсе (ftp, TFTP, или RCP сервере), так и на flash памяти. При этом база DHCP-сервера содержит всю его информацию. Имеется возможность настроить DHCP-сервер на использование нескольких агентов, для обновления и размещения баз DHCP-сервера несколькими агентами.

Для настройки агента базы DHCP-сервера и параметров агента, используется команда:

Router(config)# ip dhcp database url [timeout seconds | write-delay seconds] 

Например:

router(config)#ip dhcp database ftp://user:password@172.16.1.1/router-dhcp timeout 80

для отключения агента базы данных DHCP-сервера:

Router(config)# no ip dhcp conflict logging

[править] Дополнительные настройки DHCP

Время аренды IP-адреса от 0 до 365 дней(в эмуляторе PT - не поддерживается):

(dhcp-config)# lease 5

[править] Параметры конфигурации DHCP

Возможно так же описывать dhcp-options - Параметры конфигурации DHCP. Это необходимо делать с помощью ключевого слова options название значение
Пример:

Router(config)#ip dhcp pool phone2
Router(config-pool)#host 10.84.202.22 255.255.255.224
Router(config-pool)#client-identifier 0100.0ab8.268f.c7
Router(config-pool)#dns-server 10.84.242.102
Router(config-pool)#default-router 10.84.242.102
Router(config-pool)#domain-name pech3.xgu.ru
Router(config-pool)#client-name phone2
Router(config-pool)#option 66 ip 10.44.2.1 10.44.2.2

Для выдачи клиентам статических маршрутов необходимо использовать опцию 33

Router(config)#ip dhcp pool poolname
Router(config-pool)#network 172.17.0.0 255.255.248.0
Router(config-pool)#default-router 172.17.0.1
Router(config-pool)#dns-server 10.84.242.102
Router(config-pool)#domain-name pech3.xgu.ru
Router(config-pool)#option 33 ip 10.84.242.102 172.17.0.1
Router(config-pool)#option 31 hex 01

Опция 31 говорит клиенту периодически проверять информацию у сервера DHCP о маршрутах и шлюзе по умолчанию.

[править] Настройка загрузочного файла для DHCP-сервера

Что бы задать имя загрузочного образа загрузочного файла необходимо выполнить команду

bootfile filename

Пример

Router(config)#ip dhcp pool sm7.sm.aval
Router(dhcp-config)#bootfile SM7

[править] Настройка идентификации конфликтов IP-адресов

Во время процесса назначения адреса DHCP-сервер проверяет, что предлагаемый адрес не используется. Для этого он до отправки ответа DHCP-клиенту посылает по предлагаемому адресу серию ping-пакетов. Если адрес уже используется, то он протоколируется как конфликтный и не предлагается до тех пор, пока администратор сети не разрешит конфликт. По умолчанию DHCP-сервер пингует IP-адрес из пула дважды, прежде чем назначает его клиенту. Если ответа на запрос ICMP не было, то DHCP-сервер считает, что адрес не используется и присваивает его клиенту, который его запрашивал.

По умолчанию DHCP-сервер ждет две секунды ответ, а затем повторяет ICMP запрос.

Эти параметры можно изменить.

Изменить количество отправляемых ICMP запросов (0 отключает ping):

ip dhcp ping packets <0-10>

Изменение таймаута между запросами:

Router(config)# ip dhcp ping timeout 300

[править] Очистка таблицы соответствия динамически выданных адресов

Очистки таблицы соответствия физических адресов и адресов выданных с пула DHCP-сервером:

Router#clear ip dhcp binding

Очистить привязку для конкретного IP-адреса:

Router# clear ip dhcp binding 10.84.168.181

[править] Просмотр информации про DHCP

[править] Просмотр информации, о выданных адресах

Просмотр информации об адресах, которые были выданы DHCP-сервером:

Router# show ip dhcp binding

Если для этой команды указать в качестве необязательного параметра IP-адрес, то будет показана информация о привязке для этого конкретного адреса.

Router# show ip dhcp binding 10.84.130.42

В выводимой информации показываются текущие данные о выделенных и назначенных адресах, соответствующий МАС-адрес DHCP-клиента и время истечения срока аренды адреса

IP address Hardware address Lease expiration Type
192.168.1.89 afa0.9802.32de Jun 11 2012 12:00 AM Automatic
192.168.1.156 afa0.9478.43ae Jun 11 2012 1:00 AM Automatic

[править] Просмотр информации о конфликтах, при назначении IP-адресов

Router# show ip dhcp conflict

IP address Detection Method Detection time
192.168.1.126 PingJul 02 2000 12:28 AM
192.168.1.254 Gratuitous ARP Jul 02 2000 01:12 AM

В столбце Detection Method указывается метод, использованный DHCP-сервером для определения конфликтности адреса. Если указан метод обнаружения ping, то это говорит о том, что перед назначением адреса DHCP-сервер сделал попытку пропинговать этот адрес и получил успешный ответ. Метод обнаружения Gratuitious ARP (метод беспричинного разрешения адреса) означает, что до выделения адреса DHCP-сервер обнаружил в своей ARP-таблице текущую и достоверную ARP-запись для этого адреса. Наличие ссылки на любой из этих методов говорит о том, что адрес, вероятно,используется (может быть, это результат несанкционированного использования, а возможно,кто-то забыл внести адрес в список исключаемых адресов).

[править] Информация о состоянии базы IP-адресов

Если раньше было описано место хранения базы данных DHCP:

Router(config)#ip dhcp database url [timeout seconds | write-delay seconds]

то возможно посмотреть информацию о состоянии этой базы данных:

Router# show ip dhcp database

URL      : ftp://ftp.sm.aval/sm7/basessm7.txt
Read     : Never
Written  : Feb 27 2009 11:20 AM
Status   : Last write succeeded. Agent information is up-to-date.
Delay    : 120 seconds
Timeout  : 300 seconds
Failures : 0
Successes: 400

[править] Просмотр статистики DHCP-сервера:

Router# show ip dhcp server statistics
Memory usage         27543
Address pools        1
Database agents      1
Automatic bindings   13
Manual bindings      0
Expired bindings     365
Malformed messages   0
Secure arp entries   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         460
DHCPREQUEST          8355
DHCPDECLINE          2
DHCPRELEASE          0
DHCPINFORM           2130

Message              Sent
BOOTREPLY            0
DHCPOFFER            460
DHCPACK              10329
DHCPNAK              5

[править] Настройка DHCP в Linux

[править] Настройка DHCP в Windows 2003

[править] Примеры конфигураций

[править] Пример конфигурации маршрутизатора Cisco

!
version 12.4
!
hostname Router
!
!
ip dhcp excluded-address 192.168.20.1
ip dhcp excluded-address 192.168.30.1
ip dhcp excluded-address 192.168.40.1
ip dhcp excluded-address 192.168.50.1
ip dhcp excluded-address 192.168.90.1
!
ip dhcp pool guest
   network 192.168.20.0 255.255.255.0
   default-router 192.168.20.1 
!
ip dhcp pool marketing
   network 192.168.30.0 255.255.255.0
   default-router 192.168.30.1 
!
ip dhcp pool sales
   network 192.168.40.0 255.255.255.0
   default-router 192.168.40.1 
!
ip dhcp pool restricted
   network 192.168.50.0 255.255.255.0
   default-router 192.168.50.1 
!
ip dhcp pool unauthenticated
   network 192.168.90.0 255.255.255.0
   default-router 192.168.90.1 
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
!
interface FastEthernet0/0.40
 encapsulation dot1Q 40
 ip address 192.168.40.1 255.255.255.0
!
interface FastEthernet0/0.50
 encapsulation dot1Q 50
 ip address 192.168.50.1 255.255.255.0
!
interface FastEthernet0/0.90
 encapsulation dot1Q 90
 ip address 192.168.90.1 255.255.255.0
!


[править] Материалы по DHCP на Xgu.ru

Источник — «http://xgu.ru/wiki/DHCP»