Xgu.ru теперь в Контакте  — приходите и подключайтесь.
Пока мы работаем над следующими видео, вы можете подключиться в Контакте. Познакомимся и обсудим новые страницы и ролики.

Vk-big.pngYoutube-big.jpeg

Резервирование Интернет-каналов без использования BGP/Lab

Материал из Xgu.ru

Перейти к: навигация, поиск
Автор: Наташа Самойленко

На странице описываются лабораторные к курсу по настройке резервирования Интернет-каналов без использования BGP.

К сожалению, сейчас на странице отсутствуют финальные конфигурации устройств, есть только пошаговое выполнение задания. Конфигурации будут, по возможности, добавлены позже.

При использовании этой информации обратите внимание на то, что это учебный материал. Не все сценарии и решения могут соответствовать реальной жизни.

Основная задача лабораторных показать какие механизмы доступны для резервирования Интернет-каналов без использования BGP.

Icon-caution.gif

На этой странице находятся только лабораторные.

Описание технологий, который нужны для настройки резервирования на Cisco, описаны на странице Резервирование Интернет-каналов без использования BGP


Содержание

[править] Лабораторная 1. Настройка резервирования каналов в сети с одним пограничным маршрутизатором и двумя каналами к разным провайдерам. Без балансировки нагрузки

Backup lab 1.png

[править] Задание

Локальная сеть подключена к двум провайдерам. ISP1 это основной провайдер, ISP2 используется в случае недоступности ISP1.

  1. Настройка IP-адресации
    Необходимо выполнить настройку IP-адресации в сети в соответствии с топологией.
    Если не указано явно, то 4 октет IP-адреса, соответствует номеру маршрутизатора.
  2. Настройка трансляции адресов с учётом исходящего интерфейса
    В зависимости от того, какой маршрут по умолчанию используется (через ISP1 или через ISP2), адреса локальной сети должны транслироваться в диапазон адресов соответствующего провайдера.
    Диапазон локальных адресов 10.0.100.0/24 должен транслироваться в IP-адрес интерфейсов fa1/0 или fa2/0 соответственно.
  3. Настройка IP SLA для мониторинга доступности провайдера
    Настроить IP SLA для проверки доступности ISP1. Тест должен периодически (каждые 3 секунды) отправлять ICMP-пакеты на IP-адрес пограничного маршрутизатора провайдера или другого ресурса в сети провайдера и ожидать ответа на них 500ms. Тест должен быть запущен с момента настройки и работать постоянно.
  4. Привязка результатов IP SLA через track к статическим маршрутам по умолчанию
    Настроить track для мониторинга доступности ISP1.
    Настроить в track задержки на переход в состояния UP и DOWN.
    Создать статические маршруты так, чтобы основным был маршрут на ISP1, а в случае его недоступности, поднимался маршрут на ISP2.
  5. Проверка настроек. Тестирование переключения на ISP2 при недоступности ISP1.
  6. Настройка правил для автоматической очистки таблицы трансляций при переключении на другого провайдера с помощью EEM.


[править] Пошаговая настройка

[править] Настройка IP-адресации

Необходимо выполнить настройку IP-адресации в сети в соответствии с топологией. Если не указано явно, то 4 октет IP-адреса, соответствует номеру маршрутизатора.

[править] Настройка трансляции адресов

Настройка трансляции адресов с учётом исходящего интерфейса. Обязательно динамические и опционально статические правила.

В зависимости от того, какой маршрут по умолчанию используется (через ISP1 или через ISP2), адреса локальной сети должны транслироваться в диапазон адресов соответствующего провайдера.

Диапазон локальных адресов 10.0.100.0/24 должен транслироваться в IP-адрес интерфейсов fa1/0 или fa2/0 соответственно.

Настройка NAT на интерфейсах:

interface FastEthernet0/0
 ip address 10.0.100.1 255.255.255.0
 ip nat inside

interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.0
 ip nat outside

interface FastEthernet2/0
 ip address 192.168.2.1 255.255.255.0
 ip nat outside

Лучше явно указывать какие сети необходимо транслировать, так как, когда выполняется мониторинг доступности провайдера, по какому-то внутреннему его ресурсу, может получиться, что ICMP-пакеты пойдут через второго провайдера и track поднимется. Соответственно поднимется и маршрут по умолчанию. А через него ресурс не доступен и track опять упадет. Так будет повторяться постоянно.

Настройка ACL, который указывает какие сети транслировать:

ip access-list extended LAN
 permit ip 10.0.100.0 0.0.0.255 any

Необходимо настроить route-map, которые будут использоваться в правилах трансляции, и указывать интерфейс через который должен выйти трафик, для того чтобы отработало правило трансляции. Маршрутизация отрабатывает до правил трансляции, поэтому, в зависимости от того какой провайдер доступен сейчас и какой основной, трафик будет маршрутизироваться, на соответствующий интерфейс. После этого отрабатывает то правило трансляции, которое соответствует исходящему интерфейсу.

Настройка route-map для правил трансляции:

route-map ISP_1 permit 10
 match ip address LAN
 match interface FastEthernet1/0

route-map ISP_2 permit 10
 match ip address LAN
 match interface FastEthernet2/0

Настройка правил динамической трансляции адресов с привязкой к исходящему интерфейсу:

ip nat inside source route-map ISP_1 interface Fa1/0 overload
ip nat inside source route-map ISP_2 interface Fa2/0 overload

Настройка статической трансляции (проброс telnet на dyn3):

ip nat inside source static tcp 10.0.100.3 23 192.168.1.10 23 route-map ISP_1
ip nat inside source static tcp 10.0.100.3 23 192.168.2.10 23 route-map ISP_2

В таком случае оба адреса должны быть настроены на DNS-сервере или пользователи должны знать, что надо пробовать обратиться на второй адрес, если первый недоступен.

[править] Настройка IP SLA для мониторинга доступности провайдера

Настроить IP SLA для проверки доступности ISP1. Тест должен периодически (каждые 3 секунды) отправлять ICMP-пакеты на IP-адрес пограничного маршрутизатора провайдера или другого ресурса в сети провайдера и ожидать ответа на них 500ms.

Тест должен быть запущен с момента настройки и работать постоянно.

ip sla 1
 icmp-echo 192.168.6.8 source-interface FastEthernet1/0
 timeout 500
 frequency 3
ip sla schedule 1 life forever start-time now

Если для проверки доступности выбран какой-то ресурс в сети провайдера, а не пограничный маршрутизатор, то необходимо прописать к нему статический маршрут:

ip route 192.168.6.8 255.255.255.255 192.168.1.5

Note-icon.gif

В реальной жизни лучше отслеживать какие-то популярные ресурсы (google, yandex и тд). В треке можно объединять несколько условий. Это позволяет избежать переключений из-за того, что конкретный ресурс недоступен. Переключение может происходить только когда все ресурсы недоступны.

[править] Привязка результатов IP SLA через track к статическим маршрутам по умолчанию

Настройка track для мониторинга доступности ISP1.

track 1 ip sla 1 reachability

Настройка в track задержки на переход в состояния UP и DOWN:

track 1 ip sla 1 reachability
 delay down 10 up 5

Создание статических маршрутов. Основной маршрут на ISP1, а в случае его недоступности, поднимается маршрут на ISP2.

ip route 0.0.0.0 0.0.0.0 192.168.1.5 track 1
ip route 0.0.0.0 0.0.0.0 192.168.2.6 250


[править] Проверка настроек. Тестирование переключения на ISP2 при недоступности ISP1

Проверка настроек при доступном ISP1. Проверка состояния track:

dyn1#sh track 1 
Track 1
  IP SLA 1 reachability
  Reachability is Up
    8 changes, last change 00:23:30
  Delay up 5 secs, down 10 secs
  Latest operation return code: OK
  Latest RTT (millisecs) 56
  Tracked by:
    STATIC-IP-ROUTING 0

Просмотр маршрутов с привязанным к ним track и его состоянием:

dyn1# sh ip route track-table 
 ip route 0.0.0.0 0.0.0.0 192.168.1.5 track 1 state is [up]

Статистика по IP SLA:

dyn1#sh ip sla statistics 
IPSLAs Latest Operation Statistics

IPSLA operation id: 1
        Latest RTT: 144 milliseconds
Latest operation start time: *08:42:03.787 UTC Fri Dec 10 2010
Latest operation return code: OK
Number of successes: 517
Number of failures: 1
Operation time to live: Forever

Таблица трансляций (запущен ping 192.168.10.11 на маршрутизаторе dyn3):

dyn1#sh ip nat translations 
Pro  Inside global  Inside local  Outside local    Outside global
icmp 192.168.1.1:7  10.0.100.3:7  192.168.10.11:7  192.168.10.11:7

Проверка настроек, если ISP1 недоступен. Лучше для этой проверки убрать IP-адрес с интерфейса маршрутизатора dyn5, а не отключать интерфейс. Проверка состояния track:

dyn1#sh track 1
Track 1
  IP SLA 1 reachability
  Reachability is Down
    33 changes, last change 00:02:33
  Latest operation return code: Timeout
  Tracked by:
    STATIC-IP-ROUTING 0

Статистика по IP SLA:

dyn1#sh ip sla statistics 
IPSLAs Latest Operation Statistics

IPSLA operation id: 1
        Latest RTT: NoConnection/Busy/Timeout
Latest operation start time: *09:46:06.787 UTC Fri Dec 10 2010
Latest operation return code: Timeout
Number of successes: 57
Number of failures: 542
Operation time to live: Forever

Таблица трансляций (запущен ping 192.168.10.11 на маршрутизаторе dyn3):

dyn1#sh ip nat translations 
Pro Inside global   Inside local  Outside local     Outside global
icmp 192.168.2.1:8  10.0.100.3:8  192.168.10.11:8   192.168.10.11:8


[править] Настройка правил для автоматической очистки таблицы трансляций

Настройка правил для автоматической очистки таблицы трансляций при переключении на другого провайдера.

Если не выполнять такую очистку, то сессии подвисают и не происходит переключения на другого провайдера. На тестах, которые были проведены с помощью ICMP этого не видно. Но, если, например, проверить TCP-сессию, то она подвиснет.

Как вариант можно занижать таймеры, которые отвечают за время жизни трансляций. Но это может привести к лишним разрывам сессий. Тут эти команды показаны для того чтобы показать как можно изменить таймеры, но такой вариант лучше не использовать.

Изменение таймеров:

ip nat translation tcp-timeout <sec>
ip nat translation udp-timeout <sec>

Для автоматической очистки таблицы трансляций при переключении на другого провайдера, необходимо использовать EEM. Он позволяет привязать к изменению состояния track действия. С помощью EEM также можно сгенерировать syslog-сообщение о том, что произошло переключение на другого провайдера.

Простейший вариант настройки:

event manager applet track_ISP 
 event track 1 state any
 action 1.0 cli command "enable"
 action 1.1 cli command "clear ip nat trans *"
 action 1.2 syslog msg "Track state is changed"

Более информативный вариант:

event manager applet ISP_1_UP 
 event track 1 state up
 action 1.0 cli command "enable"
 action 1.1 cli command "clear ip nat trans *"
 action 1.2 syslog msg "ISP 1 is UP"
event manager applet ISP_1_DOWN 
 event track 1 state down
 action 1.0 cli command "enable"
 action 1.1 cli command "clear ip nat trans *"
 action 1.2 syslog msg "ISP 1 is DOWN"

[править] Лабораторная 2. Настройка резервирования каналов в сети с одним пограничным маршрутизатором и двумя каналами к разным провайдерам. Балансировка нагрузки

Backup lab 1.png

[править] Задание

Локальная сеть подключена к двум провайдерам. Должны использоваться оба канала с распределением нагрузки между ними.


  1. Настройка IP-адресации
    Необходимо выполнить настройку IP-адресации в сети в соответствии с топологией.
    Если не указано явно, то 4 октет IP-адреса, соответствует номеру маршрутизатора.
  2. Настройка трансляции адресов с учётом исходящего интерфейса
    Настройки сохраняются с прошлой лабораторной.
  3. Настройка IP SLA для мониторинга доступности провайдеров.
    Так как теперь будут использоваться оба провайдера, то необходимо отслеживать состояние обоих провайдеров и, при недоступности одного из них, переключаться на другой.
    Настроить IP SLA для проверки доступности ISP1 и ISP2. Может быть использован тест созданный в прошлой лабораторной.
    Тест должен периодически (каждые 3 секунды) отправлять ICMP-пакеты на IP-адрес пограничного маршрутизатора соответствующего провайдера или другого ресурса в сети провайдера и ожидать ответа на них 500ms. Тест должен быть запущен с момента настройки и работать постоянно.
  4. Привязка результатов IP SLA через track к статическим маршрутам по умолчанию.
    Настроить track для мониторинга доступности маршрутов по умолчанию в обоим провайдерам.
    Создать статические маршруты так, чтобы одновременно использовались оба маршрута
  5. Настройка балансировки нагрузки между провайдерами. После каждого варианта настройки необходимо выполнить проверку
    1. Балансировка с помощью CEF.
    2. Балансировка с использованием Policy routing.
    3. Балансировка несколькими статическими маршрутами пропорционально пропускной способности.
  6. Проверка настроек.
  7. Настройка правил для автоматической очистки таблицы трансляций при переключении на другого провайдера с помощью EEM.
    Правила аналогичны прошлой лабораторной.

[править] Пошаговая настройка

[править] Настройка IP-адресации

Необходимо выполнить настройку IP-адресации в сети в соответствии с топологией. Если не указано явно, то 4 октет IP-адреса, соответствует номеру маршрутизатора.

[править] Настройка трансляции адресов с учётом исходящего интерфейса

Настройки сохраняются с прошлой лабораторной.

[править] Настройка IP SLA для мониторинга доступности провайдеров

Так как теперь будут использоваться оба провайдера, то необходимо отслеживать состояние обоих провайдеров и, при недоступности одного из них, переключаться на другой. Настроить IP SLA для проверки доступности ISP1 и ISP2. Может быть использован тест созданный в прошлой лабораторной. Тест должен периодически (каждые 3 секунды) отправлять ICMP-пакеты на IP-адрес пограничного маршрутизатора соответствующего провайдера или другого ресурса в сети провайдера и ожидать ответа на них 500ms. Тест должен быть запущен с момента настройки и работать постоянно.

ip sla 1
 icmp-echo 192.168.6.8 source-interface FastEthernet1/0
 timeout 500
 frequency 3
ip sla schedule 1 life forever start-time now

ip sla 2
 icmp-echo 192.168.7.9 source-interface FastEthernet2/0
 timeout 500
 frequency 3
ip sla schedule 2 life forever start-time now

Если для проверки доступности выбран какой-то ресурс в сети провайдера, а не пограничный маршрутизатор, то необходимо прописать к нему статический маршрут:

ip route 192.168.6.8 255.255.255.255 192.168.1.5
ip route 192.168.7.9 255.255.255.255 192.168.2.6


Note-icon.gif

В реальной жизни лучше отслеживать какие-то популярные ресурсы (google, yandex и тд). В треке можно объединять несколько условий. Это позволяет избежать переключений из-за того, что конкретный ресурс недоступен. Переключение может происходить только когда все ресурсы недоступны.

[править] Привязка результатов IP SLA через track к статическим маршрутам по умолчанию

Настроить track для мониторинга доступности маршрутов по умолчанию к обоим провайдерам.

track 1 ip sla 1 reachability
 delay down 10 up 5

track 2 ip sla 2 reachability
 delay down 10 up 5


Создать статические маршруты так, чтобы одновременно использовались оба маршрута

ip route 0.0.0.0 0.0.0.0 192.168.1.5 track 1
ip route 0.0.0.0 0.0.0.0 192.168.2.6 track 2


[править] Настройка балансировки нагрузки между провайдерами

После каждого варианта настройки необходимо выполнить проверку

[править] Балансировка с помощью CEF

По умолчанию включена балансировка per-destination (per-session). Если настроена трансляция адресов, то надо использовать этот вариант чтобы пакеты одной сессии шли по одному пути. Проверить как отрабатывает балансировка нагрузки можно командой:

show ip cef exact-route 

Проверка балансировки нагрузки:

dyn1#$xact-route 10.0.100.3 src-port 300 192.168.14.12 dest-port 20 
10.0.100.3 -> 192.168.14.12 => IP adj out of Fa2/0, addr 192.168.2.6
dyn1#$xact-route 10.0.100.3 src-port 300 192.168.14.12 dest-port 208 
10.0.100.3 -> 192.168.14.12 => IP adj out of Fa2/0, addr 192.168.2.6
dyn1#$xact-route 10.0.100.3 src-port 3080 192.168.14.12 dest-port 208 
10.0.100.3 -> 192.168.14.12 => IP adj out of Fa2/0, addr 192.168.2.6
dyn1#$xact-route 10.0.100.3 src-port 3080 192.168.14.11 dest-port 208 
10.0.100.3 -> 192.168.14.11 => IP adj out of Fa1/0, addr 192.168.1.5

Можно изменить метод балансировки так, чтобы кроме IP-адресов, учитывались и порты:

ip cef load-sharing algorithm include-ports source destination

Проверка балансировки нагрузки:

dyn1#$xact-route 10.0.100.3 src-port 3000 192.168.14.11 dest-port 80 
10.0.100.3 -> 192.168.14.11 => IP adj out of Fa2/0, addr 192.168.2.6
dyn1#$xact-route 10.0.100.3 src-port 3000 192.168.14.12 dest-port 80 
10.0.100.3 -> 192.168.14.12 => IP adj out of Fa1/0, addr 192.168.1.5
dyn1#$xact-route 10.0.100.3 src-port 3000 192.168.14.12 dest-port 20 
10.0.100.3 -> 192.168.14.12 => IP adj out of Fa2/0, addr 192.168.2.6
dyn1#$xact-route 10.0.100.3 src-port 300 192.168.14.12 dest-port 20  
10.0.100.3 -> 192.168.14.12 => IP adj out of Fa1/0, addr 192.168.1.5


[править] Балансировка с использованием Policy routing (PBR)

Если балансировка по сессиям не дает хороших результатов, можно использовать балансировку нагрузки между провайдерами, например, в зависимости от отправителя трафика.

ACL для выделения нечетных IP-адресов:

ip access-list standard odd
 permit 10.0.100.1 0.0.0.254

ACL для выделения четных IP-адресов:

ip access-list standard even
 permit 10.0.100.0 0.0.0.254

Настройка политики

route-map POLICY permit 10
 match ip address odd
 set ip next-hop verify-availability 192.168.1.5 1 track 1
route-map POLICY permit 20
 match ip address even
 set ip next-hop verify-availability 192.168.2.6 2 track 2

Применение политики:

interface FastEthernet0/0
 ip policy route-map POLICY

Просмотр настроек route-map:

dyn1# sh route-map POLICY
route-map POLICY, permit, sequence 10
  Match clauses:
    ip address (access-lists): odd 
  Set clauses:
    ip next-hop verify-availability 192.168.1.5 1 track 1  [up]
  Policy routing matches: 36 packets, 1512 bytes
route-map POLICY, permit, sequence 20
  Match clauses:
    ip address (access-lists): even 
  Set clauses:
    ip next-hop verify-availability 192.168.2.6 2 track 2  [up]
  Policy routing matches: 9 packets, 378 bytes

Просмотр информации о примененных политиках:

dyn1# sh ip policy       
Interface      Route map
Fa0/0          POLICY


[править] Балансировка несколькими статическими маршрутами пропорционально пропускной способности

Если пропускная способность каналов соотносится, например, 2:1 (ISP1:ISP2). То можно создать ещё один статический маршрут, который будет указывать на secondary адрес провайдера (если с ним договориться), на не существующий адрес (надо добавить статическую запись в ARP-кеш) или рекурсивный маршрут (указывающий на несуществующий адрес, который в свою очередь указывает на пограничный маршрутизатор провайдера). Пример с добавлением маршрута на несуществующий адрес и статическая запись в ARP:

Добавление статического маршрута:

ip route 0.0.0.0 0.0.0.0 192.168.1.15 track 1

Таблица маршрутизации:

dyn1# sh ip route 0.0.0.0 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "static", distance 1, metric 0, candidate default path
  Routing Descriptor Blocks:
  * 192.168.2.6
      Route metric is 0, traffic share count is 1
    192.168.1.15
      Route metric is 0, traffic share count is 1
    192.168.1.5
      Route metric is 0, traffic share count is 1

Статическая запись в ARP кеш (IP-указанный в статическом маршруте ставится в соответствие MAC-адресу пограничного маршрутизатора провайдера):

arp 192.168.1.15 0016.3e01.0401 arpa

Проверить как выполняется балансировка:

dyn1#sh ip cef 0.0.0.0 0.0.0.0 internal 
0.0.0.0/0, epoch 0, RIB[S], refcount 6, per-destination sharing
.........
   15 hash buckets
      < 0 > IP adj out of FastEthernet1/0, addr 192.168.1.5 66B02DE0
      < 1 > IP adj out of FastEthernet1/0, addr 192.168.1.15 687BFC80
      < 2 > IP adj out of FastEthernet2/0, addr 192.168.2.6 67AC1860
      < 3 > IP adj out of FastEthernet1/0, addr 192.168.1.5 66B02DE0
      < 4 > IP adj out of FastEthernet1/0, addr 192.168.1.15 687BFC80
      < 5 > IP adj out of FastEthernet2/0, addr 192.168.2.6 67AC1860
      < 6 > IP adj out of FastEthernet1/0, addr 192.168.1.5 66B02DE0
      < 7 > IP adj out of FastEthernet1/0, addr 192.168.1.15 687BFC80
      < 8 > IP adj out of FastEthernet2/0, addr 192.168.2.6 67AC1860
      < 9 > IP adj out of FastEthernet1/0, addr 192.168.1.5 66B02DE0
      <10 > IP adj out of FastEthernet1/0, addr 192.168.1.15 687BFC80
      <11 > IP adj out of FastEthernet2/0, addr 192.168.2.6 67AC1860
      <12 > IP adj out of FastEthernet1/0, addr 192.168.1.5 66B02DE0
      <13 > IP adj out of FastEthernet1/0, addr 192.168.1.15 687BFC80
      <14 > IP adj out of FastEthernet2/0, addr 192.168.2.6 67AC1860


[править] Проверка настроек

[править] Настройка правил для автоматической очистки таблицы трансляций

Правила аналогичны прошлой лабораторной.

[править] Лабораторная 3. Настройка резервирования каналов в сети с двумя пограничными маршрутизаторами и двумя каналами к разным провайдерам. Без балансировки нагрузки

Backup lab 2.png

[править] Задание

Локальная сеть подключена к двум провайдерам. ISP1 это основной провайдер, ISP2 используется в случае недоступности ISP1.

  1. Убрать настройки прошлой лабораторной с маршрутизаторов dyn1, dyn3. Отключить интерфейс fa2/0 маршрутизатора dyn1.
  2. Настройка IP-адресации.
    Необходимо выполнить настройку IP-адресации в сети в соответствии с топологией.
    Если не указано явно, то 4 октет IP-адреса, соответствует номеру маршрутизатора.
  3. Настройка HSRP (или другого протокола FHRP) на dyn3 и dyn4.
  4. Настройка динамической маршрутизации в локальной сети (dyn1, dyn2, dyn3, dyn4). Настроить OSPF и анонсировать все локальные сети.
  5. Настройка трансляции адресов на пограничных маршрутизаторах
  6. Настройка IP SLA для мониторинга доступности провайдеров.
    Так как теперь будут использоваться оба провайдера, то необходимо отслеживать состояние обоих провайдеров и, при недоступности одного из них, переключаться на другой.
    Настроить IP SLA для проверки доступности ISP1 и ISP2. Может быть использован тест созданный в прошлой лабораторной.
    Тест должен периодически (каждые 3 секунды) отправлять ICMP-пакеты на IP-адрес пограничного маршрутизатора соответствующего провайдера или другого ресурса в сети провайдера и ожидать ответа на них 500ms. Тест должен быть запущен с момента настройки и работать постоянно.
  7. Привязка результатов IP SLA через track к статическим маршрутам по умолчанию.
    Настроить track для мониторинга доступности машрутов по умолчанию в обоим провайдерам.
  8. Анонсировать маршрут по умолчанию с помощью OSPF.
  9. Проверить настройки.

[править] Пошаговая настройка

Убрать настройки прошлой лабораторной с маршрутизаторов dyn1, dyn3. Отключить интерфейс fa2/0 маршрутизатора dyn1.

[править] Настройка IP-адресации

Необходимо выполнить настройку IP-адресации в сети в соответствии с топологией. Если не указано явно, то 4 октет IP-адреса, соответствует номеру маршрутизатора.

[править] Настройка HSRP (или другого протокола FHRP) на dyn3 и dyn4

Настройка HSRP на dyn3:

interface FastEthernet0/0
 ip address 10.0.10.3 255.255.255.0
 standby version 2
 standby 1 ip 10.0.10.100
 standby 1 priority 110
 standby 1 preempt
 standby 1 track FastEthernet1/0 20

Настройка HSRP на dyn4:

interface FastEthernet0/0
 ip address 10.0.10.4 255.255.255.0
 standby version 2
 standby 1 ip 10.0.10.100
 standby 1 preempt


[править] Настройка динамической маршрутизации в локальной сети (dyn1, dyn2, dyn3, dyn4)

Настроить OSPF и анонсировать все локальные сети. На маршрутизаторах dyn1, dyn2, dyn3, dyn4:

router ospf 1
 network 10.0.0.0 0.0.255.255 area 0

Проверить доступность сетей.

sh ip route

[править] Настройка трансляции адресов на пограничных маршрутизаторах

Настройка NAT на dyn1:

interface FastEthernet0/0
 ip address 10.0.100.1 255.255.255.0
 ip nat inside

interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.0
 ip nat outside

Настройка NAT на dyn2:

interface FastEthernet0/0
 ip address 10.0.100.2 255.255.255.0
 ip nat inside

interface FastEthernet1/0
 ip address 192.168.3.2 255.255.255.0
 ip nat outside

Настройка ACL, который указывает для каких сетей выполнять трансляцию адресов, на dyn1 и dyn2:

ip access-list standard LAN
 permit 10.0.100.0 0.0.0.255
 permit 10.0.10.0 0.0.0.255

Правило трансляции (на dyn1 и dyn2):

ip nat inside source list LAN interface fa1/0


[править] Настройка IP SLA для мониторинга доступности провайдеров

Так как теперь будут использоваться оба провайдера, то необходимо отслеживать состояние обоих провайдеров и, при недоступности одного из них, переключаться на другой.

Настроить IP SLA для проверки доступности ISP1 и ISP2. Тест должен периодически (каждые 3 секунды) отправлять ICMP-пакеты на IP-адрес пограничного маршрутизатора соответствующего провайдера или другого ресурса в сети провайдера и ожидать ответа на них 500ms. Тест должен быть запущен с момента настройки и работать постоянно.

Проверка доступности ISP1 на dyn1:

ip sla 1
 icmp-echo 192.168.6.8 source-interface FastEthernet1/0
 timeout 500
 frequency 3
ip sla schedule 1 life forever start-time now

Так как для проверки доступности выбран ресурс в сети провайдера, а не пограничный маршрутизатор, то необходимо прописать к нему статический маршрут:

ip route 192.168.6.8 255.255.255.255 192.168.1.5

Проверка доступности ISP2 на dyn2:

ip sla 2
 icmp-echo 192.168.7.9 source-interface FastEthernet1/0
 timeout 500
 frequency 3
ip sla schedule 2 life forever start-time now

Так как для проверки доступности выбран ресурс в сети провайдера, а не пограничный маршрутизатор, то необходимо прописать к нему статический маршрут:

ip route 192.168.7.9 255.255.255.255 192.168.3.6

Проверка работы IP SLA:

dyn1# sh ip sla statistics 
IPSLAs Latest Operation Statistics

IPSLA operation id: 1
        Latest RTT: 228 milliseconds
Latest operation start time: *07:44:21.851 UTC Sun Dec 12 2010
Latest operation return code: OK
Number of successes: 80
Number of failures: 4
Operation time to live: Forever


[править] Привязка результатов IP SLA через track к статическим маршрутам по умолчанию

Настроить track для мониторинга доступности маршрутов по умолчанию в обоим провайдерам. Настройка track и привязка его к статическому маршруту на dyn1:

track 1 ip sla 1 reachability
 delay down 10 up 5
!
ip route 0.0.0.0 0.0.0.0 192.168.1.5 track 1

Настройка track и привязка его к статическому маршруту на dyn2:

track 2 ip sla 2 reachability
 delay down 10 up 5
!
ip route 0.0.0.0 0.0.0.0 192.168.3.6 track 2


[править] Анонсировать маршрут по умолчанию с помощью OSPF

Настройка анонсирования маршрута по умолчанию с помощью OSPF на dyn1:

router ospf 1
 default-information originate metric 100

Настройка анонсирования маршрута по умолчанию с помощью OSPF на dyn2. Тут метрика должна быть больше, чем метрика маршрута по умолчанию на dyn1:

router ospf 1
 default-information originate metric 200

Проверка анонсирования на dyn3:

dyn3#sh ip route                 
Gateway of last resort is 10.0.100.1 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 2 subnets
C       10.0.10.0 is directly connected, FastEthernet0/0
C       10.0.100.0 is directly connected, FastEthernet1/0
O*E2 0.0.0.0/0 [110/100] via 10.0.100.1, 00:06:25, FastEthernet1/0

[править] Проверить настройки

Если провайдер ISP1 доступен, то dyn3 и dyn4 используют маршрут по умолчанию через dyn1:

dyn3#sh ip route

Gateway of last resort is 10.0.100.1 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 2 subnets
C       10.0.10.0 is directly connected, FastEthernet0/0
C       10.0.100.0 is directly connected, FastEthernet1/0
O*E2 0.0.0.0/0 [110/100] via 10.0.100.1, 00:15:38, FastEthernet1/0

Если провайдер ISP1 недоступен, то dyn3 и dyn4 используют маршрут по умолчанию через dyn2:

dyn3#sh ip route

Gateway of last resort is 10.0.100.2 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 2 subnets
C       10.0.10.0 is directly connected, FastEthernet0/0
C       10.0.100.0 is directly connected, FastEthernet1/0
O*E2 0.0.0.0/0 [110/200] via 10.0.100.2, 00:00:12, FastEthernet1/0

[править] Лабораторная 4. Настройка резервирования каналов в сети с двумя пограничными маршрутизаторами и двумя каналами к разным провайдерам. Балансировка нагрузки

Backup lab 2.png

[править] Задание

Локальная сеть подключена к двум провайдерам. Должны использоваться оба канала с распределением нагрузки между ними.


  1. (опционально) Настройка GLBP для балансировки нагрузки между dyn3 и dyn4.
  2. Настройка балансировки нагрузки между провайдерами с помощью OSPF и CEF.
    1. Настройка маршрутов по умолчанию с одинаковой метрикой на dyn1 и dyn2.
    2. Настройка метода балансировки CEF.
    3. Проверка балансировки
  3. Балансировка нагрузки с использованием Policy routing.
  4. Балансировка нагрузки с использованием фильтрации маршрутов OSPF и статических маршрутов.
    Между dyn3 и dyn4 трафик балансируется с помощью какого-нибудь протокола FHRP. Например, если используется HSRP или VRRP, для одних подсетей в роли шлюза по умолчанию может быть dyn3, для других – dyn4.
    Если доступны оба провайдера, то dyn3 использует dyn1 как шлюз по умолчанию, а dyn4 – dyn2. При недоступности одного из провайдеров, должен использоваться другой шлюз по умолчанию.

[править] Пошаговая настройка

[править] (опционально) Настройка GLBP для балансировки нагрузки между dyn3 и dyn4

GLBP на dyn3:

interface FastEthernet0/0
 ip address 10.0.10.3 255.255.255.0
 glbp 1 ip 10.0.10.100
 glbp 1 priority 110
 glbp 1 load-balancing host-dependent

GLBP на dyn4:

interface FastEthernet0/0
 ip address 10.0.10.4 255.255.255.0
 glbp 1 ip 10.0.10.100
 glbp 1 load-balancing host-dependent


[править] Настройка балансировки нагрузки между провайдерами с помощью OSPF и CEF

[править] Настройка маршрутов по умолчанию с одинаковой метрикой на dyn1 и dyn2

Настройка анонсирования маршрута по умолчанию с помощью OSPF на dyn2 с такой же метрикой как маршрут на dyn1:

router ospf 1
 default-information originate metric 100

На dyn3 и dyn4 два маршрута по умолчанию:

dyn3#sh ip route

Gateway of last resort is 10.0.100.2 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 2 subnets
C       10.0.10.0 is directly connected, FastEthernet0/0
C       10.0.100.0 is directly connected, FastEthernet1/0
O*E2 0.0.0.0/0 [110/100] via 10.0.100.2, 00:10:17, FastEthernet1/0
               [110/100] via 10.0.100.1, 00:10:17, FastEthernet1/0
[править] Настройка метода балансировки CEF

Для данной схемы подходит балансировка по умолчанию, per-session. Просмотр балансировки на dyn3:

dyn3#sh ip cef 0.0.0.0 0.0.0.0 internal 
0.0.0.0/0, epoch 0, RIB[I], refcount 6, per-destination sharing
  sources: RIB, D/N, DRH 
  feature space:
   IPRM: 0x00038000
  subblocks:
   DefNet source: 0.0.0.0/0
  ifnums:
   FastEthernet1/0(5): 10.0.100.1, 10.0.100.2
  path 67DD62C4, path list 67CAA508, share 1/1, type attached nexthop, for IPv4
  nexthop 10.0.100.1 FastEthernet1/0, adjacency IP adj out of FastEthernet1/0, addr 10.0.100.1 66AF85E0
  path 67DD63AC, path list 67CAA508, share 1/1, type attached nexthop, for IPv4
  nexthop 10.0.100.2 FastEthernet1/0, adjacency IP adj out of FastEthernet1/0, addr 10.0.100.2 662540A0
  output chain:
    loadinfo 66ABC084, per-session, 2 choices, flags 0003, 5 locks
    flags: Per-session, for-rx-IPv4
    16 hash buckets
      < 0 > IP adj out of FastEthernet1/0, addr 10.0.100.1 66AF85E0
      < 1 > IP adj out of FastEthernet1/0, addr 10.0.100.2 662540A0
      < 2 > IP adj out of FastEthernet1/0, addr 10.0.100.1 66AF85E0
      < 3 > IP adj out of FastEthernet1/0, addr 10.0.100.2 662540A0
      < 4 > IP adj out of FastEthernet1/0, addr 10.0.100.1 66AF85E0
      < 5 > IP adj out of FastEthernet1/0, addr 10.0.100.2 662540A0
      < 6 > IP adj out of FastEthernet1/0, addr 10.0.100.1 66AF85E0
      < 7 > IP adj out of FastEthernet1/0, addr 10.0.100.2 662540A0
      < 8 > IP adj out of FastEthernet1/0, addr 10.0.100.1 66AF85E0
      < 9 > IP adj out of FastEthernet1/0, addr 10.0.100.2 662540A0
      <10 > IP adj out of FastEthernet1/0, addr 10.0.100.1 66AF85E0
      <11 > IP adj out of FastEthernet1/0, addr 10.0.100.2 662540A0
      <12 > IP adj out of FastEthernet1/0, addr 10.0.100.1 66AF85E0
      <13 > IP adj out of FastEthernet1/0, addr 10.0.100.2 662540A0
      <14 > IP adj out of FastEthernet1/0, addr 10.0.100.1 66AF85E0
      <15 > IP adj out of FastEthernet1/0, addr 10.0.100.2 662540A0
    Subblocks:
     None

Проверка балансировки CEF:

Dyn3# sh ip cef exact-route 10.0.10.8 192.168.14.14
10.0.10.8 -> 192.168.14.14 => IP adj out of Fa1/0, addr 10.0.100.1
dyn3# sh ip cef exact-route 10.0.10.8 192.168.14.11
10.0.10.8 -> 192.168.14.11 => IP adj out of Fa1/0, addr 10.0.100.1
dyn3# sh ip cef exact-route 10.0.10.8 192.168.14.12
10.0.10.8 -> 192.168.14.12 => IP adj out of Fa1/0, addr 10.0.100.1
dyn3# sh ip cef exact-route 10.0.10.8 192.168.14.16
10.0.10.8 -> 192.168.14.16 => IP adj out of Fa1/0, addr 10.0.100.2
dyn3# sh ip cef exact-route 10.0.10.8 192.168.14.20
10.0.10.8 -> 192.168.14.20 => IP adj out of Fa1/0, addr 10.0.100.2


[править] Проверка балансировки

Для проверки можно отправить с маршрутизатора dyn3 ICMP-запросы с разными адресами отправителя. На dyn1 и dyn2 проверить таблицы трансляции.

[править] Балансировка нагрузки с использованием Policy routing

Можно настроить балансировку нагрузки с использованием Policy routing. Настройки аналогичны второй лабораторной, но выполняются не на dyn1 и dyn2, а на dyn3 и dyn4.

[править] Балансировка нагрузки с использованием фильтрации маршрутов OSPF и статических маршрутов

Между dyn3 и dyn4 трафик балансируется с помощью какого-нибудь протокола FHRP. Например, если используется HSRP или VRRP, для одних подсетей в роли шлюза по умолчанию может быть dyn3, для других – dyn4.

Если доступны оба провайдера, то dyn3 использует dyn1 как шлюз по умолчанию, а dyn4 – dyn2. При недоступности одного из провайдеров, должен использоваться другой шлюз по умолчанию.

В OSPF нельзя фильтровать маршруты, так как тогда в одной зоне будут разные LSDB. Но можно отфильтровать маршрут перед помещением его в таблицу маршуртизации (в LSDB маршрут будет).

На dyn3 (в ACL указывается Router ID маршуртизатора, который анонсирует маршрут):

access-list 1 permit 192.168.1.1

route-map OSPF permit 10
 match ip route-source 1

router ospf 1
 distribute-list route-map OSPF in

Оба маршрута по умолчанию есть в LSDB:

dyn3#sh ip ospf database 

            OSPF Router with ID (10.0.100.3) (Process ID 1)

.....
                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         192.168.1.1     769         0x80000004 0x00FDE2 1
0.0.0.0         192.168.3.2     57          0x80000006 0x00E5F5 1

Но только один в таблице маршрутизации:

dyn3#sh ip route

Gateway of last resort is 10.0.100.1 to network 0.0.0.0 </pre>

    10.0.0.0/24 is subnetted, 2 subnets

C 10.0.10.0 is directly connected, FastEthernet0/0 C 10.0.100.0 is directly connected, FastEthernet1/0 O*E2 0.0.0.0/0 [110/100] via 10.0.100.1, 00:12:23, FastEthernet1/0 </pre>

Этот маршрут исчезнет, если track на dyn1 будет в состоянии DOWN. Так как маршрут через dyn2 отфильтрован, то необходимо прописать статический маршрут по умолчанию с большим значением AD (больше, чем у OSPF):

dyn3(config)# ip route 0.0.0.0 0.0.0.0 10.0.100.2 250

Аналогично на dyn4:

access-list 2 permit 192.168.3.2
!
route-map OSPF permit 10
 match ip route-source 2
!   
router ospf 1
 distribute-list route-map OSPF in

Статический маршрут на dyn4:

ip route 0.0.0.0 0.0.0.0 10.0.100.1 250

[править] Использование Xentaur

Xentaur — это средство для быстрой и удобной организации гетерогенных сетей, объединяющих виртуальные машины Xen, эмуляторы сетевых устройств, реальные хосты и сетевые устройства, а также управлениями ими и исследования их работы. Сети могут предназначаться как для решения учебных и исследовательских, так и для решения производственных задач. Подробнее о Xentaur

Работа с маршрутизаторами в Xentaur:

Действие
Комбинация клавиш
Переключение между окнами (с 1 по 9 окно)
Ctrl+a номер окна
Переключение между окнами
Ctrl+a ' номер окна
Список всех окон (по нему можно передвигаться и переключиться на другое окно): 
Ctrl+a “
Переключиться на следующее окно: 
Ctrl+a space  или
Ctrl+a n
Переключиться на предыдущее окно
Ctrl+a backspace или
Ctrl+a p
Прокрутка вверх
Ctrl+a [  
после нажатия комбинации, передвигаться можно стрелками вверх  и вниз